Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035025
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminorhave not tried2017-01-23 10:412017-04-06 17:43
ReporterSandrahuguetView Statuspublic 
Assigned Toebecerra 
PrioritynormalResolutionfixedFixed in VersionRR17Q2
StatusclosedFix in branchFixed in SCM revisione5322aa10299
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035025: Multiple and unnecessary requests to BPLocation in new business partner selector

DescriptionMultiple and unnecessary requests to BPLocation in new business partner selector. See attached screenshot.
Steps To Reproduce- Enable all high volumes preference
- Log in the WebPOS
- Open developers tools
- Tap on delete ticket, notice that there are multiple requests to BPLocation
TagsPerformance
Attached Filespng file icon multiplerequest.png [^] (234,584 bytes) 2017-01-23 10:41


diff file icon posterminal_35025.diff [^] (2,063 bytes) 2017-01-23 13:52 [Show Content]
diff file icon posterminal_35025_2.diff [^] (2,668 bytes) 2017-02-01 12:36 [Show Content]
diff file icon posterminal_35025_3.diff [^] (10,614 bytes) 2017-02-01 18:00 [Show Content]
diff file icon posterminal_35025_4.diff [^] (696 bytes) 2017-02-02 13:21 [Show Content]
diff file icon posterminal_35025_5.diff [^] (2,482 bytes) 2017-02-03 09:59 [Show Content]
diff file icon posterminal_35025_6.diff [^] (2,814 bytes) 2017-02-27 14:36 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0035719RR17Q1.1 closedjorge-garcia Multiple and unnecessary requests to BPLocation in new business partner selector 
related to defect 0035108 newRetail [RR17Q1][StoreServer][HighVol] It is possible to add products to a receipt different to the right one 
related to defect 0035109 scheduledmigueldejuana [RR17Q1][StoreServer][HighVol] Adding products to the receipt is too slow 

-  Notes
(0093836)
hgbot (developer)
2017-01-26 11:00

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 0de1e8153ab54ea3a85966843aa178717edf1107
Author: Eduardo Becerra <ebec70 <at> yahoo.com>
Date: Thu Jan 26 11:00:02 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0de1e8153ab54ea3a85966843aa178717edf1107 [^]

Fixed issue 35025: Optmize call to get BPLocation

---
M web/org.openbravo.retail.posterminal/js/components/modalreceiptproperties.js
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0093870)
ebecerra (developer)
2017-01-27 10:28

The multiples request to BPLocation was solved and now only two call to backend are done when a new ticket is created.

* Showing address shipping and invoice buttons in receipt panel (js/components/bplocation.js -> OB.UI.BPLocationShip.buttonShowing)

* Showing address shipping and invoice buttons receipt properties dialog (js/components/modalreceiptproperties.js -> OB.UI.ModalReceiptPropertiesImpl.init on model "change" event)
(0093953)
marvintm (developer)
2017-01-31 08:51

It's ok to do a request to bplocation to find out if two buttons need to be shown. However, these requests shouldn't happen every time a new ticket is created, they should happen only once, when terminal is loaded for the first time.
(0094109)
hgbot (developer)
2017-02-07 09:30

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 90c74c3d4836ea5c760aae880079bf1e6b24c31a
Author: Eduardo Becerra <ebec70 <at> yahoo.com>
Date: Mon Feb 06 12:14:23 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/90c74c3d4836ea5c760aae880079bf1e6b24c31a [^]

Fixed issue 35025: Optmize call to get BPLocation (v2)

---
M web/org.openbravo.retail.posterminal/js/components/bplocation.js
M web/org.openbravo.retail.posterminal/js/components/businesspartner_selector.js
M web/org.openbravo.retail.posterminal/js/components/modalreceiptproperties.js
M web/org.openbravo.retail.posterminal/js/model/businesspartner.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
---
(0094220)
marvintm (developer)
2017-02-10 14:43

Now there is a flow which is not working correctly:

- In VBS Customer, I create an address just for shipping and assign it to the ticket, and then another just for invoicing, and assign it to the ticket
- Before, two buttons would appear. However, now, only one button appears, and this is not correct.

Problem seems to be this line:

OB.MobileApp.model.get('businessPartner').locations

which should be this instead:

 OB.MobileApp.model.get('businessPartner').get('locations')
(0094830)
hgbot (developer)
2017-03-08 12:58

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e5322aa10299b508f8845f2cb435b3fe7f27266e
Author: Eduardo Becerra <ebec70 <at> yahoo.com>
Date: Wed Mar 08 12:57:33 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e5322aa10299b508f8845f2cb435b3fe7f27266e [^]

Fixed issue 35025: Update default BP locations cache when edit address

---
M web/org.openbravo.retail.posterminal/js/components/bplocation.js
M web/org.openbravo.retail.posterminal/js/data/datacustomeraddrsave.js
---

- Issue History
Date Modified Username Field Change
2017-01-23 10:41 Sandrahuguet New Issue
2017-01-23 10:41 Sandrahuguet Assigned To => ebecerra
2017-01-23 10:41 Sandrahuguet File Added: multiplerequest.png
2017-01-23 10:41 Sandrahuguet Triggers an Emergency Pack => No
2017-01-23 13:35 Sandrahuguet Tag Attached: Performance
2017-01-23 13:52 ebecerra File Added: posterminal_35025.diff
2017-01-26 11:00 hgbot Checkin
2017-01-26 11:00 hgbot Note Added: 0093836
2017-01-26 11:00 hgbot Status new => resolved
2017-01-26 11:00 hgbot Resolution open => fixed
2017-01-26 11:00 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0de1e8153ab54ea3a85966843aa178717edf1107 [^]
2017-01-26 15:39 Sandrahuguet Review Assigned To => marvintm
2017-01-27 10:28 ebecerra Note Added: 0093870
2017-01-31 08:51 marvintm Note Added: 0093953
2017-01-31 08:51 marvintm Status resolved => new
2017-01-31 08:51 marvintm Resolution fixed => open
2017-02-01 11:20 jorge-garcia Relationship added related to 0035108
2017-02-01 12:36 ebecerra File Added: posterminal_35025_2.diff
2017-02-01 18:00 ebecerra File Added: posterminal_35025_3.diff
2017-02-02 13:21 ebecerra File Added: posterminal_35025_4.diff
2017-02-03 09:59 ebecerra File Added: posterminal_35025_5.diff
2017-02-07 09:30 hgbot Checkin
2017-02-07 09:30 hgbot Note Added: 0094109
2017-02-07 09:30 hgbot Status new => resolved
2017-02-07 09:30 hgbot Resolution open => fixed
2017-02-07 09:30 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/0de1e8153ab54ea3a85966843aa178717edf1107 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/90c74c3d4836ea5c760aae880079bf1e6b24c31a [^]
2017-02-10 14:43 marvintm Note Added: 0094220
2017-02-10 14:43 marvintm Status resolved => new
2017-02-10 14:43 marvintm Resolution fixed => open
2017-02-16 18:15 aaroncalero Note View State: private: 93953
2017-02-17 09:38 aaroncalero Note View State: public: 93953
2017-02-23 09:47 ebecerra File Added: posterminal_35025_6.diff
2017-02-27 12:42 jonibc Issue Monitored: jonibc
2017-02-27 14:36 ebecerra File Deleted: posterminal_35025_6.diff
2017-02-27 14:36 ebecerra File Added: posterminal_35025_6.diff
2017-03-08 12:58 hgbot Checkin
2017-03-08 12:58 hgbot Note Added: 0094830
2017-03-08 12:58 hgbot Status new => resolved
2017-03-08 12:58 hgbot Resolution open => fixed
2017-03-08 12:58 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/90c74c3d4836ea5c760aae880079bf1e6b24c31a [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e5322aa10299b508f8845f2cb435b3fe7f27266e [^]
2017-03-09 17:25 marvintm Status resolved => closed
2017-03-09 17:25 marvintm Fixed in Version => RR17Q2
2017-03-17 09:30 Sandrahuguet Relationship added related to 0035109
2017-04-06 17:43 marvintm Status closed => new
2017-04-06 17:43 marvintm Resolution fixed => open
2017-04-06 17:43 marvintm Fixed in Version RR17Q2 =>
2017-04-06 17:43 marvintm Status new => scheduled
2017-04-06 17:43 marvintm Status scheduled => resolved
2017-04-06 17:43 marvintm Fixed in Version => RR17Q2
2017-04-06 17:43 marvintm Resolution open => fixed
2017-04-06 17:43 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker