Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034998
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajorhave not tried2017-01-18 12:552017-01-20 08:12
ReporterinigosanchezView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revision58c2343eab31
ProjectionnoneETAnoneTarget Version3.0PR17Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2016-12-20
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/33acb5a389843bb26358ea747e92383505608b56 [^]
Triggers an Emergency PackNo
Summary

0034998: All platform buildvalidations should be reviewed

DescriptionAll platform buildvalidations should be reviewed in order to check if they have to be updated their execution limits. The problems found are:
- CheckUpdateConnectionPoolMerge: Execution limit should be defined between [null, 3.0.27659].
- DatabaseDecimalNumberCheck: Should't have any execution limit because it should be executed allways.
- DatabaseVersionCheck: Should't have any execution limit because it should be executed allways.
- DuplicatedJavaPackage: Limit is defined properly.
- JdkVersionCheck: Should't have any execution limit because it should be executed allways.
- PreferenceConflict: Limit is defined properly.
- RemoveCostingRuleProcessExecutions: Execution limit should be defined between [null, 3.0.25161].
Steps To Reproduce-
Proposed SolutionSee spreadsheet for more information: https://docs.google.com/a/openbravo.com/spreadsheets/d/1oEnWQy1-wrOREHxDy1b3Ar5jL9v4cVZ-TEI1IQiRZik/edit?usp=sharing [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0034994 closedinigosanchez All platform buildvalidations should be reviewed 

-  Notes
(0093711)
hgbot (developer)
2017-01-18 17:38

Repository: erp/backports/3.0PR17Q1
Changeset: 58c2343eab31965363b2112fb18890ef1ba1a88e
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Jan 18 16:47:36 2017 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR17Q1/rev/58c2343eab31965363b2112fb18890ef1ba1a88e [^]

Fixed issue 34998: Limits of buildvalidations haven't defined properly.

Some of the execution limits of platform buildvalidations haven't defined properly. Now the problem have
been resolved by updating the following buildvalidations:

- CheckUpdateConnectionPoolMerge: Execution limit should be defined between [null, 3.0.27659].
- DatabaseDecimalNumberCheck: Should't have any execution limit because it should be executed allways.
- DatabaseVersionCheck: Should't have any execution limit because it should be executed allways.
- JdkVersionCheck: Should't have any execution limit because it should be executed allways.
- RemoveCostingRuleProcessExecutions: Execution limit should be defined between [null, 3.0.25161].

---
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/CheckUpdateConnectionPoolMerge.class
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/DatabaseDecimalNumberCheck.class
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/DatabaseVersionCheck.class
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/JdkVersionCheck.class
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/RemoveCostingRuleProcessExecutions.class
M src-util/buildvalidation/src/org/openbravo/buildvalidation/CheckUpdateConnectionPoolMerge.java
M src-util/buildvalidation/src/org/openbravo/buildvalidation/DatabaseDecimalNumberCheck.java
M src-util/buildvalidation/src/org/openbravo/buildvalidation/DatabaseVersionCheck.java
M src-util/buildvalidation/src/org/openbravo/buildvalidation/JdkVersionCheck.java
M src-util/buildvalidation/src/org/openbravo/buildvalidation/RemoveCostingRuleProcessExecutions.java
---
(0093744)
alostale (developer)
2017-01-20 08:12

reviewed

- Issue History
Date Modified Username Field Change
2017-01-18 15:31 inigosanchez Type defect => backport
2017-01-18 15:31 inigosanchez Target Version => 3.0PR17Q1
2017-01-18 17:38 hgbot Checkin
2017-01-18 17:38 hgbot Note Added: 0093711
2017-01-18 17:38 hgbot Status scheduled => resolved
2017-01-18 17:38 hgbot Resolution open => fixed
2017-01-18 17:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q1/rev/58c2343eab31965363b2112fb18890ef1ba1a88e [^]
2017-01-18 17:39 inigosanchez Review Assigned To => alostale
2017-01-20 08:12 alostale Note Added: 0093744
2017-01-20 08:12 alostale Status resolved => closed
2017-01-20 08:12 alostale Fixed in Version => 3.0PR17Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker