Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034994
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2017-01-18 12:552017-03-15 20:18
ReporterinigosanchezView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision337b0d3cd176
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2016-12-20
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/33acb5a389843bb26358ea747e92383505608b56 [^]
Triggers an Emergency PackNo
Summary

0034994: All platform buildvalidations should be reviewed

DescriptionAll platform buildvalidations should be reviewed in order to check if they have to be updated their execution limits. The problems found are:
- CheckUpdateConnectionPoolMerge: Execution limit should be defined between [null, 3.0.27659].
- DatabaseDecimalNumberCheck: Should't have any execution limit because it should be executed allways.
- DatabaseVersionCheck: Should't have any execution limit because it should be executed allways.
- DuplicatedJavaPackage: Limit is defined properly.
- JdkVersionCheck: Should't have any execution limit because it should be executed allways.
- PreferenceConflict: Limit is defined properly.
- RemoveCostingRuleProcessExecutions: Execution limit should be defined between [null, 3.0.25161].
Steps To Reproduce-
Proposed SolutionSee spreadsheet for more information: https://docs.google.com/a/openbravo.com/spreadsheets/d/1oEnWQy1-wrOREHxDy1b3Ar5jL9v4cVZ-TEI1IQiRZik/edit?usp=sharing [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0030515 closedinigosanchez Add ability to determine if build validations should be executed depending on a particular module version 
depends on backport 00349983.0PR17Q1 closedinigosanchez All platform buildvalidations should be reviewed 
caused by defect 0034718 closedSanjota Review buildvalidation performance 

-  Notes
(0093703)
hgbot (developer)
2017-01-18 16:49

Repository: erp/devel/pi
Changeset: 337b0d3cd176d044c6473522e924c5bc463739f5
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Jan 18 15:50:27 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/337b0d3cd176d044c6473522e924c5bc463739f5 [^]

Fixed issue 34994: Limits of buildvalidations haven't defined properly.

Some of the execution limits of platform buildvalidations haven't defined properly. Now the problem have
been resolved by updating the following buildvalidations:

- CheckUpdateConnectionPoolMerge: Execution limit should be defined between [null, 3.0.27659].
- DatabaseDecimalNumberCheck: Should't have any execution limit because it should be executed allways.
- DatabaseVersionCheck: Should't have any execution limit because it should be executed allways.
- JdkVersionCheck: Should't have any execution limit because it should be executed allways.
- RemoveCostingRuleProcessExecutions: Execution limit should be defined between [null, 3.0.25161].

---
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/CheckUpdateConnectionPoolMerge.class
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/DatabaseDecimalNumberCheck.class
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/DatabaseVersionCheck.class
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/JdkVersionCheck.class
M src-util/buildvalidation/build/classes/org/openbravo/buildvalidation/RemoveCostingRuleProcessExecutions.class
M src-util/buildvalidation/src/org/openbravo/buildvalidation/CheckUpdateConnectionPoolMerge.java
M src-util/buildvalidation/src/org/openbravo/buildvalidation/DatabaseDecimalNumberCheck.java
M src-util/buildvalidation/src/org/openbravo/buildvalidation/DatabaseVersionCheck.java
M src-util/buildvalidation/src/org/openbravo/buildvalidation/JdkVersionCheck.java
M src-util/buildvalidation/src/org/openbravo/buildvalidation/RemoveCostingRuleProcessExecutions.java
---
(0093743)
alostale (developer)
2017-01-20 08:12

reviewed
(0095108)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-01-18 12:55 inigosanchez New Issue
2017-01-18 12:55 inigosanchez Assigned To => inigosanchez
2017-01-18 12:55 inigosanchez Modules => Core
2017-01-18 12:55 inigosanchez Triggers an Emergency Pack => No
2017-01-18 13:00 inigosanchez Regression date => 2016-12-20
2017-01-18 13:00 inigosanchez Regression introduced in release => pi
2017-01-18 13:00 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/33acb5a389843bb26358ea747e92383505608b56 [^]
2017-01-18 13:02 inigosanchez Relationship added caused by 0034718
2017-01-18 13:03 inigosanchez Relationship added related to 0030515
2017-01-18 13:08 inigosanchez Regression level => Pre packaging ( pi )
2017-01-18 14:44 inigosanchez Description Updated View Revisions
2017-01-18 14:45 inigosanchez Description Updated View Revisions
2017-01-18 15:31 inigosanchez Status new => scheduled
2017-01-18 16:49 hgbot Checkin
2017-01-18 16:49 hgbot Note Added: 0093703
2017-01-18 16:49 hgbot Status scheduled => resolved
2017-01-18 16:49 hgbot Resolution open => fixed
2017-01-18 16:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/337b0d3cd176d044c6473522e924c5bc463739f5 [^]
2017-01-18 16:50 inigosanchez Review Assigned To => alostale
2017-01-20 08:12 alostale Note Added: 0093743
2017-01-20 08:12 alostale Status resolved => closed
2017-01-20 08:12 alostale Fixed in Version => 3.0PR17Q2
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095108


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker