Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034891
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2017-01-09 11:022017-01-13 12:56
ReporterumartirenaView Statuspublic 
Assigned ToNaroaIriarte 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revisioncf927f9233ea
ProjectionnoneETAnoneTarget Version3.0PR17Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in release3.0PR16Q2
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/afa165be3e5900d1114d33e5106114d0e089876a [^]
Triggers an Emergency PackNo
Summary

0034891: Ordering in GL Item grid in Add Payment process definition does not work. It deletes the lines.

DescriptionOrdering in GL Item grid in Add Payment process definition does not work. It deletes the lines.
Steps To ReproduceIn live builds:
 * Go to "Payment In" window.
 * Create a new record.
 * Click on "Add Details" button.
 * In GL Items section click on "Add New".
 * Add a GL Item and save the record.
 * Sort by GL Item.
 * The previous record disappears.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0034864 closedNaroaIriarte Ordering in GL Item grid in Add Payment process definition does not work. It deletes the lines. 

-  Notes
(0093365)
hgbot (developer)
2017-01-11 16:06

Repository: erp/backports/3.0PR17Q1
Changeset: cf927f9233ea7e693f2926a22b0ff927922a3767
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Wed Jan 11 16:00:39 2017 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR17Q1/rev/cf927f9233ea7e693f2926a22b0ff927922a3767 [^]

Fixed issue 34891: The GL item section of add payment was not working fine

The grid of the G/L item section of the Add payment process was not workinf fine. The problem was that it was shown as sortable and as filterable and it must not be filterable nor sortable. This has been caused by the changeset[1]. This proyect set every column as sortable and as filterable and so was the problem.
To fix this the values of "canSort" and "canFilter" have been changed in the needed cases, which are the ones that satisfy the condition of having the canDelete property or the canAdd property set to yes and are in Pick and Execute window.
The code which handles the logic has been moved from the OBViewFieldHandler.getGridFieldProperties() to UIDefinition.getGridFieldProperties().

[1]http://code.openbravo.com/erp/devel/pi/rev/afa165be3e5900d1114d33e5106114d0e089876a [^]

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewFieldHandler.java
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/reference/UIDefinition.java
---
(0093520)
alostale (developer)
2017-01-13 12:56

code reviewed

tested:
- It's not possible to filter nor sort in P&E grids that allow adding or removing records
- The rest of grids continue allowing filtering sorting by default
- It's possible to overwrite this behavior through grid configuration

- Issue History
Date Modified Username Field Change
2017-01-10 12:56 NaroaIriarte Type defect => backport
2017-01-10 12:56 NaroaIriarte Target Version => 3.0PR17Q1
2017-01-11 16:06 hgbot Checkin
2017-01-11 16:06 hgbot Note Added: 0093365
2017-01-11 16:06 hgbot Status scheduled => resolved
2017-01-11 16:06 hgbot Resolution open => fixed
2017-01-11 16:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q1/rev/cf927f9233ea7e693f2926a22b0ff927922a3767 [^]
2017-01-13 12:56 alostale Note Added: 0093520
2017-01-13 12:56 alostale Status resolved => closed
2017-01-13 12:56 alostale Fixed in Version => 3.0PR17Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker