Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034864
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-01-09 11:022017-03-15 20:18
ReporterumartirenaView Statuspublic 
Assigned ToNaroaIriarte 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revisiond1fba62ec656
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date
Regression introduced in release3.0PR16Q2
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/afa165be3e5900d1114d33e5106114d0e089876a [^]
Triggers an Emergency PackNo
Summary

0034864: Ordering in GL Item grid in Add Payment process definition does not work. It deletes the lines.

DescriptionOrdering in GL Item grid in Add Payment process definition does not work. It deletes the lines.
Steps To ReproduceIn live builds:
 * Go to "Payment In" window.
 * Create a new record.
 * Click on "Add Details" button.
 * In GL Items section click on "Add New".
 * Add a GL Item and save the record.
 * Sort by GL Item.
 * The previous record disappears.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00348913.0PR17Q1 closedNaroaIriarte Ordering in GL Item grid in Add Payment process definition does not work. It deletes the lines. 
depends on backport 00348923.0PR16Q4.1 closedNaroaIriarte Ordering in GL Item grid in Add Payment process definition does not work. It deletes the lines. 
depends on backport 00348933.0PR16Q3.4 closedNaroaIriarte Ordering in GL Item grid in Add Payment process definition does not work. It deletes the lines. 
caused by feature request 0031468 closedNaroaIriarte It would be nice to prevent sorting and filtering some columns. 

-  Notes
(0093366)
hgbot (developer)
2017-01-11 16:07

Repository: erp/devel/pi
Changeset: d1fba62ec6569659b96e367d70dc9d8caa437ff9
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Wed Jan 11 16:03:20 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d1fba62ec6569659b96e367d70dc9d8caa437ff9 [^]

Fixed issue 34864: The GL item section of add payment was not working fine

The grid of the G/L item section of the Add payment process was not workinf fine. The problem was that it was shown as sortable and as filterable and it must not be filterable nor sortable. This has been caused by the changeset[1]. This proyect set every column as sortable and as filterable and so was the problem.
To fix this the values of "canSort" and "canFilter" have been changed in the needed cases, which are the ones that satisfy the condition of having the canDelete property or the canAdd property set to yes and are in Pick and Execute window.
The code which handles the logic has been moved from the OBViewFieldHandler.getGridFieldProperties() to UIDefinition.getGridFieldProperties().

[1]http://code.openbravo.com/erp/devel/pi/rev/afa165be3e5900d1114d33e5106114d0e089876a [^]

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewFieldHandler.java
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/reference/UIDefinition.java
---
(0093519)
alostale (developer)
2017-01-13 12:55

code reviewed

tested:
- It's not possible to filter nor sort in P&E grids that allow adding or removing records
- The rest of grids continue allowing filtering sorting by default
- It's possible to overwrite this behavior through grid configuration
(0095087)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-01-09 11:02 umartirena New Issue
2017-01-09 11:02 umartirena Assigned To => platform
2017-01-09 11:02 umartirena Modules => Core
2017-01-09 11:02 umartirena Triggers an Emergency Pack => No
2017-01-09 11:02 umartirena Steps to Reproduce Updated View Revisions
2017-01-09 12:56 NaroaIriarte Assigned To platform => NaroaIriarte
2017-01-09 13:04 NaroaIriarte Status new => acknowledged
2017-01-09 15:40 NaroaIriarte Severity major => minor
2017-01-10 09:26 NaroaIriarte Review Assigned To => alostale
2017-01-10 09:26 NaroaIriarte Regression introduced in release => 3.0PR16Q2
2017-01-10 09:26 NaroaIriarte Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/afa165be3e5900d1114d33e5106114d0e089876a [^]
2017-01-10 09:26 NaroaIriarte Priority normal => immediate
2017-01-10 09:26 NaroaIriarte Status acknowledged => scheduled
2017-01-10 09:26 NaroaIriarte Relationship added caused by 0031468
2017-01-10 09:50 NaroaIriarte Regression level => Production - Confirmed Stable
2017-01-10 12:52 NaroaIriarte Status scheduled => acknowledged
2017-01-10 12:56 NaroaIriarte Status acknowledged => scheduled
2017-01-11 16:07 hgbot Checkin
2017-01-11 16:07 hgbot Note Added: 0093366
2017-01-11 16:07 hgbot Status scheduled => resolved
2017-01-11 16:07 hgbot Resolution open => fixed
2017-01-11 16:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d1fba62ec6569659b96e367d70dc9d8caa437ff9 [^]
2017-01-13 12:55 alostale Note Added: 0093519
2017-01-13 12:55 alostale Status resolved => closed
2017-01-13 12:55 alostale Fixed in Version => 3.0PR17Q2
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095087


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker