Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034882
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminorhave not tried2017-01-10 10:232017-03-15 20:18
ReporteralostaleView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision4e2349d8c98e
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034882: Incorrect styling in Chrome 56

DescriptionChrome 56 (in beta phase when reporting this issue) displays some elements slightly wrong.

This seems to be a bug in SmartClient, therefore, the following issue has been raised in their forum: http://forums.smartclient.com/forum/technical-q-a/242200-incorrect-styling-in-chrome-56 [^]
Steps To ReproduceSee attached images comparing visualization in Chromium 55.0.2883.87 (Correct) with Chrome 56.0.2924.51 beta (Incorrect). For these cases:

A. Widgets:
A.1 Login and check widgets in workspace

B. Log out confirmation popup:
B.1 Click on the End Session button

C. Popup titles:
C.1 Open Sales Order window
C.2 Select a record
C.3 Click on add payment button: check popup's title bar
TagsNo tags attached.
Attached Filespng file icon widgets_55..png [^] (41,683 bytes) 2017-01-10 10:24


png file icon widgets_56.png [^] (125,482 bytes) 2017-01-10 10:24


png file icon logout_55.png [^] (12,523 bytes) 2017-01-10 10:24


png file icon logout_56.png [^] (12,585 bytes) 2017-01-10 10:24


png file icon popup_title_55.png [^] (4,318 bytes) 2017-01-10 10:25


png file icon popup_title_56.png [^] (4,199 bytes) 2017-01-10 10:25

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0030534 closedcaristu Some pop-ups are not displayed properly on Microsoft Edge 
depends on backport 00350263.0PR17Q1 closedcaristu Incorrect styling in Chrome 56 
depends on backport 00350273.0PR16Q4.2 closedcaristu Incorrect styling in Chrome 56 
depends on backport 00350283.0PR16Q3.5 closedcaristu Incorrect styling in Chrome 56 
related to design defect 0038413 acknowledgedplatform [RR18Q2] Incorrect styling in Safari 11.3 (15E216) 

-  Notes
(0093681)
alostale (developer)
2017-01-18 10:34

Reported also to chrome: https://bugs.chromium.org/p/chromium/issues/detail?id=682166 [^]
(0093770)
hgbot (developer)
2017-01-23 11:49

Repository: erp/mods/org.openbravo.userinterface.smartclient.dev
Changeset: 85cb7b141f55d4a2d2a8784bc4c2bba379c2070c
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jan 23 11:48:52 2017 +0100
URL: http://code.openbravo.com/erp/mods/org.openbravo.userinterface.smartclient.dev/rev/85cb7b141f55d4a2d2a8784bc4c2bba379c2070c [^]

related to issue 34882: Incorrect styling in Chrome 56

---
M web/org.openbravo.userinterface.smartclient/isomorphic/client/widgets/EdgedCanvas.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/development/ISC_Core.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/modules-debug/ISC_Core.js
M web/org.openbravo.userinterface.smartclient/isomorphic/system/modules/ISC_Core.js
---
(0093771)
hgbot (developer)
2017-01-23 11:52

Repository: erp/devel/pi
Changeset: 4e2349d8c98e22ce097b3baeda11aeb23a78bbca
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Jan 23 11:51:24 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4e2349d8c98e22ce097b3baeda11aeb23a78bbca [^]

fixes issue 34882: Incorrect styling in Chrome 56

---
M modules/org.openbravo.userinterface.smartclient/web/org.openbravo.userinterface.smartclient/isomorphic/ISC_Combined.js
---
(0093774)
alostale (developer)
2017-01-23 12:58

Code reviewed: checked also the only change in ISC_Combined.js is the intended one.

Tested (in all cases with smartclient.dev module in develompent and not in development).

* Chromium stable Version 55.0.2883.87 Built on Ubuntu , running on Ubuntu 16.04 (64-bit)
* Google Chrome Version 56.0.2924.67 beta (64-bit)
* Google Chrome Version 57.0.2986.0 dev (64-bit)
* Firefox 45.6.0
* Edge 20
* IE 11
(0095115)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-01-10 10:23 alostale New Issue
2017-01-10 10:23 alostale Assigned To => platform
2017-01-10 10:23 alostale Web browser => Google Chrome
2017-01-10 10:23 alostale Modules => Core
2017-01-10 10:23 alostale Triggers an Emergency Pack => No
2017-01-10 10:24 alostale File Added: widgets_55..png
2017-01-10 10:24 alostale File Added: widgets_56.png
2017-01-10 10:24 alostale File Added: logout_55.png
2017-01-10 10:24 alostale File Added: logout_56.png
2017-01-10 10:25 alostale File Added: popup_title_55.png
2017-01-10 10:25 alostale File Added: popup_title_56.png
2017-01-10 12:37 caristu Relationship added related to 0030534
2017-01-11 09:10 alostale Status new => acknowledged
2017-01-11 17:55 caristu Web browser Google Chrome => Google Chrome
2017-01-11 17:55 caristu Description Updated View Revisions
2017-01-18 10:34 alostale Note Added: 0093681
2017-01-23 10:49 alostale Status acknowledged => scheduled
2017-01-23 10:49 alostale Assigned To platform => caristu
2017-01-23 11:19 Orekaria Issue Monitored: Orekaria
2017-01-23 11:49 hgbot Checkin
2017-01-23 11:49 hgbot Note Added: 0093770
2017-01-23 11:52 hgbot Checkin
2017-01-23 11:52 hgbot Note Added: 0093771
2017-01-23 11:52 hgbot Status scheduled => resolved
2017-01-23 11:52 hgbot Resolution open => fixed
2017-01-23 11:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4e2349d8c98e22ce097b3baeda11aeb23a78bbca [^]
2017-01-23 12:35 caristu Review Assigned To => alostale
2017-01-23 12:35 caristu Web browser Google Chrome => Google Chrome
2017-01-23 12:58 alostale Note Added: 0093774
2017-01-23 12:58 alostale Status resolved => closed
2017-01-23 12:58 alostale Fixed in Version => 3.0PR17Q2
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095115
2018-04-19 12:56 lorenzofidalgo Relationship added related to 0038413


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker