Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034846
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorsometimes2017-01-03 17:062017-01-16 12:42
Reporterjorge-garciaView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in VersionRR17Q2
StatusclosedFix in branchFixed in SCM revisionb3cf9ddc2aa3
ProjectionnoneETAnoneTarget Versionpi
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelPre packaging ( pi )
Regression date2016-12-14
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8435373ee62da7f6c0d667ba227e1e37c10f87e9 [^]
Triggers an Emergency PackNo
Summary

0034846: Scanning could not work if the model has change but cache is not deleted

DescriptionWhen we use findUsingCache, the result of the search is cached in memory.

This is working fine until a new incremental refresh is done and the model of Product has change (for example, changing the UPC/EAN code associated). If the cache is not deleted, the result returned will not change.
Steps To Reproduce1) Go to backend and add/change the UPC/EAN code
2) Clean the cache of the browser and log in the webpos
3) Scan that UPC/EAN code and check the product is added to the receipt.
4) Clean this receipt
5) Go again to backend, and change the UPC/EAN code of that product again
6) Wait until the incremental refresh is done (don't do a browser refresh nor clean the cache).
7) Scan the new UPC/EAN code and check no products is added.
Proposed SolutionIn OB.DAL.findUsingCache from 'productSearch' and 'productPrice' should have a parameter after the error callback like this

{modelsAffectedByCache: ['Product']} --> This is for 'productSearch' part.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0034887RR17Q1 closedjorge-garcia Scanning could not work if the model has change but cache is not deleted 
depends on backport 0034888RR16Q4.1 closedjorge-garcia Scanning could not work if the model has change but cache is not deleted 
caused by defect 0032365 closedjorge-garcia Scanning with external barcode scanner performance can be improved 
related to defect 0034868 closedjorge-garcia Find using cache does not work if high volumes is deactivate 
related to defect 0034965 closedranjith_qualiantech_com OB-Dal query caching is not properly handled in some external modules 

-  Notes
(0093304)
jorge-garcia (developer)
2017-01-10 12:10

Create backports for 17Q1 and 16Q4.1
(0093321)
hgbot (developer)
2017-01-11 09:17

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: b3cf9ddc2aa3836d1666351387ee6abbac33ce3e
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Mon Jan 09 12:07:43 2017 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b3cf9ddc2aa3836d1666351387ee6abbac33ce3e [^]

Fixed issue 34846: Scanning could not work if the model has change but
cache is not deleted

Added logic to manage find models using cache for these models:
* Find product.
* Find product price.
* Find product service.

---
M web/org.openbravo.retail.posterminal/js/model/order.js
M web/org.openbravo.retail.posterminal/js/pointofsale/view/keyboardorder.js
---

- Issue History
Date Modified Username Field Change
2017-01-03 17:06 jorge-garcia New Issue
2017-01-03 17:06 jorge-garcia Assigned To => Retail
2017-01-03 17:06 jorge-garcia Regression level => Pre packaging ( pi )
2017-01-03 17:06 jorge-garcia Regression date => 2016-12-14
2017-01-03 17:06 jorge-garcia Regression introduced in release => main
2017-01-03 17:06 jorge-garcia Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8435373ee62da7f6c0d667ba227e1e37c10f87e9 [^]
2017-01-03 17:06 jorge-garcia Triggers an Emergency Pack => No
2017-01-03 17:07 jorge-garcia Relationship added caused by 0032365
2017-01-09 12:05 jorge-garcia Status new => scheduled
2017-01-09 12:05 jorge-garcia Assigned To Retail => jorge-garcia
2017-01-09 13:57 jorge-garcia Relationship added related to 0034868
2017-01-10 12:10 jorge-garcia Status scheduled => resolved
2017-01-10 12:10 jorge-garcia Resolution open => fixed
2017-01-10 12:10 jorge-garcia Note Added: 0093304
2017-01-10 12:10 jorge-garcia Status resolved => new
2017-01-10 12:10 jorge-garcia Resolution fixed => open
2017-01-10 12:10 jorge-garcia Status new => scheduled
2017-01-11 09:17 hgbot Checkin
2017-01-11 09:17 hgbot Note Added: 0093321
2017-01-11 09:17 hgbot Status scheduled => resolved
2017-01-11 09:17 hgbot Resolution open => fixed
2017-01-11 09:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b3cf9ddc2aa3836d1666351387ee6abbac33ce3e [^]
2017-01-16 12:42 marvintm Relationship added related to 0034965
2017-01-16 12:42 marvintm Review Assigned To => marvintm
2017-01-16 12:42 marvintm Status resolved => closed
2017-01-16 12:42 marvintm Fixed in Version => RR17Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker