Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034829
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 01. General setupmajoralways2016-12-23 19:272016-12-30 13:45
ReporterrbianchiniView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q4.1
StatusclosedFix in branchFixed in SCM revision801e5057180c
ProjectionnoneETAnoneTarget Version3.0PR16Q4.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR16Q3.3SCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-04-28
Regression introduced in release3.0PR16Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/e8c0df5664deca28ef28bc90ef088d6ec532043c [^]
Triggers an Emergency PackNo
Summary

0034829: Can't add lines in Requisition with role F&B España, S.A - Employee

DescriptionIf you log in ERP Version < 16Q3, and switch role to F&B España, S.A - Employee, you are able to create Requisition and Requisition's lines.
If you log in ERP Version > 16Q3, and switch role to F&B España, S.A - Employee, you are able to create Requisition but Requisition's lines, the products are not listed.
Adding access to the tables m_product* to the role doesn't solve the problem.
You have to add permissions to product window in order to solve the problem.
With this configuration, a new menu entry <product> is shown, but the product window is not accesible becouse permissions (Error
With your current role and settings, you cannot view this information)
Steps To Reproduce1 - Log in livebuilds https://livebuilds.openbravo.com/erp_mp_3.0PR16Q3.3 [^]
2 - switch to F&B España, S.A - Employee role
3 - Open Requisition window
4 - Create a new header
5 - Crate a new line
6 - Realize that you can't perform step 5 becouse no product is listed.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0034823 closedinigosanchez Can't add lines in Requisition with role F&B España, S.A - Employee 

-  Notes
(0093066)
hgbot (developer)
2016-12-30 00:43

Repository: erp/backports/3.0PR16Q4.1
Changeset: 801e5057180ce207d0b406b206cb997dff173e1d
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Dec 30 00:41:56 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q4.1/rev/801e5057180ce207d0b406b206cb997dff173e1d [^]

Fixed issue 34829: Product selector of the Requisition subtab appears empty

The problem was introduced in a refactor of checkFetchDatasourceAccess() method of
BaseDataSourceService class. This refactor change the way in wich entities of
selectors were calculated. It is important to note that the refactor is not bad in
itself. The problem was appeared because it was forgotten to do an additional thing.

Before this refactor in some cases entities were not calculated properly. For example
in the subtab of Requisition window there are a complex selector of product. (Reference:
Product Complete - Parent Reference: Search). In this example, checkFetchDatasourceAccess
method was checked Product entity instead of ProductStockView. The refactor fixed this
problem.

Otherwise, the refactor missed to take into account entities of complex defined selectors
as derivedReadableEntities. To solve the problem now, when initialize() method of
EntityAccessChecker class calculates permissions, it will take into account this entities.

---
M src/org/openbravo/dal/security/EntityAccessChecker.java
---
(0093079)
AugustoMauch (developer)
2016-12-30 13:44

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2016-12-29 15:17 inigosanchez Type defect => backport
2016-12-29 15:17 inigosanchez Target Version => 3.0PR16Q4.1
2016-12-30 00:43 hgbot Checkin
2016-12-30 00:43 hgbot Note Added: 0093066
2016-12-30 00:43 hgbot Status scheduled => resolved
2016-12-30 00:43 hgbot Resolution open => fixed
2016-12-30 00:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q4.1/rev/801e5057180ce207d0b406b206cb997dff173e1d [^]
2016-12-30 10:00 inigosanchez Review Assigned To => AugustoMauch
2016-12-30 13:44 AugustoMauch Note Added: 0093079
2016-12-30 13:44 AugustoMauch Status resolved => closed
2016-12-30 13:44 AugustoMauch Fixed in Version => 3.0PR16Q3.3
2016-12-30 13:45 AugustoMauch Fixed in Version 3.0PR16Q3.3 => 3.0PR16Q4.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker