Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034823
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajoralways2016-12-23 19:272016-12-30 16:39
ReporterrbianchiniView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revision68aee6dfac93
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR16Q3.3SCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-04-28
Regression introduced in release3.0PR16Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/e8c0df5664deca28ef28bc90ef088d6ec532043c [^]
Triggers an Emergency PackNo
Summary

0034823: Can't add lines in Requisition with role F&B España, S.A - Employee

DescriptionIf you log in ERP Version < 16Q3, and switch role to F&B España, S.A - Employee, you are able to create Requisition and Requisition's lines.
If you log in ERP Version > 16Q3, and switch role to F&B España, S.A - Employee, you are able to create Requisition but Requisition's lines, the products are not listed.
Adding access to the tables m_product* to the role doesn't solve the problem.
You have to add permissions to product window in order to solve the problem.
With this configuration, a new menu entry <product> is shown, but the product window is not accesible becouse permissions (Error
With your current role and settings, you cannot view this information)
Steps To Reproduce1 - Log in livebuilds https://livebuilds.openbravo.com/erp_mp_3.0PR16Q3.3 [^]
2 - switch to F&B España, S.A - Employee role
3 - Open Requisition window
4 - Create a new header
5 - Crate a new line
6 - Realize that you can't perform step 5 becouse no product is listed.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 00327283.0PR16Q3 closedinigosanchez Standard datasources should check entity access. 
depends on backport 00348293.0PR16Q4.1 closedinigosanchez Can't add lines in Requisition with role F&B España, S.A - Employee 
depends on backport 00348303.0PR16Q3.4 closedinigosanchez Can't add lines in Requisition with role F&B España, S.A - Employee 
caused by defect 00327953.0PR16Q3 closedinigosanchez G/L Item combo appears empty in Add Payment process definition 

-  Notes
(0092993)
AtulOpenbravo (developer)
2016-12-26 15:59

Solution:-
- Login as F&B International Group Admin.
- Go to Role Access window, Select Employee Role.
- Add record by selecting table "M_Product_Stock_V",
  set Read Only = Yes, Exclude = No.

- Change profile to Employee Role.
- Go to Requisition Window. Create Header.
- Go to Lines Tab, Try to select Product.
- Check that List of Product appears.
(0093064)
hgbot (developer)
2016-12-30 00:33

Repository: erp/devel/pi
Changeset: 68aee6dfac93298c56f466d201e51138700e9c93
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Dec 30 00:31:59 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/68aee6dfac93298c56f466d201e51138700e9c93 [^]

Fixed issue 34823: Product selector of the Requisition subtab appears empty

The problem was introduced in a refactor of checkFetchDatasourceAccess() method of
BaseDataSourceService class. This refactor change the way in wich entities of
selectors were calculated. It is important to note that the refactor is not bad in
itself. The problem was appeared because it was forgotten to do an additional thing.

Before this refactor in some cases entities were not calculated properly. For example
in the subtab of Requisition window there are a complex selector of product. (Reference:
Product Complete - Parent Reference: Search). In this example, checkFetchDatasourceAccess
method was checked Product entity instead of ProductStockView. The refactor fixed this
problem.

Otherwise, the refactor missed to take into account entities of complex defined selectors
as derivedReadableEntities. To solve the problem now, when initialize() method of
EntityAccessChecker class calculates permissions, it will take into account this entities.

---
M src/org/openbravo/dal/security/EntityAccessChecker.java
---
(0093067)
hgbot (developer)
2016-12-30 00:55

Repository: erp/devel/pi
Changeset: c1b4f96c83787d2c111546379231de27b3cb40eb
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Dec 30 00:54:27 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c1b4f96c83787d2c111546379231de27b3cb40eb [^]

Related with issue 34823: Added new test case to DataSourceSecurity

- Added F&B España, S.A - Employee role to the test class.
- Added a new test case in order to cover this regression. Requisition
Window > Requisition Lines > Product Complete Selector.

---
M src-test/src/org/openbravo/test/datasource/DataSourceSecurity.java
---
(0093068)
hudsonbot (developer)
2016-12-30 05:45

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c951f095b5d3 [^]
Maturity status: Test
(0093072)
hgbot (developer)
2016-12-30 10:44

Repository: erp/devel/pi
Changeset: 261174abcf4ca647a7fcbcfc32a0c6dde2d898e1
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Dec 30 10:43:15 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/261174abcf4ca647a7fcbcfc32a0c6dde2d898e1 [^]

Related with issue 34823: Improve comments

---
M src-test/src/org/openbravo/test/datasource/DataSourceSecurity.java
M src/org/openbravo/dal/security/EntityAccessChecker.java
---
(0093073)
AugustoMauch (developer)
2016-12-30 10:48

Code reviewed and verified in pi@987dedc02635
(0093082)
hudsonbot (developer)
2016-12-30 16:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7f58c9165bf6 [^]
Maturity status: Test
(0093083)
hudsonbot (developer)
2016-12-30 16:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7f58c9165bf6 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-12-23 19:27 rbianchini New Issue
2016-12-23 19:27 rbianchini Assigned To => Triage Finance
2016-12-23 19:27 rbianchini Modules => Core
2016-12-23 19:27 rbianchini Regression level => Production - Confirmed Stable
2016-12-23 19:27 rbianchini Regression introduced in release => 3.0PR16Q3
2016-12-23 19:27 rbianchini Triggers an Emergency Pack => No
2016-12-23 21:37 markmm82 Assigned To Triage Finance => AtulOpenbravo
2016-12-26 09:36 AtulOpenbravo Status new => scheduled
2016-12-26 15:59 AtulOpenbravo Note Added: 0092993
2016-12-27 13:52 AtulOpenbravo Assigned To AtulOpenbravo => platform
2016-12-27 23:41 inigosanchez Assigned To platform => inigosanchez
2016-12-27 23:43 inigosanchez Regression date => 2016-04-28
2016-12-27 23:43 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/e8c0df5664deca28ef28bc90ef088d6ec532043c [^]
2016-12-29 15:13 inigosanchez Relationship added caused by 0032795
2016-12-29 15:13 inigosanchez Relationship added related to 0032728
2016-12-29 15:15 inigosanchez Status scheduled => acknowledged
2016-12-29 15:17 inigosanchez Status acknowledged => scheduled
2016-12-30 00:33 hgbot Checkin
2016-12-30 00:33 hgbot Note Added: 0093064
2016-12-30 00:33 hgbot Status scheduled => resolved
2016-12-30 00:33 hgbot Resolution open => fixed
2016-12-30 00:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/68aee6dfac93298c56f466d201e51138700e9c93 [^]
2016-12-30 00:55 hgbot Checkin
2016-12-30 00:55 hgbot Note Added: 0093067
2016-12-30 05:45 hudsonbot Checkin
2016-12-30 05:45 hudsonbot Note Added: 0093068
2016-12-30 10:00 inigosanchez Review Assigned To => AugustoMauch
2016-12-30 10:44 hgbot Checkin
2016-12-30 10:44 hgbot Note Added: 0093072
2016-12-30 10:48 AugustoMauch Note Added: 0093073
2016-12-30 10:48 AugustoMauch Status resolved => closed
2016-12-30 10:48 AugustoMauch Fixed in Version => 3.0PR17Q1
2016-12-30 16:39 hudsonbot Checkin
2016-12-30 16:39 hudsonbot Note Added: 0093082
2016-12-30 16:39 hudsonbot Checkin
2016-12-30 16:39 hudsonbot Note Added: 0093083


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker