Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034767
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] StoreServermajorhave not tried2016-12-16 12:002016-12-29 14:19
ReporterAugustoMauchView Statuspublic 
Assigned ToSandrahuguet 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision9143a4ac553c
ProjectionnoneETAnoneTarget VersionRR16Q4.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Regression levelProduction - QA Approved
Regression date2016-08-19
Regression introduced in releaseRR16Q4
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/6ccbd09b41f4 [^]
Triggers an Emergency PackNo
Summary

0034767: Transact left open leads to database locks when updating entries from the Mobile Server window

DescriptionThere is a bug in SetCurrentMobileServerListener that results in a transaction being left open if the mobile.server.key property is not defined in Openbravo.properties.

As a result of that transaction being left open, it will not be possible to update a mobile server that was already defined when Tomcat was last started because the uncommited transaction will cause a database lock.
Steps To Reproduce- Make sure there is at least one entry in the obmobc_server_definition table.
- Make sure the mobile.server.key parameter is not defined in Openbravo.properties
- Start Tomcat
- After starting Tomcat, run this query in the database to check that one transaction has been left open: select * from pg_stat_activity where state <> 'idle' and query ilike '%server%';
- Open the Mobile Server window and try to modify an existing mobile server. The record will not be saved due to a lock in the database.
Proposed SolutionMake sure under all circumstances the connection is either commited or rolled back
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0034756 closedSandrahuguet Transaction left open leads to database locks when updating entries from the Mobile Server window 

-  Notes
(0092775)
hgbot (developer)
2016-12-19 12:38

Repository: retail/backports/3.0RR16Q4.1/org.openbravo.mobile.core
Changeset: 9143a4ac553c6c80523bbcf7d2407c8b107e3bfa
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Mon Dec 19 12:37:47 2016 +0100
URL: http://code.openbravo.com/retail/backports/3.0RR16Q4.1/org.openbravo.mobile.core/rev/9143a4ac553c6c80523bbcf7d2407c8b107e3bfa [^]

Fixed issue 34767 properly commitAndClose in SetCurrentMobileServerListener

properly commitAndClose in SetCurrentMobileServerListener to avoid the
transaction left open leads to database locks when updating entries
from the Mobile Server window

---
M src/org/openbravo/mobile/core/listener/SetCurrentMobileServerListener.java
---
(0093054)
AugustoMauch (developer)
2016-12-29 14:19

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2016-12-19 11:12 Sandrahuguet Type defect => backport
2016-12-19 11:12 Sandrahuguet Target Version => RR16Q4.1
2016-12-19 12:38 hgbot Checkin
2016-12-19 12:38 hgbot Note Added: 0092775
2016-12-19 12:38 hgbot Status scheduled => resolved
2016-12-19 12:38 hgbot Resolution open => fixed
2016-12-19 12:38 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/64da711454b7732e30477ac0598f9844442eb41d [^] => http://code.openbravo.com/retail/backports/3.0RR16Q4.1/org.openbravo.mobile.core/rev/9143a4ac553c6c80523bbcf7d2407c8b107e3bfa [^]
2016-12-29 14:19 AugustoMauch Note Added: 0093054
2016-12-29 14:19 AugustoMauch Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker