Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034641
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminorsometimes2016-11-28 08:202017-10-02 13:53
ReportermalsasuaView Statuspublic 
Assigned Tomigueldejuana 
PriorityhighResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revision70b2f9f884de
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned To
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034641: corrupted receipts are stored in c_order local database

DescriptionSometimes, corrupted receipts (with json column set to null) are stored in local database in c_order table
Steps To Reproducen/a
Proposed Solutionsee attachment
TagsNo tags attached.
Attached Filesdiff file icon nullOrders_mobileCore_16Q12.diff [^] (4,435 bytes) 2016-11-28 10:48 [Show Content]
diff file icon nullC_order_idMobileCore_16Q12.diff [^] (1,259 bytes) 2016-12-12 16:37 [Show Content]
? file icon issue34641posterminal.commit [^] (2,368 bytes) 2017-07-13 11:57
diff file icon issue36441_posterminal_isEditable.diff [^] (837 bytes) 2017-10-02 13:40 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0034321 closedmigueldejuana We are saving order with id:null inside json 

-  Notes
(0097422)
hgbot (developer)
2017-06-15 17:21

Repository: erp/pmods/org.openbravo.mobile.procurement
Changeset: 3ad78c2227b2d40abd5bd1a8529ccc982bce42d2
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Thu Jun 15 17:21:33 2017 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.procurement/rev/3ad78c2227b2d40abd5bd1a8529ccc982bce42d2 [^]

Fixed issue 0034641: corrupted receipts are stored in c_order local database

- Set the order id before setting json

---
M web/org.openbravo.mobile.procurement/source/model/mpr-order.js
---
(0097475)
hgbot (developer)
2017-06-19 11:31

Repository: erp/pmods/org.openbravo.retail.trainingmode
Changeset: 09212617473c595d233c89cb25d3ec5347269597
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Mon Jun 19 11:30:53 2017 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.trainingmode/rev/09212617473c595d233c89cb25d3ec5347269597 [^]

Fixed issue 0034641: corrupted receipts are stored in c_order local database

- Skip saveOrder callback

---
M web/org.openbravo.retail.trainingmode/js/ordersavehook.js
---
(0097479)
hgbot (developer)
2017-06-19 15:35

Repository: erp/pmods/org.openbravo.mobile.procurement
Changeset: 49563cf50d36ef7749bdc473d8f90fdff9fc06eb
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Mon Jun 19 15:35:02 2017 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.procurement/rev/49563cf50d36ef7749bdc473d8f90fdff9fc06eb [^]

Fixed issue 0034641: corrupted receipts are stored in c_order local database

- Declare forceInsert and pass it to save method because the id is already defined

---
M web/org.openbravo.mobile.procurement/source/model/mpr-order.js
---
(0097531)
hgbot (developer)
2017-06-20 17:36

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: b6a2aa0b7aa854d836fac1145b423451b4a79829
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Mon Jun 19 15:39:40 2017 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b6a2aa0b7aa854d836fac1145b423451b4a79829 [^]

Fixed issue 0034641: corrupted receipts are stored in c_order local database

- Allow to skip closed callback

---
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
M web/org.openbravo.retail.posterminal/js/pointofsale/model/pointofsale-model.js
---
(0097532)
hgbot (developer)
2017-06-20 17:36

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 70b2f9f884ded376d241b86e36e030610fa1e08b
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Thu Jun 15 17:19:59 2017 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/70b2f9f884ded376d241b86e36e030610fa1e08b [^]

Fixed issue 0034641: corrupted receipts are stored in c_order local database

- Check if id and json are set when saving an order
- If we try to synchronize corrupted order, show a message a delete them from local database because they have missing data. We cannot fix them and they will never be synchronized

---
M web/org.openbravo.mobile.core/source/data/ob-dal.js
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---
(0097621)
mtaal (manager)
2017-06-25 14:54

Checked training mode and procurement --> fine

This change [1] is not complete imv. If the json has value null then only an error is reported in the first if. But the second if in the changeset is not executed and the order will still get saved without a value in the json. So maybe think of initializing the json also in the first if.

[1]
https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/70b2f9f884ded376d241b86e36e030610fa1e08b#l1.9 [^]
(0099692)
migueldejuana (developer)
2017-10-02 13:53

The patch issue36441_posterminal_isEditable.diff is for 16Q4. It avoids to save non editable orders. With this diff we solve some errors happened in Decathlon India. Errors of orders with null values in backend or frontend.

- Issue History
Date Modified Username Field Change
2016-11-28 08:20 malsasua New Issue
2016-11-28 08:20 malsasua Assigned To => Retail
2016-11-28 08:20 malsasua Triggers an Emergency Pack => No
2016-11-28 08:21 malsasua Proposed Solution updated
2016-11-28 08:21 malsasua File Added: nullOrders_mobilecore.diff
2016-11-28 10:47 migueldejuana File Deleted: nullOrders_mobilecore.diff
2016-11-28 10:48 migueldejuana File Added: nullOrders_mobileCore_16Q12.diff
2016-12-12 16:37 migueldejuana File Added: nullC_order_idMobileCore_16Q12.diff
2017-02-03 09:32 malsasua Relationship added related to 0034321
2017-06-15 17:21 hgbot Checkin
2017-06-15 17:21 hgbot Note Added: 0097422
2017-06-15 17:21 hgbot Status new => resolved
2017-06-15 17:21 hgbot Resolution open => fixed
2017-06-15 17:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.procurement/rev/3ad78c2227b2d40abd5bd1a8529ccc982bce42d2 [^]
2017-06-19 11:31 hgbot Checkin
2017-06-19 11:31 hgbot Note Added: 0097475
2017-06-19 11:31 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.procurement/rev/3ad78c2227b2d40abd5bd1a8529ccc982bce42d2 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.trainingmode/rev/09212617473c595d233c89cb25d3ec5347269597 [^]
2017-06-19 15:35 hgbot Checkin
2017-06-19 15:35 hgbot Note Added: 0097479
2017-06-19 15:35 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.trainingmode/rev/09212617473c595d233c89cb25d3ec5347269597 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.procurement/rev/49563cf50d36ef7749bdc473d8f90fdff9fc06eb [^]
2017-06-20 12:22 Sandrahuguet Assigned To Retail => migueldejuana
2017-06-20 17:36 hgbot Checkin
2017-06-20 17:36 hgbot Note Added: 0097531
2017-06-20 17:36 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.procurement/rev/49563cf50d36ef7749bdc473d8f90fdff9fc06eb [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b6a2aa0b7aa854d836fac1145b423451b4a79829 [^]
2017-06-20 17:36 hgbot Checkin
2017-06-20 17:36 hgbot Note Added: 0097532
2017-06-20 17:36 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/b6a2aa0b7aa854d836fac1145b423451b4a79829 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/70b2f9f884ded376d241b86e36e030610fa1e08b [^]
2017-06-25 14:54 mtaal Note Added: 0097621
2017-06-25 14:54 mtaal Status resolved => new
2017-06-25 14:54 mtaal Resolution fixed => open
2017-07-13 11:57 migueldejuana File Added: issue34641posterminal.commit
2017-10-02 13:40 malsasua File Added: issue36441_posterminal_isEditable.diff
2017-10-02 13:53 migueldejuana Note Added: 0099692


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker