Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034213
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. PlatformminorN/A2016-10-17 08:472018-04-20 09:58
ReporteralostaleView Statuspublic 
Assigned Toshuehner 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revision0ddd9d57e495
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034213: clean up AD_Model_Object and AD_Model_Object_Mapping

DescriptionThe main purpose of AD_Model_Object and AD_Model_Object_Mapping tables is to define in dictionary the mappings for web.xml. After 0032366 and 0032512, callouts are no longer defined as servlets.

Therefore mappings for them (which are not currently included in web.xml) should be removed.

Note, even they are not used for web.xml, callouts require of AD_Model_Object row to define the java class they use.
Steps To Reproduce-
Proposed Solution* Review and clean unneeded entries up
* Add validation to prevent future cases
TagsNo tags attached.
Attached Files? file icon SimpleCalloutMappingTest.java [^] (4,228 bytes) 2017-01-13 14:21

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 00323663.0PR16Q4 closedinigosanchez Openbravo ERP callout invocation ineficiencies 
related to feature request 00325123.0PR17Q1 closedalostale Openbravo ERP support WildFly 10 
related to defect 0038368 closedshuehner Openbravo ERP API-change for removal of obsolete ad_model_object_mapping for callouts in pi. 
related to defect 0038370 closedshuehner Openbravo ERP Stop auto-adding new html mapping for every new callout (in ad_callout_trg) 
related to defect 0035540 closedalostale Openbravo ERP Traceability Report does not work 
related to defect 0038257 closedshuehner Retail Modules Cleanup obsolete callout related ad_model_object_mapping entries 
blocks design defect 0032688 acknowledgedplatform Openbravo ERP remove unused resources 

-  Notes
(0093544)
shuehner (administrator)
2017-01-13 14:23

In addition to cleanup the existing mappings i think we should also add a check to not introduce new mappings we don't really need.

The attached new junit test is quick start to find those mappings. It is based on our ClassLoaderTest adapted a bit to check for 'extends SimpleCallout' & checking for any mappings

Test maybe need some review + cleanup but is a start.

Note:
Probably only callouts should be cleaned up if the directly or indirectly depend on ERP 16Q4 which has the change of SimpleCallout. Either a note to the output or a check in the code could be added to avoid introducing issues here.
(0103884)
shuehner (administrator)
2018-04-14 14:23

The following commit published in 17Q1 (as part of wildfly support) disabled generaing any web.xml servlet mapping for callouts (simplecallout + also old servlet based ones).
https://code.openbravo.com/erp/devel/pi/rev/b468094df0d0ff1d168a03977ba314f64549b998 [^]

That means and every mapping for callout is no longer useful to have in xml if it is used with >=17Q1.
(0103885)
hgbot (developer)
2018-04-14 14:28

Repository: erp/devel/pi
Changeset: 0ddd9d57e495bafab879eec45a978f2555fdf757
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Fri Mar 30 13:56:25 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0ddd9d57e495bafab879eec45a978f2555fdf757 [^]

Fixed 34213. Delete obsolete ad_model_object_mappings related to callouts.

Since commit b468094df0d0 (shipped in 17Q1 any callout related
model object(& mapping) are not generated into web.xml
As consequence all those ad_model_object mapping entries are obsolete and
hereby removed.
This applies both to SimpleCallout and old callouts still implementing a
servlet as FIC code does calls those old servlets directly in java without
doing a real http call.

---
M src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
R modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
R modules/org.openbravo.client.querylist/src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
R modules/org.openbravo.userinterface.selector/src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
---
(0104008)
alostale (developer)
2018-04-20 09:58

reviewed

- Issue History
Date Modified Username Field Change
2016-10-17 08:47 alostale New Issue
2016-10-17 08:47 alostale Assigned To => platform
2016-10-17 08:47 alostale Modules => Core
2016-10-17 08:47 alostale Triggers an Emergency Pack => No
2016-10-17 08:47 alostale Relationship added related to 0032366
2016-10-17 08:47 alostale Relationship added related to 0032512
2016-12-01 12:11 alostale Relationship added blocks 0032688
2016-12-01 12:11 alostale Status new => acknowledged
2016-12-01 12:11 alostale Target Version 3.0PR17Q1 =>
2017-01-13 13:56 alostale Proposed Solution updated
2017-01-13 14:21 shuehner File Added: SimpleCalloutMappingTest.java
2017-01-13 14:23 shuehner Note Added: 0093544
2017-03-21 09:18 alostale Relationship added related to 0035540
2018-03-30 14:10 shuehner Relationship added related to 0038257
2018-04-14 14:23 shuehner Note Added: 0103884
2018-04-14 14:24 shuehner Assigned To platform => shuehner
2018-04-14 14:26 shuehner Relationship added related to 0038368
2018-04-14 14:28 hgbot Checkin
2018-04-14 14:28 hgbot Note Added: 0103885
2018-04-14 14:28 hgbot Status acknowledged => resolved
2018-04-14 14:28 hgbot Resolution open => fixed
2018-04-14 14:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0ddd9d57e495bafab879eec45a978f2555fdf757 [^]
2018-04-14 14:28 shuehner Review Assigned To => alostale
2018-04-14 15:16 shuehner Relationship added related to 0038370
2018-04-20 09:58 alostale Note Added: 0104008
2018-04-20 09:58 alostale Status resolved => closed
2018-04-20 09:58 alostale Fixed in Version => 3.0PR18Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker