Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038370
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2018-04-14 15:162018-04-20 09:57
ReportershuehnerView Statuspublic 
Assigned Toshuehner 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisiondd78fd211350
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038370: Stop auto-adding new html mapping for every new callout (in ad_callout_trg)

DescriptionURL mapping for callout are no longer required/used and all old ones have been removed in pi in issue: 34213

However the ad_callout_trg trigger is still inserting new html mappings for every callout re-adding new mappings which is not useful.
Steps To Reproduce-
TagsNo tags attached.
Attached Files? file icon 38370.hgexport [^] (1,845 bytes) 2018-04-14 15:26

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 00323663.0PR16Q4 closedinigosanchez callout invocation ineficiencies 
related to defect 0034213 closedshuehner clean up AD_Model_Object and AD_Model_Object_Mapping 

-  Notes
(0103890)
shuehner (administrator)
2018-04-14 15:30

Doing this change has following side-effects:
a.) Using >=18Q3 release to develop new old-style servlet non SimpleCallouts will require to manually insert html mapping
b.) Using >=18Q3 to edit old-style servlet ad_callout entries will delete + not re-create the mapping so make the callout unusable unless the mapping is manually re-addded (As the code to delete mappings on 'edit' stays).

Given timing with this published in 18Q3 only:
- No new callouts should be created not being SimpleCallout based
- Developing new code compatible with <17Q1 using 18Q3 is highly unlikely.
- Editing ad_callout entry for old-style callout with 18Q3 and wanting to to keep 17Q3 compat is also quite unlikely.

So those side-effect should be acceptable.
(0104006)
hgbot (developer)
2018-04-20 09:57

Repository: erp/devel/pi
Changeset: dd78fd2113508b43f62e9f9cf2f6be528b4c5f92
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Sat Apr 14 15:25:14 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/dd78fd2113508b43f62e9f9cf2f6be528b4c5f92 [^]

Fixed 38370. Don't add new html mapping for new callouts.

Remove code to auto-insert into ad_model_object_mapping in ad_callout_trg.
As those mappings are no longer useful since 17Q1.

---
M src-db/database/model/triggers/AD_CALLOUT_TRG.xml
---
(0104007)
alostale (developer)
2018-04-20 09:57

reviewed

- Issue History
Date Modified Username Field Change
2018-04-14 15:16 shuehner New Issue
2018-04-14 15:16 shuehner Assigned To => shuehner
2018-04-14 15:16 shuehner Modules => Core
2018-04-14 15:16 shuehner Triggers an Emergency Pack => No
2018-04-14 15:16 shuehner Relationship added related to 0034213
2018-04-14 15:24 shuehner Summary Remove trigger to generate ad_model_object_mapping for every new callout. => Stop auto-adding new html mapping for every new callout (in ad_callout_trg)
2018-04-14 15:26 shuehner File Added: 38370.hgexport
2018-04-14 15:30 shuehner Note Added: 0103890
2018-04-19 09:41 alostale Relationship added related to 0032366
2018-04-20 09:57 hgbot Checkin
2018-04-20 09:57 hgbot Note Added: 0104006
2018-04-20 09:57 hgbot Status new => resolved
2018-04-20 09:57 hgbot Resolution open => fixed
2018-04-20 09:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/dd78fd2113508b43f62e9f9cf2f6be528b4c5f92 [^]
2018-04-20 09:57 alostale Review Assigned To => alostale
2018-04-20 09:57 alostale Note Added: 0104007
2018-04-20 09:57 alostale Status resolved => closed
2018-04-20 09:57 alostale Fixed in Version => 3.0PR18Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker