Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033620
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2016-08-04 08:452016-08-11 18:40
ReporterdmiguelezView Statuspublic 
Assigned Todmiguelez 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revision3f38dea1af12
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-02-16
Regression introduced in release3.0PR16Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/5435ecfe6c1f [^]
Triggers an Emergency PackNo
Summary

0033620: Performance problems in Postgresql 9.3 when invoking view from query

DescriptionPerformance problems in Postgresql 9.3 when invoking view from query.

If this view is invoked from a Query in an environment with large volumes of data it can create performance problems in Postgresql 9.3 due to the Union in the view.
Steps To ReproduceIn an environment with large volumes of data, try to Post a Document (an Invoice for example). It takes a significant amount of time to post it.
Proposed SolutionMerge the View into one query removing the view.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00336513.0PR16Q3.2 closeddmiguelez Performance problems in Postgresql 9.3 when invoking view from query 
depends on backport 00336523.0PR16Q2.2 closeddmiguelez Performance problems in Postgresql 9.3 when invoking view from query 
caused by defect 0032216 closedvmromanos An error is shown in the Cash VAT tab in the case of decreasing Purchase Invoice Amount created from a prepaid order. 

-  Notes
(0088896)
hgbot (developer)
2016-08-08 14:57

Repository: erp/devel/pi
Changeset: 3f38dea1af12c2d4368bae83de5cc67552422d13
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Fri Aug 05 11:30:23 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3f38dea1af12c2d4368bae83de5cc67552422d13 [^]

Fixes issue 33620: Removes UNION ALL from view and merges it into one sentece

---
M src-db/database/model/views/C_INVOICETAX_CASHVAT_V.xml
---
(0088899)
aferraz (developer)
2016-08-08 15:00

Code review OK
(0088921)
hgbot (developer)
2016-08-09 11:32

Repository: erp/devel/pi
Changeset: 1755dcdca82d53b12f8b46626f6a25947af32ef6
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Aug 09 11:30:20 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1755dcdca82d53b12f8b46626f6a25947af32ef6 [^]

Related to issue 33620: Remove parenthesis

---
M src-db/database/model/views/C_INVOICETAX_CASHVAT_V.xml
---
(0089048)
hudsonbot (developer)
2016-08-11 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/edaa05b1fb18 [^]
Maturity status: Test
(0089053)
hudsonbot (developer)
2016-08-11 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/edaa05b1fb18 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-08-04 08:45 dmiguelez New Issue
2016-08-04 08:45 dmiguelez Assigned To => Triage Finance
2016-08-04 08:45 dmiguelez Modules => Core
2016-08-04 08:45 dmiguelez Regression level => Production - Confirmed Stable
2016-08-04 08:45 dmiguelez Regression date => 2016-02-12
2016-08-04 08:45 dmiguelez Regression introduced in release => 3.0PR16Q1.2
2016-08-04 08:45 dmiguelez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/5435ecfe6c1f [^]
2016-08-04 08:45 dmiguelez Triggers an Emergency Pack => No
2016-08-08 13:20 aferraz Regression date 2016-02-12 => 2016-02-16
2016-08-08 13:20 aferraz Regression introduced in release 3.0PR16Q1.2 => 3.0PR16Q2
2016-08-08 14:34 aferraz Relationship added caused by 0032216
2016-08-08 14:34 aferraz Assigned To Triage Finance => dmiguelez
2016-08-08 14:35 aferraz Status new => scheduled
2016-08-08 14:57 hgbot Checkin
2016-08-08 14:57 hgbot Note Added: 0088896
2016-08-08 14:57 hgbot Status scheduled => resolved
2016-08-08 14:57 hgbot Resolution open => fixed
2016-08-08 14:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3f38dea1af12c2d4368bae83de5cc67552422d13 [^]
2016-08-08 15:00 aferraz Review Assigned To => aferraz
2016-08-08 15:00 aferraz Note Added: 0088899
2016-08-08 15:00 aferraz Status resolved => closed
2016-08-08 15:00 aferraz Fixed in Version => 3.0PR16Q4
2016-08-09 11:32 hgbot Checkin
2016-08-09 11:32 hgbot Note Added: 0088921
2016-08-11 18:40 hudsonbot Checkin
2016-08-11 18:40 hudsonbot Note Added: 0089048
2016-08-11 18:40 hudsonbot Checkin
2016-08-11 18:40 hudsonbot Note Added: 0089053


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker