Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033651
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementmajoralways2016-08-04 08:452016-09-13 15:46
ReporterdmiguelezView Statuspublic 
Assigned Todmiguelez 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q3.2
StatusclosedFix in branchFixed in SCM revisionc236f2c98d6d
ProjectionnoneETAnoneTarget Version3.0PR16Q3.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-02-16
Regression introduced in release3.0PR16Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/5435ecfe6c1f [^]
Triggers an Emergency PackNo
Summary

0033651: Performance problems in Postgresql 9.3 when invoking view from query

DescriptionPerformance problems in Postgresql 9.3 when invoking view from query.

If this view is invoked from a Query in an environment with large volumes of data it can create performance problems in Postgresql 9.3 due to the Union in the view.
Steps To ReproduceIn an environment with large volumes of data, try to Post a Document (an Invoice for example). It takes a significant amount of time to post it.
Proposed SolutionMerge the View into one query removing the view.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0033620 closeddmiguelez Performance problems in Postgresql 9.3 when invoking view from query 

-  Notes
(0089922)
hgbot (developer)
2016-09-13 15:45

Repository: erp/backports/3.0PR16Q3.2
Changeset: c236f2c98d6dfbf6a6ae37698ea1606019d4dee5
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Fri Aug 05 11:30:23 2016 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR16Q3.2/rev/c236f2c98d6dfbf6a6ae37698ea1606019d4dee5 [^]

Fixes issue 33651: Removes UNION ALL from view and merges it into one sentece

---
M src-db/database/model/views/C_INVOICETAX_CASHVAT_V.xml
---
(0089923)
hgbot (developer)
2016-09-13 15:45

Repository: erp/backports/3.0PR16Q3.2
Changeset: bb5f221bc82961ac36293ec923de026cc73767fd
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Aug 09 11:30:20 2016 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR16Q3.2/rev/bb5f221bc82961ac36293ec923de026cc73767fd [^]

Related to issue 33651: Remove parenthesis

---
M src-db/database/model/views/C_INVOICETAX_CASHVAT_V.xml
---
(0089924)
aferraz (developer)
2016-09-13 15:46

Code review OK

- Issue History
Date Modified Username Field Change
2016-08-08 14:35 aferraz Type defect => backport
2016-08-08 14:35 aferraz Target Version => 3.0PR16Q3.1
2016-08-22 14:38 aferraz Target Version 3.0PR16Q3.1 => 3.0PR16Q3.2
2016-09-13 15:45 hgbot Checkin
2016-09-13 15:45 hgbot Note Added: 0089922
2016-09-13 15:45 hgbot Status scheduled => resolved
2016-09-13 15:45 hgbot Resolution open => fixed
2016-09-13 15:45 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q3.2/rev/c236f2c98d6dfbf6a6ae37698ea1606019d4dee5 [^]
2016-09-13 15:45 hgbot Checkin
2016-09-13 15:45 hgbot Note Added: 0089923
2016-09-13 15:46 aferraz Review Assigned To => aferraz
2016-09-13 15:46 aferraz Note Added: 0089924
2016-09-13 15:46 aferraz Status resolved => closed
2016-09-13 15:46 aferraz Fixed in Version => 3.0PR16Q3.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker