Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033599
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2016-08-02 14:192016-08-23 14:26
ReporterngarciaView Statuspublic 
Assigned Tononofrancisco 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revision18744d5df2a4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0033599: Cannot validate a new Costing Rule after validating a costing rule with FIFO algorithm if there exists negative stock

DescriptionCannot validate a new Costing Rule after validating a costing rule with FIFO algorithm if there exists negative stock
Steps To ReproduceAs group admin role:
   Validate a Costing Rule with FIFO Costing Algorithm for F&B US, Inc.
   Create a product for F&B US, Inc.
   Set Allow Negative Stock at client level
   Create a Goods Receipt for F&B US - West Coast with 2 units of the product
   Create a Goods Shipment for F&B US - West Coast with 1 units of the product
   Create a Goods Shipment for F&B US - East Coast with 1 units of the product
   Check there exists negative stock for the product in East Coast warehouse
   Launch the Costing Background process and check it finishes successfully
   Validate a Costing Rule with Average Algorithm for F&B US, Inc. and check an empty error message is shown
   The log shows:
      
ERROR org.openbravo.costing.CostingRuleProcess -
java.lang.NullPointerException
    at org.openbravo.costing.CostingRuleProcess.updateInventoriesCostAndProcessInitInventories(CostingRuleProcess.java:583)
    at org.openbravo.costing.CostingRuleProcess.execute(CostingRuleProcess.java:132)
...
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0033379 closedmarkmm82 Modules Cannot validate a new Costing Rule after validating a costing rule with FIFO algorithm 
related to defect 0034670 closedTriage Finance Modules CostingServer should check if current algorithm supports adjustments, when trying to adjust remainder value in inventory closing 

-  Notes
(0089273)
hgbot (developer)
2016-08-22 13:29

Repository: erp/devel/pi
Changeset: 18744d5df2a4dd6bacc52994e6ffd259eaebc0bd
Author: Nono Carballo <nonofce <at> gmail.com>
Date: Thu Aug 18 12:08:06 2016 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/18744d5df2a4dd6bacc52994e6ffd259eaebc0bd [^]

Fixes issue 33599: Can't validate a costing rule after one with FIFO algorithm

Can not validate a new Costing Rule after validating onw with FIFO algorithm if there exists negative stock.
Problem is that FIFO Costing Algorithm is not able to calculate the cost of the closing inventory transaction with negative stock, because there will be more quantity in the Output Stack than the available in the Input Stack.
In that case, "NoCostCalculated" error message will be shown when validating the new Costing Rule until negative stock is regularized.

---
M src/org/openbravo/costing/CostingRuleProcess.java
---
(0089274)
aferraz (developer)
2016-08-22 13:30

Code review + Testing OK
(0089275)
aferraz (developer)
2016-08-22 13:37

Test plan:

As group admin role:
   Validate a Costing Rule with FIFO Costing Algorithm for F&B US, Inc.
   Create a product for F&B US, Inc.
   Set Allow Negative Stock at client level
   Create a Goods Receipt for F&B US - West Coast with 2 units of the product
   Create a Goods Shipment for F&B US - West Coast with 1 units of the product
   Create a Goods Shipment for F&B US - East Coast with 1 units of the product
   Check there exists negative stock for the product in East Coast warehouse
   Launch the Costing Background process and check it finishes successfully
   Validate a Costing Rule with Average Algorithm for F&B US, Inc. and check "NoCostCalculated" error message is shown as explained in the wiki
   Create a Physical Inventory for F&B US - East Coast. Click on Create Inventory Count List and select Inventory Quantity < 0. Edit line for created product and set Quantity count = 0 in order to remove negative stock of this product. Process it
   Launch the Costing Background process and check it finishes successfully
   Validate a Costing Rule with Average Algorithm for F&B US, Inc. and check it finishes successfully
(0089281)
aferraz (developer)
2016-08-22 14:34
edited on: 2016-08-22 14:35

Documentation updated (http://forge.openbravo.com/plugins/mwiki/index.php/FIFO [^]):

"Besides that, it will not be possible to validate a new costing rule until negative stock is regularized."

(0089298)
hudsonbot (developer)
2016-08-23 14:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/49d28e45a11a [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-08-02 14:19 ngarcia New Issue
2016-08-02 14:19 ngarcia Assigned To => Triage Finance
2016-08-02 14:19 ngarcia Relationship added related to 0033379
2016-08-02 15:17 aferraz Assigned To Triage Finance => markmm82
2016-08-08 16:04 markmm82 Status new => scheduled
2016-08-12 15:29 aferraz Assigned To markmm82 => nonofrancisco
2016-08-22 13:15 aferraz Project Modules => Openbravo ERP
2016-08-22 13:15 aferraz Modules => Core
2016-08-22 13:15 aferraz Triggers an Emergency Pack => No
2016-08-22 13:15 aferraz Category FIFO Costing Algorithm => 04. Warehouse management
2016-08-22 13:29 hgbot Checkin
2016-08-22 13:29 hgbot Note Added: 0089273
2016-08-22 13:29 hgbot Status scheduled => resolved
2016-08-22 13:29 hgbot Resolution open => fixed
2016-08-22 13:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/18744d5df2a4dd6bacc52994e6ffd259eaebc0bd [^]
2016-08-22 13:30 aferraz Review Assigned To => aferraz
2016-08-22 13:30 aferraz Note Added: 0089274
2016-08-22 13:30 aferraz Status resolved => closed
2016-08-22 13:30 aferraz Fixed in Version => 3.0PR16Q4
2016-08-22 13:37 aferraz Note Added: 0089275
2016-08-22 14:34 aferraz Note Added: 0089281
2016-08-22 14:35 aferraz Note Edited: 0089281 View Revisions
2016-08-23 14:26 hudsonbot Checkin
2016-08-23 14:26 hudsonbot Note Added: 0089298
2016-12-02 11:45 aferraz Relationship added related to 0034670


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker