Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0033002
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2016-05-19 16:322016-06-17 19:37
ReporterngarciaView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision98ac1279b215
ProjectionnoneETAnoneTarget Version3.0PR16Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-11-27
Regression introduced in release3.0PR16Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/92d905a6c013 [^]
Triggers an Emergency PackNo
Summary

0033002: Stock available previous to the validation of the costing rule is not shown in Valued Stock Report

DescriptionStock available previous to the validation of the costing rule is not shown in Valued Stock Report. The starting date (timestamp) is truncated to date with the to_date function. Example:

to_date('02-07-2015 20:36:35') -> '2015-07-02 00:00:00'
Steps To ReproduceAs group admin role:
   Check there is stock of a product
   Validate a costing rule for the organization the stock belongs to
   Create a goods receipt for that product
   Launch the Costing Background Process and check it finishes successfully
   Launch the Valued Stock Report with tomorrow's date and check only the stock received in the goods receipt is shown
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00330063.0PR16Q2 closedaferraz Stock available previous to the validation of the costing rule is not shown in Valued Stock Report 
depends on backport 00330073.0PR16Q1.2 closedaferraz Stock available previous to the validation of the costing rule is not shown in Valued Stock Report 
caused by defect 00314153.0PR16Q1 closedaferraz The valued stock report is not taking into account the starting date of the costing rule 

-  Notes
(0086596)
aferraz (developer)
2016-05-20 11:04

Test Plan:

As group admin role:
   Check there is stock of a product
   Validate a costing rule for the organization the stock belongs to
   Create a goods receipt for that product
   Launch the Costing Background Process and check it finishes successfully
   Launch the Valued Stock Report with tomorrow's date and check previous stock + stock received in the goods receipt is shown
(0086617)
hgbot (developer)
2016-05-20 13:29

Repository: erp/devel/pi
Changeset: 98ac1279b215ca0f41ca2844a584b4a7fa315082
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri May 20 10:08:11 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/98ac1279b215ca0f41ca2844a584b4a7fa315082 [^]

Fixes issue 33002: Stock before costing rule not shown in Valued Stock Report

Convert current costing rule starting date with to_timestamp instead of with to_date function to avoid date truncation.
Before, current costing rule starting date was truncated and closing and opening inventories created by costing rule validation were taken, so stock was zero.
Now, current costing rule starting date will not be truncated and only opening inventory created by costing rule validation will be taken, then stock will be the same as before the costing rule.

---
M src/org/openbravo/erpCommon/ad_reports/ReportValuationStock.java
M src/org/openbravo/erpCommon/ad_reports/ReportValuationStock_data.xsql
---
(0086620)
dmiguelez (developer)
2016-05-20 13:32

Code Review + Testing Ok
(0087549)
hudsonbot (developer)
2016-06-17 19:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-05-19 16:32 ngarcia New Issue
2016-05-19 16:32 ngarcia Assigned To => Triage Finance
2016-05-19 16:32 ngarcia Modules => Core
2016-05-19 16:32 ngarcia Resolution time => 1465336800
2016-05-19 16:32 ngarcia Triggers an Emergency Pack => No
2016-05-19 17:10 ngarcia Issue Monitored: networkb
2016-05-19 17:17 ngarcia Description Updated View Revisions
2016-05-19 17:17 ngarcia Steps to Reproduce Updated View Revisions
2016-05-19 17:17 ngarcia Relationship added caused by 0031415
2016-05-20 09:30 aferraz Status new => scheduled
2016-05-20 09:30 aferraz Relationship deleted depends on 0033008
2016-05-20 10:11 aferraz Assigned To Triage Finance => aferraz
2016-05-20 11:04 aferraz Note Added: 0086596
2016-05-20 13:29 hgbot Checkin
2016-05-20 13:29 hgbot Note Added: 0086617
2016-05-20 13:29 hgbot Status scheduled => resolved
2016-05-20 13:29 hgbot Resolution open => fixed
2016-05-20 13:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/98ac1279b215ca0f41ca2844a584b4a7fa315082 [^]
2016-05-20 13:32 dmiguelez Review Assigned To => dmiguelez
2016-05-20 13:32 dmiguelez Note Added: 0086620
2016-05-20 13:32 dmiguelez Status resolved => closed
2016-05-23 12:57 aferraz Regression level => Production - QA Approved
2016-05-23 12:57 aferraz Regression date => 2015-11-27
2016-05-23 12:57 aferraz Regression introduced in release => 3.0PR16Q1
2016-05-23 12:57 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/92d905a6c013 [^]
2016-05-23 12:58 aferraz Fixed in Version => 3.0PR16Q3
2016-05-23 12:58 aferraz Target Version => 3.0PR16Q3
2016-06-17 19:37 hudsonbot Checkin
2016-06-17 19:37 hudsonbot Note Added: 0087549


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker