Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032923
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2016-05-11 10:562016-06-17 19:37
ReportercaristuView Statuspublic 
Assigned ToNaroaIriarte 
PriorityhighResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision4451654b2b92
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032923: NullPointerException in SelectorFieldPropertyCallout

DescriptionA NullPointerException is thrown in SelectorFieldPropertyCallout after selecting a computed column as a property to be shown as a selector field.

In this case, the callout execution is not completed successfully.
Steps To Reproduce1) As system role, go to [Reference] window
2) Create a new Reference with OBUISEL_Selector Reference as parent reference
3) Navigate to [Defined Selector] tab, create a new record:
  - Name: order
  - Table: Order
  - Template: Selector Template
4) Navigate to [Defined Selector] tab, create a new record:
  - Select a computed column as the property for the field, for example _computedColumns.deliveryStatus. The error mentioned above is thrown in the log.
Proposed SolutionPrevent NullPointerException in line 108 of SelectorFieldPropertyCallout, for example by checking if currentEntity is null before doing currentEntity.getProperty(part)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0086503)
hgbot (developer)
2016-05-17 16:31

Repository: erp/devel/pi
Changeset: 4451654b2b92a21c56a163451b37c569ed57d425
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Mon May 16 15:57:17 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4451654b2b92a21c56a163451b37c569ed57d425 [^]

Fixed issue 32923: There was a NPE in the SelectorFieldPropertyCallout

There was a NullpointerException in the SelectorFieldPropertyCallout because
in the printPage method, there was not being taken into account the fact of
having a property of a computed column and the entity was not correctly retrieved.
This have been fixed checking if it is a computed column and generating the entity
correctly if so.

---
M modules/org.openbravo.userinterface.selector/src/org/openbravo/userinterface/selector/SelectorFieldPropertyCallout.java
---
(0086586)
alostale (developer)
2016-05-20 08:02

code reviewed + tested
(0087541)
hudsonbot (developer)
2016-06-17 19:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-05-11 10:56 caristu New Issue
2016-05-11 10:56 caristu Assigned To => platform
2016-05-11 10:56 caristu Modules => Core
2016-05-11 10:56 caristu Triggers an Emergency Pack => No
2016-05-11 10:57 caristu Severity minor => major
2016-05-11 10:57 caristu Description Updated View Revisions
2016-05-13 10:53 NaroaIriarte Assigned To platform => NaroaIriarte
2016-05-13 10:53 NaroaIriarte Status new => acknowledged
2016-05-17 16:31 hgbot Checkin
2016-05-17 16:31 hgbot Note Added: 0086503
2016-05-17 16:31 hgbot Status acknowledged => resolved
2016-05-17 16:31 hgbot Resolution open => fixed
2016-05-17 16:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4451654b2b92a21c56a163451b37c569ed57d425 [^]
2016-05-20 08:02 alostale Review Assigned To => alostale
2016-05-20 08:02 alostale Note Added: 0086586
2016-05-20 08:02 alostale Status resolved => closed
2016-05-20 08:02 alostale Fixed in Version => 3.0PR16Q3
2016-06-17 19:37 hudsonbot Checkin
2016-06-17 19:37 hudsonbot Note Added: 0087541


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker