Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032902
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-05-09 11:262016-12-16 18:39
ReporterlorenzofidalgoView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revisione47c128a3513
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tocaristu
Web browserGoogle Chrome, Mozilla Firefox
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032902: SelectAll checkbox is not currently active in all flows when all lines are selected in grid

DescriptionSelectAll checkbox is not correctly activated if all records are selected under some circumstances. Besides, clicking once selectAll in that moment has not effect. (In the following video, you can check that behaviour between 1:08 and 1:14 https://drive.google.com/a/openbravo.com/file/d/0Bz1bUfkEffVIY2phT0NORldSS00/view [^] )
This behaviour is, currently, breaking some QA automated tests.
Steps To Reproduce0-Login ERP as QAAdmin//QAAdmin.
1-Using QA Testing Admin role, go to "Payment Proposal" window.
2-Create new record in form using the following values:
--
Organization: Spain
Paying From: Spain Bank - EUR
--
Save the record.
3-Click "Select Expected Payments" process, select all records and click "Submit".
4-Click "Generate Payments" process. Once the popup has appeared, with "Group separate payments for the same vendor into one payment" option selected, click "Process" button.
5-Click "Reactivate" process button and once the popup has appeared, with "Reactivate" Action selected, click "Process" button.
6-Now, click "Select Expected Payments" process button. All records will be selected, but selectAll checkbox is not selected. That checkbox should be selected. In that circumstances, clicking selectAll checkbox has not effect in the application.
TagsNo tags attached.
Attached Filespng file icon selectAllCheckboxNotSelected.png [^] (256,294 bytes) 2016-05-09 11:26

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0032904 acknowledgedplatform SelectAll checkbox in deselected if a filter column is clicked to sort 
related to defect 0033552 acknowledgedplatform The selectAll checkbox is not working fine 

-  Notes
(0092316)
inigosanchez (developer)
2016-12-13 13:39
edited on: 2016-12-14 00:30

Test plan:
- Flow described in steps to reproduce.
- Login with F&B International Admin. Return Material receipt Window. Open P&E without lines.
- Login with F&B International Admin. Create a Return From Customer and Booked. Return Material receipt Window. Open P&E with not selected lines.
- Login with F&B International Admin. Create a Return From Customer and Booked. Return Material receipt Window. Open P&E with all lines selected.

Results:
- All flows work as expected.

(0092330)
hgbot (developer)
2016-12-14 00:30

Repository: erp/devel/pi
Changeset: e47c128a35133072f21ffa2eec09c11e14578fbe
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Dec 14 00:21:05 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e47c128a35133072f21ffa2eec09c11e14578fbe [^]

Fixes issue 32902: SelectAll checkbox is not currently active in all flows

The problem was that SelectAll checkbox was not currently active in P&E windows when all
lines were selected in grid.

The problem has been resolved by using updateCheckboxHeaderState() function. This function
update the state of the SelectAll checkbox when a P&E window have selected all of their lines.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0092479)
caristu (developer)
2016-12-16 12:20

Code reviewed + testing OK: "SelectAll" checkbox is now checked off when the P&E is opened having selected all its records.
(0092705)
hudsonbot (developer)
2016-12-16 18:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8bf00badd0 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-05-09 11:26 lorenzofidalgo New Issue
2016-05-09 11:26 lorenzofidalgo Assigned To => platform
2016-05-09 11:26 lorenzofidalgo File Added: selectAllCheckboxNotSelected.png
2016-05-09 11:26 lorenzofidalgo Web browser => Google Chrome, Mozilla Firefox
2016-05-09 11:26 lorenzofidalgo Modules => Core
2016-05-09 11:26 lorenzofidalgo Triggers an Emergency Pack => No
2016-05-09 11:27 lorenzofidalgo Web browser Google Chrome, Mozilla Firefox => Google Chrome, Mozilla Firefox
2016-05-09 11:27 lorenzofidalgo Description Updated View Revisions
2016-05-09 12:17 lorenzofidalgo Relationship added related to 0032904
2016-06-02 15:13 lorenzofidalgo Issue Monitored: lorenzofidalgo
2016-07-15 10:15 alostale Status new => acknowledged
2016-11-07 12:43 plujan Issue Monitored: plujan
2016-11-30 10:37 inigosanchez Assigned To platform => inigosanchez
2016-11-30 14:49 inigosanchez Status acknowledged => scheduled
2016-12-01 12:41 alostale Relationship added related to 0033552
2016-12-01 13:20 alostale Priority high => normal
2016-12-13 13:39 inigosanchez Note Added: 0092316
2016-12-14 00:30 hgbot Checkin
2016-12-14 00:30 hgbot Note Added: 0092330
2016-12-14 00:30 hgbot Status scheduled => resolved
2016-12-14 00:30 hgbot Resolution open => fixed
2016-12-14 00:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e47c128a35133072f21ffa2eec09c11e14578fbe [^]
2016-12-14 00:30 inigosanchez Note Edited: 0092316 View Revisions
2016-12-14 00:42 inigosanchez Review Assigned To => caristu
2016-12-14 00:42 inigosanchez Web browser Google Chrome, Mozilla Firefox => Google Chrome, Mozilla Firefox
2016-12-16 12:20 caristu Note Added: 0092479
2016-12-16 12:20 caristu Status resolved => closed
2016-12-16 12:20 caristu Fixed in Version => 3.0PR17Q1
2016-12-16 18:39 hudsonbot Checkin
2016-12-16 18:39 hudsonbot Note Added: 0092705


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker