Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032668
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajorunable to reproduce2016-04-14 14:222016-06-17 19:37
ReporterngarciaView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revisione5e6126fc21b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR16Q1SCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-07-16
Regression introduced in release3.0PR15Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/8860b648abb2 [^]
Triggers an Emergency PackNo
Summary

0032668: Wrong Total Gross Amount, Total Net Amount and Tax information is obtained in order and invoices

DescriptionWrong Total Gross Amount, Total Net Amount and Tax information is obtained in order and invoices. Before 3.0PR15Q4 the problem could be solved by reactivating and processing the document. After the following commit

https://issues.openbravo.com/view.php?id=28366 [^]

the only option is to delete the whole document (header and lines)
Steps To ReproduceIn order to easily reproduce in a local instance, set browser's network throttling to ie. Regular 3G (100ms, 750kb/s, 250kb/s)

0. Login as group admin role
1. Create a Sales Order
2. Add a line to it and click on Book button
3. Before booking it keep the mouse in the New toolbar button
4. Press enter and at the same time click on the New button sometimes
    -> ERROR 1: Check the new header is created with the values of the old record in the status bar fields
            * Status: Booked
            * Total Amounts: The values in previous document
6. Fill in mandatory fields in header
7. Save header. See different behavior depending on the version:
   7.1. 3.0PR15Q4-3.0PR16Q1
     -> ERROR 2: status bar values:
          * Status: Draft (OK)
          * Total Amounts: Previous values are kept (ERROR)
   7.2. >=3.0PR16Q2
      -> OK: status bar values are reset:
          * Status: Draft
          * Total Amounts: 0


Error 7.2 is caused because in the save request numeric values are sending an outdated textualValue property, this property was removed in 16Q2 by fix for 0031901.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031901 closedcaristu decimal value can't be changed by trigger/observer after manual edition in form view 
related to defect 0020474 closedmtaal When you save a register in grid view, amounts fields change to the previous value 
depends on backport 00327793.0PR16Q2 closedplatform Wrong Total Gross Amount, Total Net Amount and Tax information is obtained in order and invoices 
depends on backport 00327803.0PR16Q1.1 closedplatform Wrong Total Gross Amount, Total Net Amount and Tax information is obtained in order and invoices 
depends on backport 00327813.0PR15Q4.6 closedplatform Wrong Total Gross Amount, Total Net Amount and Tax information is obtained in order and invoices 
caused by feature request 0028366 closedadrianromero Add new functionality to calculate taxes per product BOM 
related to defect 0036454 closedalostale editing in grid record can be saved before callouts are applied 

-  Notes
(0085954)
ngarcia (developer)
2016-04-25 11:41

Sometimes, the difference is the total amount of the previously created record. It seems the record is created with a value different from 0 in the total fields of the header
(0085995)
hgbot (developer)
2016-04-26 15:59

Repository: erp/devel/pi
Changeset: e5e6126fc21b6f2e5ad3ecaed5bc0429335342fb
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Apr 26 10:47:23 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e5e6126fc21b6f2e5ad3ecaed5bc0429335342fb [^]

fixed bug 32668: wrong values displayed in status bar on record creation

  When a new record is created just after processing a previous one, status bar
  displayed valued of the previous record instead of being in New mode.

  Fixed by forcing status bar reset on FIC response for NEW.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0086001)
caristu (developer)
2016-04-26 17:30

Code review + testing OK, after following the steps the status bar is in new status
(0086169)
alostale (developer)
2016-05-04 08:31

Test link: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10018 [^]
(0087492)
hudsonbot (developer)
2016-06-17 19:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-04-14 14:22 ngarcia New Issue
2016-04-14 14:22 ngarcia Assigned To => Triage Finance
2016-04-14 14:22 ngarcia Modules => Core
2016-04-14 14:22 ngarcia Triggers an Emergency Pack => No
2016-04-14 14:22 ngarcia Issue Monitored: networkb
2016-04-25 11:41 ngarcia Note Added: 0085954
2016-04-25 13:13 ngarcia Resolution time => 1464127200
2016-04-25 18:16 ngarcia Steps to Reproduce Updated View Revisions
2016-04-25 18:38 ngarcia Assigned To Triage Finance => platform
2016-04-25 18:38 ngarcia Priority urgent => immediate
2016-04-25 18:38 ngarcia version => 3.0PR16Q1
2016-04-26 08:39 egoitz Issue Monitored: egoitz
2016-04-26 08:42 alostale Relationship added related to 0031901
2016-04-26 08:42 alostale Relationship added caused by 0028366
2016-04-26 08:50 alostale Steps to Reproduce Updated View Revisions
2016-04-26 08:56 alostale Steps to Reproduce Updated View Revisions
2016-04-26 08:56 alostale Steps to Reproduce Updated View Revisions
2016-04-26 09:30 alostale Relationship added related to 0020474
2016-04-26 09:50 alostale Status new => scheduled
2016-04-26 09:50 alostale Assigned To platform => alostale
2016-04-26 10:38 alostale Regression level => Production - Confirmed Stable
2016-04-26 10:38 alostale Regression date => 2015-07-16
2016-04-26 10:38 alostale Regression introduced in release => 3.0PR15Q4
2016-04-26 10:38 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/8860b648abb2 [^]
2016-04-26 10:38 alostale Steps to Reproduce Updated View Revisions
2016-04-26 11:05 alostale Review Assigned To => caristu
2016-04-26 12:18 jfrances Issue Monitored: jfrances
2016-04-26 15:59 hgbot Checkin
2016-04-26 15:59 hgbot Note Added: 0085995
2016-04-26 15:59 hgbot Status scheduled => resolved
2016-04-26 15:59 hgbot Resolution open => fixed
2016-04-26 15:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e5e6126fc21b6f2e5ad3ecaed5bc0429335342fb [^]
2016-04-26 17:30 caristu Note Added: 0086001
2016-04-26 17:30 caristu Status resolved => closed
2016-04-26 17:30 caristu Fixed in Version => 3.0PR16Q3
2016-05-04 08:31 alostale Note Added: 0086169
2016-06-17 19:37 hudsonbot Checkin
2016-06-17 19:37 hudsonbot Note Added: 0087492
2017-07-11 09:06 alostale Relationship added related to 0036454


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker