Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0020474
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2012-05-11 12:502012-05-28 13:56
ReporterxabiermerinoView Statuspublic 
Assigned Tomtaal 
PriorityimmediateResolutionfixedFixed in Version3.0MP12
StatusclosedFix in branchFixed in SCM revisiona821c504f959
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned To
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0020474: When you save a register in grid view, amounts fields change to the previous value

DescriptionWhen you save a register in grid view amounts fields change to 0
Steps To ReproduceExample 1:
- As admin create a sales invoice and go to lines
- Save a line in form view.
- Change the Invoiced Quantity and the Net Unit Price in grid view
- Save the line (using the save button of the file or the button of the toolbar)
- Realize that thes fields change to the previous value

Example 2:
- Go to financial account and insert a row
- Introduce a 100 as Current Balance
- Save
- Realize that the current balance is 0
TagsRegression QA
Attached Filesdiff file icon 20474.diff [^] (16,646 bytes) 2012-05-16 11:59 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 0020500 closedalostale Price List values roll back to old values 
has duplicate defect 00205193.0MP12 closedmtaal Line created in grid is not saved when navigating back to header 
related to defect 0020524 closedSandrahuguet get a null error when saving an invoice line 
related to defect 0031901 closedcaristu decimal value can't be changed by trigger/observer after manual edition in form view 
related to defect 0032668 closedalostale Wrong Total Gross Amount, Total Net Amount and Tax information is obtained in order and invoices 
related to defect 0036454 closedalostale editing in grid record can be saved before callouts are applied 

-  Notes
(0048599)
hgbot (developer)
2012-05-13 22:46

Repository: erp/devel/pi
Changeset: 3e863f6c3a4141923d62e4ee0699e8111da5b9d5
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Sun May 13 22:46:18 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3e863f6c3a4141923d62e4ee0699e8111da5b9d5 [^]

Fixes issue 20474: When you save a register in grid view, amounts fields change to the previous value
The wrong id was used to get the editvalues object of a row, the rownumber should be used.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0048662)
alostale (developer)
2012-05-15 18:01

Still can be reproduced following scenarios in steps to reproduce as well as the reported in 0020500
(0048686)
mtaal (developer)
2012-05-16 11:42

The bug/issue occurs but example 2 is not completely valid. The value can be set but after save it is set back to zero, this is because of logic in triggers probably.
This can be seen in main also. So example 2 can not be used to reproduce this issue.
For another example see this issue:
https://issues.openbravo.com/view.php?id=20500 [^]

gr. Martin
(0048687)
mtaal (developer)
2012-05-16 11:50

Note this issue occurs because in the ListGrid.js the getEditValues method always returns a new object, so not the object internally used in the ListGrid. This means that any changes made to the edit values object returned from getEditValues are not persisted/retained.
See here:
http://forums.smartclient.com/showthread.php?p=86378#post86378 [^]

To solve this direct access to the edit values object should not be done, the attached diff repairs this. But as the changes are in several places I will wait applying it until Isomorphic replies to the thread above.

gr. Martin
(0048690)
mtaal (developer)
2012-05-16 12:02

Note the attached diff has not been tested extensively, this needs to be done. The following needs to be tested:
- date field in form/grid editing (autocomplete and pick a date from the calendar)
- password field in grid editing and form editing
- fields with a FicCall, test this with a simulated slow network like this for example:
(https://issues.openbravo.com/view.php?id=20328 [^])
In order to simulate a slow network, place a Thread.sleep(2000) in the execute method of the FIC. Then do the following:
    Place the Thread.sleep(2000) in the FIC
    Open the Sales Order window
    Create a new record in the grid
    Select a Business Partner and immediately click in the Lines Tab

- test issue 20500
- test issue 20519
(0048725)
hgbot (developer)
2012-05-17 11:57

Repository: erp/devel/pi
Changeset: a821c504f959ae2b8f3eb1fd69af1964b69951ad
Author: Martin Taal <martin.taal <at> openbravo.com>
Date: Thu May 17 11:56:12 2012 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a821c504f959ae2b8f3eb1fd69af1964b69951ad [^]

Fixes issue 20474: When you save a register in grid view, amounts fields change to the previous value
Object returned from ListGrid.getEditValues can't be used directly always go through the ListGrid api
For example: ListGrid.setEditValue

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-date.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-encrypted.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0049107)
hudsonbot (developer)
2012-05-25 12:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5401e185a8b0 [^]

Maturity status: Test
(0049155)
hudsonbot (developer)
2012-05-25 12:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5401e185a8b0 [^]

Maturity status: Test
(0049369)
AugustoMauch (developer)
2012-05-28 13:56

Code reviewed and verified in pi@ff800550e531

- Issue History
Date Modified Username Field Change
2012-05-11 12:50 xabiermerino New Issue
2012-05-11 12:50 xabiermerino Assigned To => alostale
2012-05-11 12:50 xabiermerino Modules => Core
2012-05-11 14:33 xabiermerino Steps to Reproduce Updated View Revisions
2012-05-11 14:38 jonalegriaesarte Tag Attached: Regression QA
2012-05-13 22:46 hgbot Checkin
2012-05-13 22:46 hgbot Note Added: 0048599
2012-05-13 22:46 hgbot Status new => resolved
2012-05-13 22:46 hgbot Resolution open => fixed
2012-05-13 22:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3e863f6c3a4141923d62e4ee0699e8111da5b9d5 [^]
2012-05-15 08:51 alostale Relationship added has duplicate 0020500
2012-05-15 18:01 alostale Assigned To alostale => mtaal
2012-05-15 18:01 alostale Note Added: 0048662
2012-05-15 18:01 alostale Status resolved => new
2012-05-15 18:01 alostale Resolution fixed => open
2012-05-15 23:02 dbaz Relationship added related to 0020519
2012-05-16 11:42 mtaal Note Added: 0048686
2012-05-16 11:50 mtaal Note Added: 0048687
2012-05-16 11:50 mtaal File Added: 20474.diff
2012-05-16 11:51 mtaal File Deleted: 20474.diff
2012-05-16 11:59 mtaal File Added: 20474.diff
2012-05-16 12:02 mtaal Note Added: 0048690
2012-05-17 09:16 Sandrahuguet Relationship added related to 0020524
2012-05-17 11:57 hgbot Checkin
2012-05-17 11:57 hgbot Note Added: 0048725
2012-05-17 11:57 hgbot Status new => resolved
2012-05-17 11:57 hgbot Resolution open => fixed
2012-05-17 11:57 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/3e863f6c3a4141923d62e4ee0699e8111da5b9d5 [^] => http://code.openbravo.com/erp/devel/pi/rev/a821c504f959ae2b8f3eb1fd69af1964b69951ad [^]
2012-05-17 11:58 mtaal Relationship replaced has duplicate 0020519
2012-05-25 12:11 hudsonbot Checkin
2012-05-25 12:11 hudsonbot Note Added: 0049107
2012-05-25 12:12 hudsonbot Checkin
2012-05-25 12:12 hudsonbot Note Added: 0049155
2012-05-28 13:56 AugustoMauch Note Added: 0049369
2012-05-28 13:56 AugustoMauch Status resolved => closed
2012-05-28 13:56 AugustoMauch Fixed in Version => 3.0MP12
2016-01-25 12:52 caristu Relationship added related to 0031901
2016-04-26 09:30 alostale Relationship added related to 0032668
2017-07-11 09:05 alostale Relationship added related to 0036454


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker