Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032437
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 07. Sales managementmajoralways2016-03-07 16:562016-03-10 20:36
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revision44e1aca856d3
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-07-16
Regression introduced in release3.0PR15Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/8860b648abb2 [^]
Triggers an Emergency PackNo
Summary

0032437: Wrong Tax Amount and Total Gross Amount in orders created by the Copy Record process if price list includes taxes

DescriptionWrong Tax Amount and Total Gross Amount in orders created by the Copy Record process if price list includes taxes
Steps To ReproduceAs group admin role:
   Create a Sales Price List
   Set it as Price Includes Tax
   Add a version and a product to it
   Create a Sales Order with that price list and product and book it
   Click on the Copy record button of the toolbar and check the Total Gross Amount field of the status bar is wrong
   The tax amount of the tax tab is also wrong
   Book it and check the values do not change
   Repeat the process in the purchase flow and check the problem is also reproducible
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0032428 closedmarkmm82 Wrong Tax Amount and Total Gross Amount in orders created by the Copy Record process if price list includes taxes 

-  Notes
(0084852)
markmm82 (developer)
2016-03-09 18:40

Test plan:
As group admin role:
   Create a Sales Price List
   Set it as Price Includes Tax
   Add a version and a product to it
   Create a Sales Order with that price list and product and book it
   Click on the Copy record button of the toolbar and check the Total Gross Amount field of the status bar are the same like the original.
   The tax amount of the tax tab is also right
   Book it and check the values do not change (everything was calculated where cloning, including taxes)
   Repeat the process in the purchase flow and check the problem is also corrected.
(0084887)
hgbot (developer)
2016-03-10 20:36

Repository: erp/backports/3.0PR16Q1
Changeset: 44e1aca856d34c06c68725cc18c3ca3463401c6a
Author: Mark <m.molina <at> nectus.com>
Date: Wed Mar 09 18:53:24 2016 -0500
URL: http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/44e1aca856d34c06c68725cc18c3ca3463401c6a [^]

Fixes issue 32437: Wrong orders created by the Copy Record process

Fixed the wrong Tax Amount and Total Gross Amount calculation in orders created by the Copy Record process
if price list includes taxes. These amounts are calculated when related triggers are fired, due that when
the order is cloned from the original order was necessary to reset calculated amounts and then triggers updates
them again when lines are added to the cloned order.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/businesslogic/CloneOrderActionHandler.java
---
(0084888)
hgbot (developer)
2016-03-10 20:36

Repository: erp/backports/3.0PR16Q1
Changeset: f5662292ac13119d6ff90bd31dc8be101a647fba
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Mar 10 17:56:11 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/f5662292ac13119d6ff90bd31dc8be101a647fba [^]

Related to issue 32437: Code review improvements

Use BigDecimal.ZERO instead of new BigDecimal(0).

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/businesslogic/CloneOrderActionHandler.java
---
(0084889)
aferraz (developer)
2016-03-10 20:36

Code review + Testing OK

- Issue History
Date Modified Username Field Change
2016-03-08 18:17 aferraz Type defect => backport
2016-03-08 18:17 aferraz Target Version => 3.0PR16Q1
2016-03-09 18:40 markmm82 Note Added: 0084852
2016-03-10 20:36 hgbot Checkin
2016-03-10 20:36 hgbot Note Added: 0084887
2016-03-10 20:36 hgbot Status scheduled => resolved
2016-03-10 20:36 hgbot Resolution open => fixed
2016-03-10 20:36 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/44e1aca856d34c06c68725cc18c3ca3463401c6a [^]
2016-03-10 20:36 hgbot Checkin
2016-03-10 20:36 hgbot Note Added: 0084888
2016-03-10 20:36 aferraz Review Assigned To => aferraz
2016-03-10 20:36 aferraz Note Added: 0084889
2016-03-10 20:36 aferraz Status resolved => closed
2016-03-10 20:36 aferraz Fixed in Version => 3.0PR16Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker