Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032429
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-03-07 18:332016-03-17 10:56
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revisionc89d61d6ab14
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032429: Add error log in the remove function of DefaultJsonDataService class

DescriptionAdd error log in the remove function of DefaultJsonDataService class. Currently the following error is shown in the application if an error is raised during the deleting of a record (for example: NullPointerException in an eventhandler):

Server returned FAILURE with no error message

and the log shows no error
Steps To Reproduce*
Proposed SolutionAdd the log.error(t.getMessage(), t); sentence in the catch section of the remove function:

    } catch (Throwable t) {
      log.error(t.getMessage(), t);
      return JsonUtils.convertExceptionToJson(t);
    }
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0084792)
hgbot (developer)
2016-03-07 19:19

Repository: erp/devel/pi
Changeset: c89d61d6ab14a51b3ea8dff0dfaf2c51bd4a9ee4
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Mar 07 19:15:00 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c89d61d6ab14a51b3ea8dff0dfaf2c51bd4a9ee4 [^]

fixes issue 32429: Added error log in remove method of DefaultJsonDataService

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
---
(0084803)
alostale (developer)
2016-03-08 09:02

reopening after code review because:

1. if condition is unnecessary overcomplicated
2. log should add some context
(0084807)
hgbot (developer)
2016-03-08 09:38

Repository: erp/devel/pi
Changeset: e9790863827331887dd7d3c7e661dd96334fedb6
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Mar 08 09:36:55 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e9790863827331887dd7d3c7e661dd96334fedb6 [^]

related to issue 32429: code review improvements

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
---
(0084897)
alostale (developer)
2016-03-11 08:24

code reviewed
(0085187)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085190)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-03-07 18:33 ngarcia New Issue
2016-03-07 18:33 ngarcia Assigned To => platform
2016-03-07 18:33 ngarcia Modules => Core
2016-03-07 18:33 ngarcia Triggers an Emergency Pack => No
2016-03-07 18:44 ngarcia Issue Monitored: networkb
2016-03-07 19:18 caristu Assigned To platform => caristu
2016-03-07 19:19 hgbot Checkin
2016-03-07 19:19 hgbot Note Added: 0084792
2016-03-07 19:19 hgbot Status new => resolved
2016-03-07 19:19 hgbot Resolution open => fixed
2016-03-07 19:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c89d61d6ab14a51b3ea8dff0dfaf2c51bd4a9ee4 [^]
2016-03-07 19:20 caristu Review Assigned To => alostale
2016-03-08 09:02 alostale Note Added: 0084803
2016-03-08 09:02 alostale Status resolved => new
2016-03-08 09:02 alostale Resolution fixed => open
2016-03-08 09:37 caristu Issue Monitored: alostale
2016-03-08 09:38 hgbot Checkin
2016-03-08 09:38 hgbot Note Added: 0084807
2016-03-08 09:38 caristu Status new => scheduled
2016-03-08 09:38 caristu Status scheduled => resolved
2016-03-08 09:38 caristu Resolution open => fixed
2016-03-11 08:24 alostale Note Added: 0084897
2016-03-11 08:24 alostale Status resolved => closed
2016-03-11 08:24 alostale Fixed in Version => 3.0PR16Q2
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085187
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085190


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker