Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032268
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2016-02-17 19:512016-04-08 11:00
ReportermaiteView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision143d5c808926
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-09-23
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
Triggers an Emergency PackNo
Summary

0032268: Wrong payment status when unmatching bankstatement line manually matched against an invoice

DescriptionWrong payment status when unmatching bankstatement line manually matched against an invoice
Steps To Reproduce0. Configure "Bank" financial account to use "Advanced Matching algorithm"
1. Access Financial Account, create Bank Statement record and add line with amount in =100. Process bank statement
2. Register Sales invoice with any line and total invoice amount = 100
3. Come back to Financial Account and run "Match Statement" process
4. Select "Cancel" option to not execute automatic matching
5. Run "add transaction" process by pressing + button
6. Create payment by pressing "+" button in payment's selector and select your invoice. Process Done and Done to finish with matching process
7. Filter in the grid by "matched=yes" records and unmatch record. Press OK to save reconciliation
8. Realize that transaction has correct status "deposited not cleared"
9. Navigate to related payment in and realize that status is "payment cleared" instead of "deposited not cleared"

NOTE: I followed same steps in an standard MP30.3 version and both payment and transaction has status "deposited not cleared"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00322983.0PR16Q1 closedAtulOpenbravo Wrong payment status when unmatching bankstatement line manually matched against an invoice 
depends on backport 00322993.0PR15Q4.4 closedAtulOpenbravo Wrong payment status when unmatching bankstatement line manually matched against an invoice 
depends on backport 00323003.0PR15Q3.6 closedAtulOpenbravo Wrong payment status when unmatching bankstatement line manually matched against an invoice 
caused by feature request 00293903.0PR14Q4 closedSandrahuguet Reconciliation refactor project 

-  Notes
(0084399)
AtulOpenbravo (developer)
2016-02-22 11:13
edited on: 2016-02-22 14:40

Test Plan
- Configure "Bank" financial account to use "Advanced Matching algorithm"
- Access Financial Account, create Bank Statement record and add line with amount in =100. Process bank statement
- Register Sales invoice with any line and total invoice amount = 100
- Come back to Financial Account and run "Match Statement" process
- Select "Cancel" option to not execute automatic matching
- Remove the filter.
- Run "add transaction" process by pressing + button
- Create payment by pressing "+" button in payment's selector and select your invoice. Process Done and Done to finish with matching process
- Filter in the grid by "matched=yes" records and unmatch record. Press OK to save reconciliation
- Check that financial account transaction has correct status "deposited not cleared".
- Go to related payment in and check that status is "deposited not cleared" which is correct.
- Match the payment and the statement line and check that payment status changes to "Payment Cleared" same as Financial Account Transaction.

Repeat same flow for purchase out, therefore Status is "Withdrawn not Cleared" for both payment out created and financial account transaction.

(0084405)
psanjuan (manager)
2016-02-22 14:08

Issue verified.
(0084407)
psanjuan (manager)
2016-02-22 14:42

Test plan above verified.

Issue can be code reviewed and closed.
(0084410)
vmromanos (developer)
2016-02-22 18:00

Verified also with the new "Unmatch Selected" process
(0084422)
hgbot (developer)
2016-02-23 14:00

Repository: erp/devel/pi
Changeset: 143d5c8089260d63d8f645b73c5cf43bf1216828
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Mon Feb 22 15:33:27 2016 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/143d5c8089260d63d8f645b73c5cf43bf1216828 [^]

Fixes Issue 32268: Wrong payment status when unmatching bankstatement line
manually matched against an invoice

Incase a finTransaction is unmatched which has finPayment,status of finPayment
is also updated accordingly as per isReceipt flag

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/utility/APRM_MatchingUtility.java
---
(0084429)
vmromanos (developer)
2016-02-23 14:02

Code review + testing OK
(0084697)
aferraz (developer)
2016-03-03 18:53

Tests in TestLink:

https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10003 [^]

https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-10004 [^]
(0085162)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085527)
hgbot (developer)
2016-04-08 11:00

Repository: tools/automation/int
Changeset: a0e4097727b38183d7209a473e0e709f9b5bfea5
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Mar 09 19:05:46 2016 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/a0e4097727b38183d7209a473e0e709f9b5bfea5 [^]

Related to issue 32268: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/data/financial/receivablespayables/transactions/AddPaymentPopUpData.java
M src-test/com/openbravo/test/integration/erp/data/financial/receivablespayables/transactions/bankstatement/BankStatementHeaderData.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/gui/FormInputFieldFactory.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRIn_Regressions/APRIn_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRIn_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APROut_Regressions/APROut_RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APROut_Regressions/build.xml
A src-test/com/openbravo/test/integration/erp/modules/client/application/gui/searchitems/FinaccTransactionSearchItem.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRIn_Regressions/APRRegression32268In.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APROut_Regressions/APRRegression32268Out.java
---

- Issue History
Date Modified Username Field Change
2016-02-17 19:51 maite New Issue
2016-02-17 19:51 maite Assigned To => Triage Finance
2016-02-17 19:51 maite Issue Monitored: networkb
2016-02-17 19:52 maite Steps to Reproduce Updated View Revisions
2016-02-22 10:26 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2016-02-22 10:26 AtulOpenbravo Status new => scheduled
2016-02-22 10:39 AtulOpenbravo Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/179d97ee602d [^]
2016-02-22 10:39 AtulOpenbravo Regression level => Production - Confirmed Stable
2016-02-22 10:41 AtulOpenbravo Relationship added caused by 0029390
2016-02-22 10:41 AtulOpenbravo Status scheduled => acknowledged
2016-02-22 10:45 vmromanos Project Modules => Openbravo ERP
2016-02-22 10:46 vmromanos Modules => Core
2016-02-22 10:46 vmromanos Triggers an Emergency Pack => No
2016-02-22 10:46 vmromanos Category Advanced Matching Algorithm => 09. Financial management
2016-02-22 10:46 AtulOpenbravo Status acknowledged => scheduled
2016-02-22 10:47 AtulOpenbravo Regression date => 2014-09-23
2016-02-22 10:52 AtulOpenbravo Regression introduced in release => 3.0PR14Q4
2016-02-22 11:13 AtulOpenbravo Note Added: 0084399
2016-02-22 14:08 psanjuan Note Added: 0084405
2016-02-22 14:27 psanjuan Note Edited: 0084399 View Revisions
2016-02-22 14:33 psanjuan Note Edited: 0084399 View Revisions
2016-02-22 14:40 psanjuan Note Edited: 0084399 View Revisions
2016-02-22 14:42 psanjuan Note Added: 0084407
2016-02-22 18:00 vmromanos Note Added: 0084410
2016-02-23 14:00 hgbot Checkin
2016-02-23 14:00 hgbot Note Added: 0084422
2016-02-23 14:00 hgbot Status scheduled => resolved
2016-02-23 14:00 hgbot Resolution open => fixed
2016-02-23 14:00 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/143d5c8089260d63d8f645b73c5cf43bf1216828 [^]
2016-02-23 14:02 vmromanos Review Assigned To => vmromanos
2016-02-23 14:02 vmromanos Note Added: 0084429
2016-02-23 14:02 vmromanos Status resolved => closed
2016-03-03 18:53 aferraz Note Added: 0084697
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085162
2016-04-08 11:00 hgbot Checkin
2016-04-08 11:00 hgbot Note Added: 0085527


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker