Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032260
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2016-02-17 14:292016-08-11 18:40
ReporterinigosanchezView Statuspublic 
Assigned ToNaroaIriarte 
PriorityhighResolutionfixedFixed in Version3.0PR16Q4
StatusclosedFix in branchFixed in SCM revisionb1f17fd0957b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032260: Editing a record in grid view with a few visible columns doesnt work properly

DescriptionEditing a record in grid view with a few visible columns doesnt work properly. If there is a visible selector, for example business partner selector, the behaviour is correct.
Steps To Reproduce1.- Login as F&B International Admin.
2.- Go to Sales Order.
3.- Clear all filters.
3.- Make visible only the following columns:
3.1.- Organization.
3.2.- Document No.
4.- Click on pencil button for edit any record in grid view.
5.- Click on pencil button of another record.
5.1.- Check that previous record is opened yet. This behaviour is not correct.
5.2.- New record is opened too. It is not possible to close these records.
6.- Now make visible "Business Partner" selector.
7.- Click on pencil button for edit any record in grid view.
8.- Click on pencil button of another record.
8.1.- Check that previous record is closed. This works properly.
8.2.- New record is ready for editing in grid view.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0033452 acknowledgedplatform refresh grid can cause edit icons to disappear 

-  Notes
(0088231)
NaroaIriarte (developer)
2016-07-06 11:08

This happens only when every column of the record are read only.
But if one of those columns is a selector, even if it is read only, it works fine.
(0088257)
hgbot (developer)
2016-07-07 09:10

Repository: erp/devel/pi
Changeset: b1f17fd0957b749b078ffcb82d94dfe846f06173
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Wed Jul 06 17:52:48 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b1f17fd0957b749b078ffcb82d94dfe846f06173 [^]

Fixed issue 32260: Editing records in grid view was not working properly.

Editing in grid view was not working properly when all the fields of the record were readonly.
The problem was in "ob-view-grid.js" in the "startEditing" function. In this function, the focused field is set, but when every field is readonly there was not setting the value, so it was undefined. This was causing the failure.

To fix this a new condition has been added. Now, it is checked if the colNum is undefined and if the new function "isThereAnyEditableField" returns false. If these conditions are met, it means that the focus is not set yet and that there aren't any editable fields. Because if there were any editable fields, not setting the focus at that point would not be a problem, smartclient puts the focus there.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0088317)
alostale (developer)
2016-07-08 09:08

Code reviewed + tested
(0088995)
hudsonbot (developer)
2016-08-11 18:40

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/edaa05b1fb18 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-17 14:29 inigosanchez New Issue
2016-02-17 14:29 inigosanchez Assigned To => platform
2016-02-17 14:29 inigosanchez Modules => Core
2016-02-17 14:29 inigosanchez Triggers an Emergency Pack => No
2016-02-25 14:27 alostale Priority low => high
2016-02-25 14:27 alostale Severity minor => major
2016-02-25 14:27 alostale Status new => acknowledged
2016-06-23 10:10 NaroaIriarte Assigned To platform => NaroaIriarte
2016-07-06 11:08 NaroaIriarte Note Added: 0088231
2016-07-07 09:10 hgbot Checkin
2016-07-07 09:10 hgbot Note Added: 0088257
2016-07-07 09:10 hgbot Status acknowledged => resolved
2016-07-07 09:10 hgbot Resolution open => fixed
2016-07-07 09:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b1f17fd0957b749b078ffcb82d94dfe846f06173 [^]
2016-07-07 09:13 NaroaIriarte Review Assigned To => alostale
2016-07-07 09:13 NaroaIriarte Issue Monitored: NaroaIriarte
2016-07-07 09:14 NaroaIriarte Issue End Monitor: NaroaIriarte
2016-07-07 09:15 NaroaIriarte Issue Monitored: NaroaIriarte
2016-07-07 09:15 NaroaIriarte Issue End Monitor: NaroaIriarte
2016-07-08 09:08 alostale Note Added: 0088317
2016-07-08 09:08 alostale Status resolved => closed
2016-07-08 09:08 alostale Fixed in Version => 3.0PR16Q4
2016-07-08 09:13 alostale Relationship added related to 0033452
2016-08-11 18:40 hudsonbot Checkin
2016-08-11 18:40 hudsonbot Note Added: 0088995


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker