Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032247
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajorsometimes2016-02-15 18:522016-02-26 09:18
ReportervmromanosView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revisione91d7a38fa6b
ProjectionnoneETAnoneTarget Version3.0PR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPackaging and release
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032247: Read only logic doesn't work on some columns in grid view

DescriptionThe read only doesn't apply properly when a display logic or read only logic are applied in grid view. It is not take into account read only value.

This is a regression that affects Main and PI (Introduced by Grid Display Logic as Read Only project)
Steps To ReproduceAs Openbravo Admin go to Financial Account window
Select "Cuenta de Banco" and go to Transaction tab in grid mode
Clear the filters so the grid shows all the records.
Edit any processed record.
Verify Currency and Status columns can be edited. However these fields are set as Read Only in the Application Dictionary.
Open this record in form view and verify the Currency field is properly set as read only
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0032240 closedinigosanchez Read only logic doesn't work on some columns in grid view 

-  Notes
(0084479)
hgbot (developer)
2016-02-25 00:48

Repository: erp/backports/3.0PR16Q1
Changeset: e91d7a38fa6bbec99badef48ebf57740c6aee801
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Feb 25 00:33:12 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/e91d7a38fa6bbec99badef48ebf57740c6aee801 [^]

Fixes issue 32247: Read only doesn't work on some columns in grid view

The problem is caused because it was not take into account read only when other
logic (e.g. display logic) was being applied in an editing grid view.

In order to prevent this, it take into account when a field is checks as read
only. In this case, the field is show properly.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/templates/ob-view-form.js.ftl
---
(0084542)
alostale (developer)
2016-02-26 09:18

code reviewed

tested:
- in grid view editing an existing record
- in grid view creating a new record
- in form view editing an existing record
- in form view creating a new record

- Issue History
Date Modified Username Field Change
2016-02-16 15:04 alostale Type defect => backport
2016-02-16 15:04 alostale Target Version => 3.0PR16Q1
2016-02-25 00:41 inigosanchez Assigned To platform => inigosanchez
2016-02-25 00:41 inigosanchez Description Updated View Revisions
2016-02-25 00:47 inigosanchez Review Assigned To => alostale
2016-02-25 00:48 hgbot Checkin
2016-02-25 00:48 hgbot Note Added: 0084479
2016-02-25 00:48 hgbot Status scheduled => resolved
2016-02-25 00:48 hgbot Resolution open => fixed
2016-02-25 00:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/e91d7a38fa6bbec99badef48ebf57740c6aee801 [^]
2016-02-26 09:18 alostale Note Added: 0084542
2016-02-26 09:18 alostale Status resolved => closed
2016-02-26 09:18 alostale Fixed in Version => 3.0PR16Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker