Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032240
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorsometimes2016-02-15 18:522017-02-15 09:11
ReportervmromanosView Statuspublic 
Assigned Toinigosanchez 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision5066477d172a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2015-11-23
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/9f99e60411fcba42b78da7923bca7465ae71aa09 [^]
Triggers an Emergency PackNo
Summary

0032240: Read only logic doesn't work on some columns in grid view

DescriptionThe read only doesn't apply properly when a display logic or read only logic are applied in grid view. It is not take into account read only value.

This is a regression that affects Main and PI (Introduced by Grid Display Logic as Read Only project)
Steps To ReproduceAs Openbravo Admin go to Financial Account window
Select "Cuenta de Banco" and go to Transaction tab in grid mode
Clear the filters so the grid shows all the records.
Edit any processed record.
Verify Currency and Status columns can be edited. However these fields are set as Read Only in the Application Dictionary.
Open this record in form view and verify the Currency field is properly set as read only
TagsNo tags attached.
Attached Filespng file icon readonly_currency_status.png [^] (49,540 bytes) 2016-02-15 18:52

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00322473.0PR16Q1 closedinigosanchez Read only logic doesn't work on some columns in grid view 
caused by design defect 0024319 closedinigosanchez Grid mode should hide field content as per display logic rule 
related to defect 0032147 closednonofrancisco Payment field and Transaction Type fields of Financial Account Transaction tab should be read only once the record is processed 

-  Notes
(0084477)
hgbot (developer)
2016-02-25 00:47

Repository: erp/devel/pi
Changeset: 50d727a061775e9b8522c7df5f274732c9414583
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Feb 24 15:43:32 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/50d727a061775e9b8522c7df5f274732c9414583 [^]

Fixes issue 32240: Read only doesn't work on some columns in grid view

The problem is caused because it was not take into account read only when other
logic (e.g. display logic) was being applied in an editing grid view.

In order to prevent this, it take into account when a field is checks as read
only. In this case, the field is show properly.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/templates/ob-view-form.js.ftl
---
(0084478)
inigosanchez (developer)
2016-02-25 00:48

Added a test case in TestLink > Platform > [GDL] Grid Display Logic > [GDLa] Display logic in Grid > [GDLa050] Read Only and Display Logic. This test is automated.
(0084541)
alostale (developer)
2016-02-26 09:17

code reviewed

tested:
- in grid view editing an existing record
- in grid view creating a new record
- in form view editing an existing record
- in form view creating a new record
(0085167)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0090700)
guilleaer (developer)
2016-10-19 17:01

Reclosed.

It was reopened by mistake by me.
(0094343)
hgbot (developer)
2017-02-15 09:11

Repository: tools/automation/int
Changeset: 142e8aab204c3deea259ee3e657055eab9948785
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Feb 25 00:56:35 2016 +0100
URL: http://code.openbravo.com/tools/automation/int/rev/142e8aab204c3deea259ee3e657055eab9948785 [^]

added automated test for regression issue 32240

---
M src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/GridSuite.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/build.xml
A src-test/com/openbravo/test/integration/erp/modules/client/application/testsuites/standardview/grid/GDLa050_ReadOnlyAndDisplayLogic.java
---

- Issue History
Date Modified Username Field Change
2016-02-15 18:52 vmromanos New Issue
2016-02-15 18:52 vmromanos Assigned To => platform
2016-02-15 18:52 vmromanos File Added: readonly_currency_status.png
2016-02-15 18:52 vmromanos Modules => Core
2016-02-15 18:52 vmromanos Triggers an Emergency Pack => No
2016-02-15 18:54 vmromanos Relationship added related to 0032147
2016-02-16 15:02 alostale Regression level => Packaging and release
2016-02-16 15:02 alostale Priority normal => immediate
2016-02-16 15:03 alostale Status new => acknowledged
2016-02-16 15:04 alostale Status acknowledged => scheduled
2016-02-16 17:21 inigosanchez Assigned To platform => inigosanchez
2016-02-23 13:27 inigosanchez Regression date => 2015-11-23
2016-02-23 13:27 inigosanchez Regression introduced in release => pi
2016-02-23 13:27 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/9f99e60411fcba42b78da7923bca7465ae71aa09 [^]
2016-02-24 09:45 inigosanchez Relationship added caused by 0024319
2016-02-25 00:41 inigosanchez Description Updated View Revisions
2016-02-25 00:43 inigosanchez Review Assigned To => alostale
2016-02-25 00:47 hgbot Checkin
2016-02-25 00:47 hgbot Note Added: 0084477
2016-02-25 00:47 hgbot Status scheduled => resolved
2016-02-25 00:47 hgbot Resolution open => fixed
2016-02-25 00:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/50d727a061775e9b8522c7df5f274732c9414583 [^]
2016-02-25 00:48 inigosanchez Note Added: 0084478
2016-02-26 09:17 alostale Note Added: 0084541
2016-02-26 09:17 alostale Status resolved => closed
2016-02-26 09:17 alostale Fixed in Version => 3.0PR16Q2
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085167
2016-10-19 16:10 hgbot Checkin
2016-10-19 16:10 hgbot Note Added: 0090698
2016-10-19 16:10 hgbot Status closed => resolved
2016-10-19 16:10 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/50d727a061775e9b8522c7df5f274732c9414583 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/5066477d172a9a04149306642e088fdd41b6416c [^]
2016-10-19 16:59 guilleaer Note Deleted: 0090698
2016-10-19 17:01 guilleaer Note Added: 0090700
2016-10-19 17:01 guilleaer Status resolved => closed
2017-02-15 09:11 hgbot Checkin
2017-02-15 09:11 hgbot Note Added: 0094343


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker