Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032218
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-02-12 12:192016-03-17 10:56
ReporteralostaleView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionbf8f775716f0
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-08-05
Regression introduced in release3.0PR15Q4
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/1f572104e426366ac67e9efc7bd74040f8142ac3 [^]
Triggers an Emergency PackNo
Summary

0032218: Payment In > Order navigation fails

DescriptionWhen trying to navigate from Payment In > Lines > Order Payment In Plan to Sales Order window, an error is thrown and the order is not opened.

Looking at the request to ReferencedLink, value for inpEntityName is now FIN_Payment_Schedule which is the base entity of the view linked by the field. Before it was FIN_Payment_Sched_Ord_V.
Steps To Reproduce1. Open Payment In window
2. Select any record related to an order.
3. Open Lines tab
4. Click on the link of "Order Payment Schedule"
  * Sales Invoice window is opened -> it should open Sales Order
  * This error is shown: Argument is not a BaseOBObject and not a HibernateProxy it is NULL
Proposed SolutionAdd a navigation rule for the Order Payment Schedule, in order to force the navigation to the Payment Plan tab of the Sales Order window.

Note that for the moment is not possible to create this rule from the UI, as it is not allowed to select a tab which shows an entity different from the entity pointed by the field.
TagsNo tags attached.
Attached Filesdiff file icon issue-32218-testcase.diff [^] (2,226 bytes) 2016-02-12 12:43 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00322193.0PR16Q1 closedplatform Payment In > Order navigation fails 
depends on backport 00322203.0PR15Q4.4 closedplatform Payment In > Order navigation fails 
caused by feature request 0015379 closedgorkaion Extend navigation model 

-  Notes
(0084152)
alostale (developer)
2016-02-12 12:43

attached failing test case
(0084165)
caristu (developer)
2016-02-12 15:22

The problem is that before the extend navigation project the ReferencedLink class was able to select destination of the FIN_Payment_Schedule reference from Payment In or Payment Out depending on the source window. This was harcoded.

That code was removed. Also is not possible to define a navigation rule to navigate to the sales order in this case.

So currently the field has not a navigation defined to behaved like before. This causes the breaking of the navigation is this case.
(0084322)
AtulOpenbravo (developer)
2016-02-18 13:46
edited on: 2016-02-19 13:17

Test Plan A
1. Open Payment In window.
2. Select any record with Order No. information in description field.
3. Open Lines tab.
4. Click on the link in "Order Payment Schedule" field/Link".
5. Check that Sales Order window is opened in Payment Plan Tab.

Repeat same test for Invoice Payment Schedule field/link.

Test Plan B
1. Open Payment Out window.
2. Select any record with Order No. information in description field.
3. Open Lines tab.
4. Click on the link in "Order Payment Schedule" field/Link".
5. Check that Purchase Order window is opened in Payment Plan Tab.

Repeat same test for Invoice Payment Schedule field/link.

(0084358)
psanjuan (manager)
2016-02-19 12:06
edited on: 2016-02-19 12:09

Issue verifed. Same failure shown while navigating from Payment In and Payment Out.

(0084368)
psanjuan (manager)
2016-02-19 13:18

Test plan above verified. Issue can be code reviewed and closed.
(0084391)
hgbot (developer)
2016-02-22 11:10

Repository: erp/devel/pi
Changeset: bf8f775716f07ad9926ee9b0d4c1c85be1a8bba6
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Feb 18 17:47:53 2016 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/bf8f775716f07ad9926ee9b0d4c1c85be1a8bba6 [^]

Fixes Issue 32218:Payment In & Out Window Lines Tab Order Payment Plan Field
navigation fails

Direct Navigation Rule applied to
- Window:Payment In, Tab:Lines, Field:Order Payment Plan navigate to
  Sales Order | Payment Plan Tab
- Window:Payment Out, Tab:Lines, Field:Order Payment Plan navigate to
  Purchase Order | Payment Plan Tab

---
M src-db/database/sourcedata/AD_TABLE_NAVIGATION.xml
---
(0084394)
hgbot (developer)
2016-02-22 11:10

Repository: erp/devel/pi
Changeset: 863208bb4993be5f83ced529157040032b5fd666
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Mon Feb 22 10:43:16 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/863208bb4993be5f83ced529157040032b5fd666 [^]

Related to issue 32218: fixed db consistency

---
M src-db/database/sourcedata/AD_TABLE_NAVIGATION.xml
---
(0084398)
vmromanos (developer)
2016-02-22 11:11

Code review + testing OK
(0085160)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085161)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-12 12:19 alostale New Issue
2016-02-12 12:19 alostale Assigned To => platform
2016-02-12 12:19 alostale Modules => Core
2016-02-12 12:19 alostale Triggers an Emergency Pack => No
2016-02-12 12:20 alostale Regression level => Production - QA Approved
2016-02-12 12:20 alostale Regression date => 2015-08-05
2016-02-12 12:20 alostale Regression introduced in release => 3.0PR15Q4
2016-02-12 12:20 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/1f572104e426366ac67e9efc7bd74040f8142ac3 [^]
2016-02-12 12:21 alostale Relationship added caused by 0015379
2016-02-12 12:22 alostale Status new => scheduled
2016-02-12 12:43 alostale File Added: issue-32218-testcase.diff
2016-02-12 12:43 alostale Note Added: 0084152
2016-02-12 12:43 alostale Assigned To platform => caristu
2016-02-12 15:22 caristu Note Added: 0084165
2016-02-17 13:56 caristu Assigned To caristu => Triage Finance
2016-02-17 14:00 caristu Proposed Solution updated
2016-02-17 14:01 caristu Status scheduled => acknowledged
2016-02-18 09:15 caristu Status acknowledged => scheduled
2016-02-18 09:21 vmromanos Assigned To Triage Finance => AtulOpenbravo
2016-02-18 13:46 AtulOpenbravo Note Added: 0084322
2016-02-19 12:05 psanjuan Steps to Reproduce Updated View Revisions
2016-02-19 12:06 psanjuan Note Added: 0084358
2016-02-19 12:09 psanjuan Note Edited: 0084358 View Revisions
2016-02-19 13:16 psanjuan Note Edited: 0084322 View Revisions
2016-02-19 13:17 psanjuan Note Edited: 0084322 View Revisions
2016-02-19 13:18 psanjuan Note Added: 0084368
2016-02-22 11:10 hgbot Checkin
2016-02-22 11:10 hgbot Note Added: 0084391
2016-02-22 11:10 hgbot Status scheduled => resolved
2016-02-22 11:10 hgbot Resolution open => fixed
2016-02-22 11:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bf8f775716f07ad9926ee9b0d4c1c85be1a8bba6 [^]
2016-02-22 11:10 hgbot Checkin
2016-02-22 11:10 hgbot Note Added: 0084394
2016-02-22 11:11 vmromanos Review Assigned To => vmromanos
2016-02-22 11:11 vmromanos Note Added: 0084398
2016-02-22 11:11 vmromanos Status resolved => closed
2016-02-25 09:31 psanjuan Relationship added related to 0032336
2016-02-25 11:15 psanjuan Relationship deleted related to 0032336
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085160
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085161


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker