Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0032092
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2016-02-02 13:432016-03-17 10:56
ReporterlorenzofidalgoView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision010420803d1c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0032092: [RR16Q1] "Automate Movement to Other Account" checkbox hides "Cash Management" section from POS Terminal Type || Payment Method

DescriptionAfter clicking "Automate Movement to Other Account" checkbox, "Cash Management" is hidden. User has to click Cash Management section twice to be able to see Cash Management's fields again. This is placed in "POS Terminal Type" window, "Payment Method" tab.
This issue has been reproduced in RR16Q1 and RR15Q4.1. This issue has not been reproduced in RR15Q3.4 and RR15Q2.5.
Steps To Reproduce0-Login POS backend.
1-Using "The White Valley Group Admin" role, go to "POS Terminal Type" window.
2-Select "CMS POS Terminal Type" record and click "Payment Method" tab.
3-Click "Create a new record in a form" button.
4-Cancel Edition and Click "Create a new record in a form" again.
5-Scroll down and watch "Cash Management" section. Now click "Automate Movement to Other Account" checkbox to check off it.
6-Realise that "Cash Management" section is not visible now. Scroll up/down and it is still not visible. User has to click several times "Cash Management" section to be able to see "Cash Management"'s fields again.
TagsNo tags attached.
Attached Filespng file icon CashManagementNotVisible.png [^] (162,820 bytes) 2016-02-02 13:43


diff file icon issue32092.diff [^] (1,556 bytes) 2016-02-03 09:10 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0019378 closeddbaz Hidden sections take space 
related to defect 0033576 acknowledgedplatform "Service Product" section in "Product" window performs a wrong expansion behaviour 

-  Notes
(0083849)
alostale (developer)
2016-02-02 14:34

Note in previous releases space for hidden fields by display logic was preserved whereas starting from 3.0PR15Q4 it is not. When they are shown again the space is filled again bug scroll bar is not taking new page size into consideration so it does not get refreshed.

This change is not intended so space should be preserved as it was previously.
(0083861)
caristu (developer)
2016-02-02 18:50

The problem can be reproduced always after canceling the edition and reopening edition in form. (Updated step 3)

In this case the fields are marked to not keep the space after canceling, but they are not restored again to keep the space when reopening.

The problem can not be reproduced the first time because in this case the fields are indeed marked to keep the space.

Attached proposed solution.
(0083904)
hgbot (developer)
2016-02-03 19:43

Repository: erp/devel/pi
Changeset: 010420803d1c5d4c1397a7fbcd5b02d072e208c7
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Feb 03 19:42:14 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/010420803d1c5d4c1397a7fbcd5b02d072e208c7 [^]

fixes issue 32092: hidden fields space not restored after reopening form view

The alwaysTakeSpace property of the form items was only being set after opening the form view the first time. This property is used to keep space for the displayed field (including the hidden ones by display logic). This property is being set to false when closing form view, and then, never restored again.

Now this property is set every time the UI switches into the form view.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0083917)
hgbot (developer)
2016-02-04 10:15

Repository: erp/devel/pi
Changeset: 09569ec4f2f0d6d47b4ab3753cf6244ffaba09d5
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Feb 04 10:14:27 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/09569ec4f2f0d6d47b4ab3753cf6244ffaba09d5 [^]

related to issue 32092: updated copyright year

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
---
(0083945)
alostale (developer)
2016-02-05 08:50

code reviewed + tested
(0085103)
hudsonbot (developer)
2016-03-17 10:55

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085104)
hudsonbot (developer)
2016-03-17 10:56

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-02-02 13:43 lorenzofidalgo New Issue
2016-02-02 13:43 lorenzofidalgo Assigned To => platform
2016-02-02 13:43 lorenzofidalgo File Added: CashManagementNotVisible.png
2016-02-02 13:43 lorenzofidalgo Web browser => Google Chrome
2016-02-02 13:43 lorenzofidalgo Modules => Core
2016-02-02 13:43 lorenzofidalgo Regression level => Production - QA Approved
2016-02-02 13:43 lorenzofidalgo Regression introduced in release => 3.0PR15Q4.1
2016-02-02 13:43 lorenzofidalgo Triggers an Emergency Pack => No
2016-02-02 13:46 lorenzofidalgo Web browser Google Chrome => Google Chrome
2016-02-02 13:46 lorenzofidalgo Steps to Reproduce Updated View Revisions
2016-02-02 13:46 lorenzofidalgo Web browser Google Chrome => Google Chrome
2016-02-02 13:46 lorenzofidalgo Severity trivial => minor
2016-02-02 14:34 alostale Note Added: 0083849
2016-02-02 14:34 alostale Status new => acknowledged
2016-02-02 18:42 caristu Web browser Google Chrome => Google Chrome
2016-02-02 18:42 caristu Steps to Reproduce Updated View Revisions
2016-02-02 18:43 caristu Status acknowledged => scheduled
2016-02-02 18:43 caristu Assigned To platform => caristu
2016-02-02 18:43 caristu File Added: issue32092.diff
2016-02-02 18:50 caristu Note Added: 0083861
2016-02-02 18:50 caristu Web browser Google Chrome => Google Chrome
2016-02-02 18:50 caristu Regression level Production - QA Approved =>
2016-02-02 18:50 caristu Regression introduced in release 3.0PR15Q4.1 =>
2016-02-03 09:10 caristu File Deleted: issue32092.diff
2016-02-03 09:10 caristu File Added: issue32092.diff
2016-02-03 09:13 caristu Relationship added related to 0019378
2016-02-03 19:43 hgbot Checkin
2016-02-03 19:43 hgbot Note Added: 0083904
2016-02-03 19:43 hgbot Status scheduled => resolved
2016-02-03 19:43 hgbot Resolution open => fixed
2016-02-03 19:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/010420803d1c5d4c1397a7fbcd5b02d072e208c7 [^]
2016-02-03 19:44 caristu Review Assigned To => alostale
2016-02-03 19:44 caristu Web browser Google Chrome => Google Chrome
2016-02-03 19:44 caristu Issue Monitored: alostale
2016-02-04 10:15 hgbot Checkin
2016-02-04 10:15 hgbot Note Added: 0083917
2016-02-05 08:50 alostale Note Added: 0083945
2016-02-05 08:50 alostale Status resolved => closed
2016-02-05 08:50 alostale Fixed in Version => 3.0PR16Q2
2016-03-17 10:55 hudsonbot Checkin
2016-03-17 10:55 hudsonbot Note Added: 0085103
2016-03-17 10:56 hudsonbot Checkin
2016-03-17 10:56 hudsonbot Note Added: 0085104
2016-08-01 13:18 lorenzofidalgo Relationship added related to 0033576


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker