Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031959
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalalways2016-01-19 21:212016-03-17 10:54
ReporteregoitzView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revisionc48840608378
ProjectionnoneETAnoneTarget Version
OSAnyDatabasePostgreSQLJava version
OS VersionDatabase versionAnt version
Product Version3.0PR15Q4SCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-07-06
Regression introduced in release3.0PR15Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/70c0e8fd87ee [^]
Triggers an Emergency PackNo
Summary

0031959: Incorrect posting data when not defining an external connection pool on the Openbravo.properties

DescriptionHaving on the Openbravo.properties file the parameter without value the documents are posted on the previous date than the accounting date.

The configuration is:


externalPoolClassName=
Steps To ReproduceThe problem happens by default when updating to PR15Q4.

It is reproducible as:

Edit the Openbravo.properties file by replacing


externalPoolClassName=org.openbravo.apachejdbcconnectionpool.JdbcExternalConnectionPool

with

externalPoolClassName=

Then compile with
ant smartbuild
and restart tomcat.
Then access to the application.

Reset accounting for invoices
Schedule the accoounting background process.

When it finishes check the invoices and see that the accounting date of the fact_acct entries is one day before the accounting date of the documents.

REstoring the Openbravo.properties file solves the problem.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00319603.0PR16Q1 closedcaristu Incorrect posting data when not defining an external connection pool on the Openbravo.properties 
depends on backport 00319613.0PR15Q4.2 closedcaristu Incorrect posting data when not defining an external connection pool on the Openbravo.properties 
caused by feature request 00295643.0PR15Q4 closedinigosanchez Include Connection Pool module into distribution 
related to defect 0031973 closedalostale detect situation created by issue 31959 
related to defect 0032432 closedalostale incorrect dates issue detection on install.source 

-  Notes
(0083470)
hgbot (developer)
2016-01-20 19:27

Repository: erp/devel/pi
Changeset: c488406083784aae17d1d93bdf0495d469c54225
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Jan 20 18:52:48 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c488406083784aae17d1d93bdf0495d469c54225 [^]

fixes issue 31959: Incorrect posting data using postgresql jdbc connection pool


There was a problem in the binary transfer of Dates performed by the postgresql library version 9.4-1201. This problem is not happening on version 9.4-1207 because when the queries are executed it now includes a mechanism to identify if the fields of the query need to update their format to binary.

For this reason, to fix the problem the postgresql jdbc driver has been upgraded to version 9.4-1207

---
M build.xml
M legal/Licensing.txt
A lib/runtime/postgresql-9.4.1207.jre6.jar
R lib/runtime/postgresql-9.4-1201.jdbc4.jar
---
(0083480)
alostale (developer)
2016-01-21 08:31

This issue affects PostgreSQL instances using Apache Commons DBCP Pool, this is externalPoolClassName property in Openbravo.properties is empty, which is the default values for instances updating to >=PR15Q4 from a previous version. Note that even this value is changed to use Tomcat Pool, if the instance was executing old value for a time, data generated in this period might be affected.

It affects accounting process. But it can also affect ANY other process implemented in XSQL (or using direct JDBC connections) doing operations on date fields read from database. It DOES NOT affect processes using DAL nor PL/SQL processes.

It is caused by issues 376 [1] and 387 [2] in PostgreSQL JDB.

[1] https://github.com/pgjdbc/pgjdbc/pull/376 [^]
[2] https://github.com/pgjdbc/pgjdbc/pull/387 [^]
(0083483)
alostale (developer)
2016-01-21 08:40

Code reviewed

Tested accounting process using Commons DBCP and Tomcat pool, in both cases there are not mismatches in accounting dates.
(0083497)
hgbot (developer)
2016-01-21 14:05

Repository: erp/devel/pi
Changeset: f8de3bcd78f39e8591a0c0f268a206c4cfdb3298
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Jan 21 12:44:16 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/f8de3bcd78f39e8591a0c0f268a206c4cfdb3298 [^]

fixed issue 31973: detect situation created by issue 31959

  Added module script that creates alert when in this situation

---
A src-util/modulescript/build/classes/org/openbravo/modulescript/PgJdbcDatesIssue.class
A src-util/modulescript/build/classes/org/openbravo/modulescript/PgJdbcDatesIssueData.class
A src-util/modulescript/src/org/openbravo/modulescript/PgJdbcDatesIssue.java
A src-util/modulescript/src/org/openbravo/modulescript/PgJdbcDatesIssue_data.xsql
---
(0083499)
hgbot (developer)
2016-01-21 14:06

Repository: erp/backports/3.0PR15Q4.2
Changeset: 51a2befdaed15dc4d765e841eb0695974ce562ca
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Jan 21 13:57:04 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q4.2/rev/51a2befdaed15dc4d765e841eb0695974ce562ca [^]

fixed issue 31975: detect situation created by issue 31959

  Added module script that creates alert when in this situation

---
A src-util/modulescript/build/classes/org/openbravo/modulescript/PgJdbcDatesIssue.class
A src-util/modulescript/build/classes/org/openbravo/modulescript/PgJdbcDatesIssueData.class
A src-util/modulescript/src/org/openbravo/modulescript/PgJdbcDatesIssue.java
A src-util/modulescript/src/org/openbravo/modulescript/PgJdbcDatesIssue_data.xsql
---
(0083501)
hgbot (developer)
2016-01-21 14:07

Repository: erp/backports/3.0PR16Q1
Changeset: 83073641d170a8f789b483bdcc4a14bc0a927bbf
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Jan 21 12:44:16 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR16Q1/rev/83073641d170a8f789b483bdcc4a14bc0a927bbf [^]

fixed issue 31974: detect situation created by issue 31959

  Added module script that creates alert when in this situation

---
A src-util/modulescript/build/classes/org/openbravo/modulescript/PgJdbcDatesIssue.class
A src-util/modulescript/build/classes/org/openbravo/modulescript/PgJdbcDatesIssueData.class
A src-util/modulescript/src/org/openbravo/modulescript/PgJdbcDatesIssue.java
A src-util/modulescript/src/org/openbravo/modulescript/PgJdbcDatesIssue_data.xsql
---
(0083503)
alostale (developer)
2016-01-21 15:18

for more details http://wiki.openbravo.com/wiki/Release_Notes/Issue31959 [^]
(0085060)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085063)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-19 21:21 egoitz New Issue
2016-01-19 21:21 egoitz Assigned To => platform
2016-01-19 21:21 egoitz Modules => Core
2016-01-19 21:21 egoitz Regression level => Production - QA Approved
2016-01-19 21:21 egoitz Triggers an Emergency Pack => No
2016-01-19 21:22 egoitz version => 3.0PR15Q4
2016-01-19 21:22 egoitz Target Version 3.0PR15Q4 =>
2016-01-20 09:06 alostale Relationship added caused by 0029564
2016-01-20 09:08 alostale Regression date => 2015-07-06
2016-01-20 09:08 alostale Regression introduced in release => 3.0PR15Q4
2016-01-20 09:08 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/30caa81f847ba1075d2b6e716fb1e4e8158dafe7 [^]
2016-01-20 09:08 alostale Status new => acknowledged
2016-01-20 09:08 alostale Assigned To platform => caristu
2016-01-20 09:09 alostale Status acknowledged => scheduled
2016-01-20 19:27 hgbot Checkin
2016-01-20 19:27 hgbot Note Added: 0083470
2016-01-20 19:27 hgbot Status scheduled => resolved
2016-01-20 19:27 hgbot Resolution open => fixed
2016-01-20 19:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c488406083784aae17d1d93bdf0495d469c54225 [^]
2016-01-20 19:33 caristu Review Assigned To => alostale
2016-01-20 19:33 caristu Issue Monitored: alostale
2016-01-21 08:18 alostale Regression introduced by commit https://code.openbravo.com/erp/devel/pi/rev/30caa81f847ba1075d2b6e716fb1e4e8158dafe7 [^] => https://code.openbravo.com/erp/devel/pi/rev/70c0e8fd87ee [^]
2016-01-21 08:31 alostale Note Added: 0083480
2016-01-21 08:31 alostale Note Added: 0083481
2016-01-21 08:40 alostale Note Added: 0083483
2016-01-21 08:40 alostale Status resolved => closed
2016-01-21 08:40 alostale Fixed in Version => 3.0PR16Q2
2016-01-21 08:42 alostale Note Deleted: 0083481
2016-01-21 11:05 alostale Relationship added related to 0031973
2016-01-21 14:05 hgbot Checkin
2016-01-21 14:05 hgbot Note Added: 0083497
2016-01-21 14:06 hgbot Checkin
2016-01-21 14:06 hgbot Note Added: 0083499
2016-01-21 14:07 hgbot Checkin
2016-01-21 14:07 hgbot Note Added: 0083501
2016-01-21 15:18 alostale Note Added: 0083503
2016-03-08 08:28 alostale Relationship added related to 0032432
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085060
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085063


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker