Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031961
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformcriticalalways2016-01-19 21:212016-01-21 08:41
ReporteregoitzView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q4.2
StatusclosedFix in branchFixed in SCM revision08ab0b08fa66
ProjectionnoneETAnoneTarget Version3.0PR15Q4.2
OSAnyDatabasePostgreSQLJava version
OS VersionDatabase versionAnt version
Product Version3.0PR15Q4SCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-07-06
Regression introduced in release3.0PR15Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/70c0e8fd87ee [^]
Triggers an Emergency PackYes
Summary

0031961: Incorrect posting data when not defining an external connection pool on the Openbravo.properties

DescriptionHaving on the Openbravo.properties file the parameter without value the documents are posted on the previous date than the accounting date.

The configuration is:


externalPoolClassName=
Steps To ReproduceThe problem happens by default when updating to PR15Q4.

It is reproducible as:

Edit the Openbravo.properties file by replacing


externalPoolClassName=org.openbravo.apachejdbcconnectionpool.JdbcExternalConnectionPool

with

externalPoolClassName=

Then compile with
ant smartbuild
and restart tomcat.
Then access to the application.

Reset accounting for invoices
Schedule the accoounting background process.

When it finishes check the invoices and see that the accounting date of the fact_acct entries is one day before the accounting date of the documents.

REstoring the Openbravo.properties file solves the problem.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0031959 closedcaristu Incorrect posting data when not defining an external connection pool on the Openbravo.properties 

-  Notes
(0083472)
hgbot (developer)
2016-01-20 19:32

Repository: erp/backports/3.0PR15Q4.2
Changeset: 08ab0b08fa66b4508c4b1d21d1ff2a99253e4a5b
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Jan 20 19:01:04 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q4.2/rev/08ab0b08fa66b4508c4b1d21d1ff2a99253e4a5b [^]

fixes issue 31961: Incorrect posting data using postgresql jdbc connection pool


There was a problem in the binary transfer of Dates performed by the postgresql library version 9.4-1201. This problem is not happening on version 9.4-1207 because when the queries are executed it now includes a mechanism to identify if the fields of the query need to update their format to binary.

For this reason, to fix the problem the postgresql jdbc driver has been upgraded to version 9.4-1207

---
M build.xml
M legal/Licensing.txt
A lib/runtime/postgresql-9.4.1207.jre6.jar
R lib/runtime/postgresql-9.4-1201.jdbc4.jar
---
(0083482)
alostale (developer)
2016-01-21 08:31

This issue affects PostgreSQL instances using Apache Commons DBCP Pool, this is externalPoolClassName property in Openbravo.properties is empty, which is the default values for instances updating to >=PR15Q4 from a previous version. Note that even this value is changed to use Tomcat Pool, if the instance was executing old value for a time, data generated in this period might be affected.

It affects accounting process. But it can also affect ANY other process implemented in XSQL (or using direct JDBC connections) doing operations on date fields read from database. It DOES NOT affect processes using DAL nor PL/SQL processes.

It is caused by issues 376 [1] and 387 [2] in PostgreSQL JDB.

[1] https://github.com/pgjdbc/pgjdbc/pull/376 [^]
[2] https://github.com/pgjdbc/pgjdbc/pull/387 [^]
(0083484)
alostale (developer)
2016-01-21 08:41

Code reviewed

Tested accounting process using Commons DBCP and Tomcat pool, in both cases there are not mismatches in accounting dates.

- Issue History
Date Modified Username Field Change
2016-01-20 09:09 alostale Type defect => backport
2016-01-20 09:09 alostale Target Version => 3.0PR15Q4.2
2016-01-20 19:32 hgbot Checkin
2016-01-20 19:32 hgbot Note Added: 0083472
2016-01-20 19:32 hgbot Status scheduled => resolved
2016-01-20 19:32 hgbot Resolution open => fixed
2016-01-20 19:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q4.2/rev/08ab0b08fa66b4508c4b1d21d1ff2a99253e4a5b [^]
2016-01-20 19:32 caristu Review Assigned To => alostale
2016-01-20 19:32 caristu Issue Monitored: alostale
2016-01-21 08:18 alostale Regression introduced by commit https://code.openbravo.com/erp/devel/pi/rev/30caa81f847ba1075d2b6e716fb1e4e8158dafe7 [^] => https://code.openbravo.com/erp/devel/pi/rev/70c0e8fd87ee [^]
2016-01-21 08:31 alostale Note Added: 0083482
2016-01-21 08:33 alostale Triggers an Emergency Pack No => Yes
2016-01-21 08:41 alostale Note Added: 0083484
2016-01-21 08:41 alostale Status resolved => closed
2016-01-21 08:41 alostale Fixed in Version => 3.0PR15Q4.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker