Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031944
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] E. Translationminoralways2016-01-19 14:182016-03-17 10:54
ReportervmromanosView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision4d04e9933ae6
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-11-27
Regression introduced in release3.0PR15Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/ac68a43ce6569746a77f67d78906d7addbac841b [^]
Triggers an Emergency PackNo
Summary

0031944: Labels in AD_TextInterfaces linked to a concrete file are not translated

DescriptionThe labels in AD_TextInterfaces linked to a concrete file, i.e. which are used only in just one file, are not properly translated.

However, the labels that are not linked to a concrete file (AD_TextInterfaces.filename is null because they are used in more than one report) are properly translated
Steps To ReproduceInstall the Spanish Translation Pack in a recent PI (3.0PR15Q2 or higher)

Login as Openbravo Admin and select Spanish Language

Access "Diario asientos" report. Set date from 01-01-2015 to 31-12-2015 and run report in PDF (printer icon)

Realize that title appears as "Journal Entries Report" instead of Spanish translation available in the AD_TextInterfaces ("Libro diario")
Proposed SolutionReportingUtils.java, method generateJasperPrint():
 String strBaseDesign = DalContextListener.getServletContext().getRealPath("")

Value of strBaseDesign is wrong and it should finish with "/src-loc/design"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00319463.0PR16Q1 closedcaristu Openbravo ERP Labels in AD_TextInterfaces linked to a concrete file are not translated 
depends on backport 00319473.0PR15Q4.2 closedcaristu Openbravo ERP Labels in AD_TextInterfaces linked to a concrete file are not translated 
depends on backport 00319483.0PR15Q3.5 closedcaristu Openbravo ERP Labels in AD_TextInterfaces linked to a concrete file are not translated 
caused by feature request 0029566 closedcaristu Openbravo ERP Upgrade Jasper Libraries 
has duplicate defect 0031900 closedvmromanos Localization Pack: Spain Report title not translated 
has duplicate defect 0031925 closedvmromanos Modules Header information not translated when printing remittance document in Spanish language 

-  Notes
(0083400)
vmromanos (developer)
2016-01-19 14:21

Backports required
(0083413)
hgbot (developer)
2016-01-19 17:47

Repository: erp/devel/pi
Changeset: 4d04e9933ae633ccaf5f8b72bf2ef63a742b3967
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jan 19 17:46:10 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4d04e9933ae633ccaf5f8b72bf2ef63a742b3967 [^]

fixes issue 31944: Labels linked to a concrete file are not translated

The translation engine requires the base design path to retrieve the ad_textinterfaces linked to a particular report. This path was not being sent properly in ReportinUtils class. Now the path is generated correctly making use of a new method called getBaseDesignPath.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/report/ReportingUtils.java
---
(0083419)
caristu (developer)
2016-01-19 18:08

Added new test into Testlink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-9985 [^]
(0083433)
alostale (developer)
2016-01-20 09:26

code reviewed + tested
(0083438)
alostale (developer)
2016-01-20 09:33

Downgraded severity from major to minor.

According to Reporting Guidelines [1]:
  "Minor: Do not result in failure but causes the system to show incorrect, incomplete, or inconsistent results [...]"

[1] http://wiki.openbravo.com/wiki/Bug_Reporting_Guidelines#How_to_Choose_the_Right_Severity [^] [^]
(0085055)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-19 14:18 vmromanos New Issue
2016-01-19 14:18 vmromanos Assigned To => platform
2016-01-19 14:18 vmromanos Modules => Core
2016-01-19 14:18 vmromanos Triggers an Emergency Pack => No
2016-01-19 14:21 vmromanos Regression level => Production - Confirmed Stable
2016-01-19 14:21 vmromanos Regression date => 2014-11-27
2016-01-19 14:21 vmromanos Regression introduced in release => 3.0PR15Q2
2016-01-19 14:21 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/main/rev/56f321248289#l10.113 [^]
2016-01-19 14:21 vmromanos Note Added: 0083400
2016-01-19 14:21 vmromanos Description Updated View Revisions
2016-01-19 14:22 vmromanos Relationship added causes 0031900
2016-01-19 14:23 vmromanos Relationship replaced has duplicate 0031900
2016-01-19 14:24 vmromanos Relationship added has duplicate 0031925
2016-01-19 14:56 alostale Status new => acknowledged
2016-01-19 14:56 alostale Assigned To platform => caristu
2016-01-19 14:57 alostale Status acknowledged => scheduled
2016-01-19 14:57 alostale Priority normal => immediate
2016-01-19 17:03 heccam Issue Monitored: heccam
2016-01-19 17:38 caristu Status scheduled => acknowledged
2016-01-19 17:38 caristu Regression introduced by commit https://code.openbravo.com/erp/devel/main/rev/56f321248289#l10.113 [^] => https://code.openbravo.com/erp/devel/pi/rev/ac68a43ce6569746a77f67d78906d7addbac841b [^]
2016-01-19 17:39 caristu Status acknowledged => scheduled
2016-01-19 17:42 caristu Relationship deleted depends on 0031953
2016-01-19 17:42 caristu Relationship deleted depends on 0031954
2016-01-19 17:43 caristu Relationship deleted depends on 0031955
2016-01-19 17:47 hgbot Checkin
2016-01-19 17:47 hgbot Note Added: 0083413
2016-01-19 17:47 hgbot Status scheduled => resolved
2016-01-19 17:47 hgbot Resolution open => fixed
2016-01-19 17:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4d04e9933ae633ccaf5f8b72bf2ef63a742b3967 [^]
2016-01-19 18:08 caristu Note Added: 0083419
2016-01-19 18:32 alostale Relationship added caused by 0029566
2016-01-20 09:26 alostale Review Assigned To => alostale
2016-01-20 09:26 alostale Note Added: 0083433
2016-01-20 09:26 alostale Status resolved => closed
2016-01-20 09:26 alostale Fixed in Version => 3.0PR16Q2
2016-01-20 09:33 alostale Note Added: 0083438
2016-01-20 09:33 alostale Severity major => minor
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085055


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker