Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031948
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] E. Translationminoralways2016-01-19 14:182016-01-20 17:10
ReportervmromanosView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q3.5
StatusclosedFix in branchFixed in SCM revisione44160d7b462
ProjectionnoneETAnoneTarget Version3.0PR15Q3.5
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-11-27
Regression introduced in release3.0PR15Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/ac68a43ce6569746a77f67d78906d7addbac841b [^]
Triggers an Emergency PackNo
Summary

0031948: Labels in AD_TextInterfaces linked to a concrete file are not translated

DescriptionThe labels in AD_TextInterfaces linked to a concrete file, i.e. which are used only in just one file, are not properly translated.

However, the labels that are not linked to a concrete file (AD_TextInterfaces.filename is null because they are used in more than one report) are properly translated
Steps To ReproduceInstall the Spanish Translation Pack in a recent PI (3.0PR15Q2 or higher)

Login as Openbravo Admin and select Spanish Language

Access "Diario asientos" report. Set date from 01-01-2015 to 31-12-2015 and run report in PDF (printer icon)

Realize that title appears as "Journal Entries Report" instead of Spanish translation available in the AD_TextInterfaces ("Libro diario")
Proposed SolutionReportingUtils.java, method generateJasperPrint():
 String strBaseDesign = DalContextListener.getServletContext().getRealPath("")

Value of strBaseDesign is wrong and it should finish with "/src-loc/design"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0029566 closedcaristu Upgrade Jasper Libraries 
blocks defect 0031944 closedcaristu Labels in AD_TextInterfaces linked to a concrete file are not translated 

-  Notes
(0083418)
hgbot (developer)
2016-01-19 17:54

Repository: erp/backports/3.0PR15Q3.5
Changeset: e44160d7b4622f2926b6efafe00090be224c86cf
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jan 19 17:53:22 2016 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q3.5/rev/e44160d7b4622f2926b6efafe00090be224c86cf [^]

fixes issue 31948: Labels linked to a concrete file are not translated

The translation engine requires the base design path to retrieve the ad_textinterfaces linked to a particular report. This path was not being sent properly in ReportinUtils class. Now the path is generated correctly making use of a new method called getBaseDesignPath.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/report/ReportingUtils.java
---
(0083436)
alostale (developer)
2016-01-20 09:27

code reviewed + tested
(0083437)
alostale (developer)
2016-01-20 09:32

Downgraded severity from major to minor.

According to Reporting Guidelines [1]:
  "Minor: Do not result in failure but causes the system to show incorrect, incomplete, or inconsistent results [...]"

[1] http://wiki.openbravo.com/wiki/Bug_Reporting_Guidelines#How_to_Choose_the_Right_Severity [^]

- Issue History
Date Modified Username Field Change
2016-01-19 14:57 alostale Type defect => backport
2016-01-19 14:57 alostale Target Version => 3.0PR15Q3.5
2016-01-19 17:42 caristu Relationship added has duplicate 0031955
2016-01-19 17:53 caristu Relationship deleted has duplicate 0031955
2016-01-19 17:54 hgbot Checkin
2016-01-19 17:54 hgbot Note Added: 0083418
2016-01-19 17:54 hgbot Status scheduled => resolved
2016-01-19 17:54 hgbot Resolution open => fixed
2016-01-19 17:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q3.5/rev/e44160d7b4622f2926b6efafe00090be224c86cf [^]
2016-01-19 17:54 caristu Review Assigned To => alostale
2016-01-19 17:54 caristu Issue Monitored: alostale
2016-01-19 18:27 caristu Regression introduced by commit https://code.openbravo.com/erp/devel/main/rev/56f321248289#l10.113 [^] => https://code.openbravo.com/erp/devel/pi/rev/ac68a43ce6569746a77f67d78906d7addbac841b [^]
2016-01-20 09:27 alostale Note Added: 0083436
2016-01-20 09:27 alostale Status resolved => closed
2016-01-20 09:27 alostale Fixed in Version => 3.0PR15Q3.5
2016-01-20 09:32 alostale Note Added: 0083437
2016-01-20 09:32 alostale Severity major => minor
2016-01-20 17:10 dmitry_mezentsev Relationship added caused by 0029566


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker