Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031912
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementmajoralways2016-01-15 13:502016-06-17 19:37
ReporterVictorVillarView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR16Q3
StatusclosedFix in branchFixed in SCM revision719ef21233f6
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031912: Not possible to delete a product under some circumstances

DescriptionNot possible to delete a product under some circumstances
Steps To ReproduceAs group admin role,
 Go to Product window,
    create a new one
   Go To cost tab:
      create a new one
      Permanent: Y

Try to delete it, you can not because the permanent cost register.

It should be possible to remove a product if it has not a document related.
Proposed SolutionIt should be possible to remove a permanent cost if product does not have a document related.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0086318)
markmm82 (developer)
2016-05-09 16:46

Test plan 1:
As group admin role,
   Go to Product window,
    create a new one
   Go To cost tab:
      create a new one
      Permanent: Y
   Try to delete it, see the product is removed.

Test plan 2:
As group admin role,
   Go to Product window,
    create a new one
   Go To cost tab:
      create a new one
      Permanent: Y
   Go to Sales Order window
      create a new one
      Create a line with the previously created product
   Try to delete it, you can not because the permanent cost register and the document related to the product (the created sales order).
(0086345)
hgbot (developer)
2016-05-10 11:53

Repository: erp/devel/pi
Changeset: 719ef21233f6efcdae5b0fde9abd7ccff11a49bc
Author: Mark <markmm82 <at> gmail.com>
Date: Mon May 09 10:27:19 2016 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/719ef21233f6efcdae5b0fde9abd7ccff11a49bc [^]

Fixes issue 31912: It is not possible to delete a product with a permanent cost

When a product is removed, the M_COSTING trigger is fired in cascade to delete the related costs, and it don't allow to remove the existing permanents costings associated to the product. To allow to remove the product with permanent costs was modified the M_COSTING_TRG to remove the permanent costs if the product have not related documents.

---
M src-db/database/model/triggers/M_COSTING_TRG.xml
---
(0086346)
hgbot (developer)
2016-05-10 11:53

Repository: erp/devel/pi
Changeset: 4c7b579487bdc0355def3ceba730719405c47f05
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon May 09 20:16:33 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4c7b579487bdc0355def3ceba730719405c47f05 [^]

Related to issue 31912: Code review improvements

---
M src-db/database/model/triggers/M_COSTING_TRG.xml
---
(0086347)
aferraz (developer)
2016-05-10 11:54

Code review + Testing OK
(0087528)
hudsonbot (developer)
2016-06-17 19:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test
(0087529)
hudsonbot (developer)
2016-06-17 19:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/0dc7be081b1c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-15 13:50 VictorVillar New Issue
2016-01-15 13:50 VictorVillar Assigned To => Triage Finance
2016-01-15 13:50 VictorVillar Modules => Core
2016-01-15 13:50 VictorVillar Triggers an Emergency Pack => No
2016-01-15 13:51 VictorVillar Issue Monitored: networkb
2016-04-04 10:07 aferraz Target Version 3.0PR16Q2 =>
2016-04-05 12:19 aferraz Assigned To Triage Finance => aferraz
2016-04-05 12:19 aferraz Assigned To aferraz => Triage Finance
2016-04-05 12:21 aferraz Assigned To Triage Finance => Sanjota
2016-04-13 14:45 aferraz Note Added: 0085612
2016-04-13 14:51 aferraz Note Edited: 0085612 View Revisions
2016-04-19 17:09 aferraz Assigned To Sanjota => markmm82
2016-05-06 20:28 markmm82 Status new => scheduled
2016-05-09 16:46 markmm82 Note Added: 0086318
2016-05-09 17:23 aferraz Proposed Solution updated
2016-05-09 19:31 aferraz Note Deleted: 0085612
2016-05-09 19:32 aferraz Proposed Solution updated
2016-05-10 11:53 hgbot Checkin
2016-05-10 11:53 hgbot Note Added: 0086345
2016-05-10 11:53 hgbot Status scheduled => resolved
2016-05-10 11:53 hgbot Resolution open => fixed
2016-05-10 11:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/719ef21233f6efcdae5b0fde9abd7ccff11a49bc [^]
2016-05-10 11:53 hgbot Checkin
2016-05-10 11:53 hgbot Note Added: 0086346
2016-05-10 11:54 aferraz Review Assigned To => aferraz
2016-05-10 11:54 aferraz Note Added: 0086347
2016-05-10 11:54 aferraz Status resolved => closed
2016-05-10 11:54 aferraz Fixed in Version => 3.0PR16Q3
2016-06-17 19:37 hudsonbot Checkin
2016-06-17 19:37 hudsonbot Note Added: 0087528
2016-06-17 19:37 hudsonbot Checkin
2016-06-17 19:37 hudsonbot Note Added: 0087529


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker