Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031868
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSmajorhave not tried2016-01-08 10:222016-03-08 17:26
Reporterjorge-garciaView Statuspublic 
Assigned Tojorge-garcia 
PriorityurgentResolutionfixedFixed in VersionRR16Q1
StatusclosedFix in branchFixed in SCM revision68fad334a9e2
ProjectionnoneETAnoneTarget VersionRR16Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelQA functional test
Regression date2015-12-17
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3e9de6ef5d061f49607b8ed0cc66c37ac30c23f8 [^]
Triggers an Emergency PackNo
Summary

0031868: Cash Management events are not filtered by the selected payment method

DescriptionWhen selecting a payment method in the cash management, only the cash management events with the same payment method must be show to be selected.
Steps To Reproduce1) Go to ERP
2) Go to Organization window
     In Vall Blanca Store, go to the Cash Management Events tab
     Create two cash management events with payment method type Wire Transfer (one for Deposits and one for Withdrawals)
3) Go to POS Terminal Type window
     Select one terminal type and go to Payment Method tab
     In payment method Card, check the fields Allow Withdrawals and Allow Deposits.
4) Login in one of the terminals of the terminal type
      Go to Cash Management and click in Card withdrawal button and enter a quantity.
      See that the cash management events are not correct.
     
     
TagsNo tags attached.
Attached Filesdiff file icon mgmtEvent16Q1.diff [^] (9,581 bytes) 2016-01-21 12:22 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0031838 closedjorge-garcia Cash Management events are not filtered by the selected payment method 

-  Notes
(0083399)
hgbot (developer)
2016-01-19 14:02

Repository: retail/backports/3.0RR16Q1/org.openbravo.retail.posterminal
Changeset: f5ec2fe1dca3b8301f2c9a20305e28ee9e973573
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Tue Jan 19 14:01:16 2016 +0100
URL: http://code.openbravo.com/retail/backports/3.0RR16Q1/org.openbravo.retail.posterminal/rev/f5ec2fe1dca3b8301f2c9a20305e28ee9e973573 [^]

Fixed issue 31868: Cash Management events are not filtered by the selected
payment method

It's necessary to do some changes in the logic of the popup. Now, the popup only
shows the cash management events that coincides with the payment method
selected.

---
M web/org.openbravo.retail.posterminal/js/cashmgmt/model/cashmgmt-model.js
M web/org.openbravo.retail.posterminal/js/cashmgmt/view/cashmgmtkeyboard.js
---
(0083468)
marvintm (manager)
2016-01-20 17:21

The popup needs to filter not only by payment method, but also by currency.
(0083496)
guillermogil (manager)
2016-01-21 12:22

See diff attached for the currency check
(0084476)
hgbot (developer)
2016-02-24 19:56

Repository: retail/backports/3.0RR16Q1/org.openbravo.retail.posterminal
Changeset: 68fad334a9e2ab07d622488653acd4e75ee6da41
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Wed Feb 24 19:55:59 2016 +0100
URL: http://code.openbravo.com/retail/backports/3.0RR16Q1/org.openbravo.retail.posterminal/rev/68fad334a9e2ab07d622488653acd4e75ee6da41 [^]

Fixed issue 31868, Backport of 31838: Now Cash Management popup only shows the cash management events that coincides with the selected payment method

---
M src/org/openbravo/retail/posterminal/term/CashMgmtDepositEvents.java
M src/org/openbravo/retail/posterminal/term/CashMgmtDropEvents.java
M web/org.openbravo.retail.posterminal/js/cashmgmt/model/cashmgmt-model.js
M web/org.openbravo.retail.posterminal/js/cashmgmt/view/cashmgmtkeyboard.js
---
(0084730)
jorge-garcia (developer)
2016-03-04 12:44

It's necessary to backport the sampledata also for the tests.
(0084804)
hgbot (developer)
2016-03-08 09:31

Repository: retail/backports/3.0RR16Q1/org.openbravo.retail.sampledata
Changeset: b15ecaec43db32c031c9500db919deffc4a9aa49
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Fri Mar 04 13:52:34 2016 +0100
URL: http://code.openbravo.com/retail/backports/3.0RR16Q1/org.openbravo.retail.sampledata/rev/b15ecaec43db32c031c9500db919deffc4a9aa49 [^]

Related to issue 31868: Cash Management events are not filtered by the selected
payment method

Needed to add some cashmgmt events for USD payment methods.

---
M referencedata/sampledata/The_White_Valley_Group/OBRETCO_CMEVENTS.xml
---
(0084816)
hgbot (developer)
2016-03-08 11:50

Repository: tools/automation/pi-mobile
Changeset: a9fa3831c78ed2d142aea1a687cd2494cbc96138
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Tue Mar 08 09:58:37 2016 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/a9fa3831c78ed2d142aea1a687cd2494cbc96138 [^]

Related to issue 31868: Cash Management events are not filtered by the selected
payment method

Some tests needs to be changed due to the new functionality.

The affected tests are:
* CashManagementUSDDeposit
* I30543_CashManagementInCashUpReport
* I31707_CashMgmEventsWithMultiplePaymentMthd

---
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashmanagement/CashManagementUSDDeposit.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashmanagement/I30543_CashManagementInCashUpReport.java
M src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/cashmanagement/I31707_CashMgmEventsWithMultiplePaymentMthd.java
---

- Issue History
Date Modified Username Field Change
2016-01-13 09:26 jorge-garcia Type defect => backport
2016-01-13 09:26 jorge-garcia Target Version => RR16Q1
2016-01-13 09:58 jorge-garcia Resolution time => 1452812400
2016-01-13 09:58 jorge-garcia Regression level => QA functional test
2016-01-13 09:58 jorge-garcia Regression date => 2015-12-17
2016-01-13 09:58 jorge-garcia Regression introduced in release => main
2016-01-13 09:58 jorge-garcia Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3e9de6ef5d061f49607b8ed0cc66c37ac30c23f8 [^]
2016-01-19 08:25 guillermogil Issue Monitored: guillermogil
2016-01-19 14:02 hgbot Checkin
2016-01-19 14:02 hgbot Note Added: 0083399
2016-01-19 14:02 hgbot Status scheduled => resolved
2016-01-19 14:02 hgbot Resolution open => fixed
2016-01-19 14:02 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/147ed36767c11592745199f7ea187ed1d46f3d08 [^] => http://code.openbravo.com/retail/backports/3.0RR16Q1/org.openbravo.retail.posterminal/rev/f5ec2fe1dca3b8301f2c9a20305e28ee9e973573 [^]
2016-01-19 17:52 marvintm Review Assigned To => marvintm
2016-01-19 17:52 marvintm Status resolved => closed
2016-01-19 17:52 marvintm Fixed in Version => RR16Q1
2016-01-20 17:21 marvintm Note Added: 0083468
2016-01-20 17:21 marvintm Status closed => new
2016-01-20 17:21 marvintm Resolution fixed => open
2016-01-20 17:21 marvintm Fixed in Version RR16Q1 =>
2016-01-21 12:22 guillermogil File Added: mgmtEvent16Q1.diff
2016-01-21 12:22 guillermogil Note Added: 0083496
2016-02-01 13:00 Orekaria Status new => scheduled
2016-02-24 19:56 hgbot Checkin
2016-02-24 19:56 hgbot Note Added: 0084476
2016-02-24 19:56 hgbot Status scheduled => resolved
2016-02-24 19:56 hgbot Resolution open => fixed
2016-02-24 19:56 hgbot Fixed in SCM revision http://code.openbravo.com/retail/backports/3.0RR16Q1/org.openbravo.retail.posterminal/rev/f5ec2fe1dca3b8301f2c9a20305e28ee9e973573 [^] => http://code.openbravo.com/retail/backports/3.0RR16Q1/org.openbravo.retail.posterminal/rev/68fad334a9e2ab07d622488653acd4e75ee6da41 [^]
2016-02-24 19:58 guilleaer Assigned To jorge-garcia => guilleaer
2016-03-03 16:17 marvintm Status resolved => closed
2016-03-03 16:17 marvintm Fixed in Version => RR16Q1
2016-03-04 12:44 jorge-garcia Assigned To guilleaer => jorge-garcia
2016-03-04 12:44 jorge-garcia Note Added: 0084730
2016-03-04 12:44 jorge-garcia Status closed => new
2016-03-04 12:44 jorge-garcia Resolution fixed => open
2016-03-04 12:44 jorge-garcia Fixed in Version RR16Q1 =>
2016-03-04 12:44 jorge-garcia Status new => scheduled
2016-03-08 09:31 hgbot Checkin
2016-03-08 09:31 hgbot Note Added: 0084804
2016-03-08 10:17 marvintm Status scheduled => resolved
2016-03-08 10:17 marvintm Fixed in Version => RR16Q1
2016-03-08 10:17 marvintm Resolution open => fixed
2016-03-08 11:50 hgbot Checkin
2016-03-08 11:50 hgbot Note Added: 0084816
2016-03-08 17:26 marvintm Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker