Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031859
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajorhave not tried2016-01-11 13:332016-03-17 10:54
ReporterplujanView Statuspublic 
Assigned Todmiguelez 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision1799d7a3ea4a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelQA functional test
Regression date2015-11-12
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/b48e8a24dcb38c56e5d69ea76ca286fdc8e91192 [^]
Triggers an Emergency PackNo
Summary

0031859: [PR16Q1] Add Products to a Characteristic never ends processing

DescriptionAfter selecting a record in the pick and execute pop up for the Characteristics, processing never ends (see attached screenshot)
Steps To ReproduceFailing step is step 5 of this test case: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8624 [^]
TagsNo tags attached.
Attached Filespng file icon AddCharacteristics.png [^] (45,152 bytes) 2016-01-11 13:33

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00318753.0PR16Q1 closeddmiguelez [PR16Q1] Add Products to a Characteristic never ends processing 
caused by feature request 00308843.0PR16Q1 closedjonibc Improve Add Products to Characteristic Value 

-  Notes
(0083237)
dmiguelez (developer)
2016-01-13 13:23

Steps to reproduce:

1
Login to ERP system using below details:
-'Username': Openbravo
-'Password': openbravo
Then change the role to 'The White Valley Group Admin' role

2
Navigate to 'Master Data Management || Pricing || Discounts and Promotions' window
Open discount with name '3x2 Bottles' record in form view.
Change 'Included Products' selector to 'All excluding defined'.
Change 'Included Characteristics' selector to 'Only those defined'.
Save the record.

3
Go to tab 'Characteristics'.
Add a record with characteristic 'Battery Life' and Value '120h max'.
Save the record.

4
Navigate to 'Master Data Management || Product Setup || Product Characteristic' window
Select 'Battery Life' record.
Go to Tab 'Value', select the '120h Max' record, click on button 'Add Products'.

5
In the pick & execute process, select the record of product 'Light sticks'.
Push over 'Done' button.

6
Navigate to 'Master Data Management || Product Setup || Product Characteristic' window
Select 'Battery Life' record.
Go to Tab 'Value', select the '20h ' record, click on button 'Add Products'.
The product 'Light sticks', should have the characteristic value '120 max'.
(0083260)
hgbot (developer)
2016-01-13 17:39

Repository: erp/devel/pi
Changeset: 1799d7a3ea4a2acdeef4c4e070c0961579e981c4
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Wed Jan 13 12:44:01 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1799d7a3ea4a2acdeef4c4e070c0961579e981c4 [^]

Fixes Issue 31859. Removes unnecessary code that makes the process fail with a NPE
if the global variable has not been initized yet.

---
M src/org/openbravo/event/ProductCharacteristicValueEventHandler.java
---
(0083261)
hgbot (developer)
2016-01-13 17:39

Repository: erp/devel/pi
Changeset: f8867ebd1935eeca7064950529e7aabf181d2e65
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Jan 13 17:35:14 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/f8867ebd1935eeca7064950529e7aabf181d2e65 [^]

Related to issue 31859: Updated copyright year

---
M src/org/openbravo/event/ProductCharacteristicValueEventHandler.java
---
(0083263)
vmromanos (developer)
2016-01-13 17:42

Code review OK
(0085039)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test
(0085040)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-11 13:33 plujan New Issue
2016-01-11 13:33 plujan Assigned To => Retail
2016-01-11 13:33 plujan File Added: AddCharacteristics.png
2016-01-11 13:33 plujan Triggers an Emergency Pack => No
2016-01-11 14:15 alostale Relationship added caused by 0030884
2016-01-11 14:17 alostale Regression level => QA functional test
2016-01-11 14:17 alostale Regression date => 2015-11-12
2016-01-11 14:17 alostale Regression introduced in release => main
2016-01-11 14:17 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/b48e8a24dcb38c56e5d69ea76ca286fdc8e91192 [^]
2016-01-11 14:17 alostale Priority normal => immediate
2016-01-11 14:19 plujan Project Retail Modules => Openbravo ERP
2016-01-11 14:21 plujan Modules => Core
2016-01-11 14:21 plujan Assigned To Retail => Triage Finance
2016-01-11 14:21 plujan Category Web POS => 09. Financial management
2016-01-11 14:21 plujan Summary [RR16Q1] Add Products to a Characteristic never ends processing => [PR16Q1] Add Products to a Characteristic never ends processing
2016-01-13 13:23 dmiguelez Note Added: 0083237
2016-01-13 17:23 vmromanos Status new => scheduled
2016-01-13 17:23 vmromanos Assigned To Triage Finance => dmiguelez
2016-01-13 17:39 hgbot Checkin
2016-01-13 17:39 hgbot Note Added: 0083260
2016-01-13 17:39 hgbot Status scheduled => resolved
2016-01-13 17:39 hgbot Resolution open => fixed
2016-01-13 17:39 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1799d7a3ea4a2acdeef4c4e070c0961579e981c4 [^]
2016-01-13 17:39 hgbot Checkin
2016-01-13 17:39 hgbot Note Added: 0083261
2016-01-13 17:42 vmromanos Review Assigned To => vmromanos
2016-01-13 17:42 vmromanos Note Added: 0083263
2016-01-13 17:42 vmromanos Status resolved => closed
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085039
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085040


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker