Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031816
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2016-01-04 18:102016-03-17 10:54
ReportershuehnerView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revision1e99517ffbe9
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomtaal
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031816: Same unused (disabled) code in 3 junit tests (DalQueryTest, DalTest, DynamicEntityTest)

DescriptionThe 3 java files mentioned above all have a similar code which still exists in the test but is disabled via an 'if (false)' block.

https://code.openbravo.com/erp/devel/pi/file/62e77eb7765d/src-test/src/org/openbravo/test/dal/DalQueryTest.java#l173 [^]

Either that test code should be fixed and re-activated of be removed. But keeping it disabled since a long time (merge back from modulary branch) isn't really useful.
Steps To ReproduceCheck 'Dead code' warning in eclipse for the 3 files specified in the summary.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0008708pi closedmtaal Make test cases side effect free 
blocks feature request 0031477 newshuehner Tracking issue to reduce the huge number of eclipse warnings in pi 

-  Notes
(0083388)
hgbot (developer)
2016-01-19 07:56

Repository: erp/devel/pi
Changeset: 1e99517ffbe9ebbd8e81c238d57a2ed3d3d9783d
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jan 19 07:54:44 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1e99517ffbe9ebbd8e81c238d57a2ed3d3d9783d [^]

fixed issue 31816: removed unused code

---
M src-test/src/org/openbravo/test/dal/DalQueryTest.java
M src-test/src/org/openbravo/test/dal/DalTest.java
M src-test/src/org/openbravo/test/dal/DynamicEntityTest.java
---
(0083397)
mtaal (developer)
2016-01-19 13:18

Reviewed
(0085052)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-01-04 18:10 shuehner New Issue
2016-01-04 18:10 shuehner Assigned To => platform
2016-01-04 18:10 shuehner Modules => Core
2016-01-04 18:10 shuehner Triggers an Emergency Pack => No
2016-01-04 18:10 shuehner Relationship added blocks 0031477
2016-01-07 12:05 alostale Status new => acknowledged
2016-01-19 07:53 alostale Relationship added related to 0008708
2016-01-19 07:53 alostale Assigned To platform => alostale
2016-01-19 07:54 alostale Review Assigned To => mtaal
2016-01-19 07:56 hgbot Checkin
2016-01-19 07:56 hgbot Note Added: 0083388
2016-01-19 07:56 hgbot Status acknowledged => resolved
2016-01-19 07:56 hgbot Resolution open => fixed
2016-01-19 07:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1e99517ffbe9ebbd8e81c238d57a2ed3d3d9783d [^]
2016-01-19 13:18 mtaal Note Added: 0083397
2016-01-19 13:18 mtaal Status resolved => closed
2016-01-19 13:18 mtaal Fixed in Version => 3.0PR16Q2
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085052


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker