Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031775
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] Z. Othersminoralways2015-12-11 12:532015-12-24 11:44
ReportermaiteView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3.5
StatusclosedFix in branchFixed in SCM revision7674a4411f0f
ProjectionnoneETAnoneTarget Version3.0PR15Q3.5
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031775: Bank Statement Line description overwritten with GL Item's description when adding gl item transaction form Match Statement

DescriptionBank Statement Line description overwritten with GL Item's description when adding gl item transaction form Match Statement
Steps To Reproduce1. Access Cuenta de Banco financial account, create new Bank Statement record
2. Add Bank Statement line setting any amount and Description as "bsl description". Process bank statement
3. Run "Match Statement" process and press Add Transaction button (+) from your line. Realize that Description field "bsl description"
4. Select any GL Item in the combo. Realize that Description field has been overwritten with GL Item's description

If you follow similar process in version prior to refctor (for example MP30.3) you can verify that description field is maintained
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00316973.0PR16Q1 closedvmromanos Bank Statement Line description overwritten with GL Item's description when adding gl item transaction form Match Statement 

-  Notes
(0082989)
hgbot (developer)
2015-12-24 11:43

Repository: erp/backports/3.0PR15Q3.5
Changeset: 2bfea240573864f3b699a1124c0c2e666b55111e
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Wed Dec 23 01:08:07 2015 +0530
URL: http://code.openbravo.com/erp/backports/3.0PR15Q3.5/rev/2bfea240573864f3b699a1124c0c2e666b55111e [^]

Fixes Issue 31775:Bank Statement Line description overwritten with GL Item's
or payment's description when adding gl item or payment in add transaction
of Match Statement Process.

This issue is fixed in two area's
1. Add Transaction Process Definition window in Match Statement.
2. Transaction Tab of Financial Account window.

Whenever there exists a description prior adding gl item or payment in above
both cases description is appended with either gl item description or
payment description.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/AddTransactionOnChangePaymentActionHandler.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/GLItemTransactionActionHandler.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/utility/FIN_Utility.java
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addTransaction.js
M src/org/openbravo/erpCommon/ad_callouts/SE_GLItem_Transaction.java
M src/org/openbravo/erpCommon/ad_callouts/SE_Payment_Transaction.java
---
(0082990)
hgbot (developer)
2015-12-24 11:43

Repository: erp/backports/3.0PR15Q3.5
Changeset: 7674a4411f0f6826e0958148eb6397f8660ac9fb
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Wed Dec 23 18:48:11 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q3.5/rev/7674a4411f0f6826e0958148eb6397f8660ac9fb [^]

Fixed bug 31775: code review improvements

In case of removing a gl item from a transaction, the part of the transaction's description related to the GL Item (and everything else afterwards) will be deleted. The part of the transaction's description before the GL Item description
 will be always kept.
The same behavior is applied when adding a new transaction from the Financial Account window and from the Match Statement --> Add transaction process

In case of removing a payment, the behavior is similar to the GL Item described above. However, since the payment description doesn't follow a constant structure (like in the case of GL Item's description), it's very hard to detect the description on the fly. That means that the flow will only work just after saving the transaction or in the first change after loading the transaction, which are the common flows. If the user selects different payments without saving the record, the system will append the different payment's description to the transaction.

The getFinAccTransactionDescription() method:
1. won't append multiple times the same description.
2. will add an extra empty line only when it's something to be appended
3. will work fine when the transaction already has a description with multiple lines
4. control any possible exception and returns the text to be append (if not blank), or the original description

Applied jsbeautifier to ob-aprm-addTransaction.js

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/GLItemTransactionActionHandler.java
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/utility/FIN_Utility.java
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addTransaction.js
M src/org/openbravo/erpCommon/ad_callouts/SE_GLItem_Transaction.java
M src/org/openbravo/erpCommon/ad_callouts/SE_Payment_Transaction.java
---
(0082991)
hgbot (developer)
2015-12-24 11:43

Repository: erp/backports/3.0PR15Q3.5
Changeset: 8294ceee69c370904bd9018635f0dc97718cff36
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Dec 24 11:03:13 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q3.5/rev/8294ceee69c370904bd9018635f0dc97718cff36 [^]

Related to issue 31775: Avoid append a null description

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/utility/FIN_Utility.java
---
(0082993)
aferraz (developer)
2015-12-24 11:44

Code review + Testing OK

- Issue History
Date Modified Username Field Change
2015-12-24 11:34 aferraz Type defect => backport
2015-12-24 11:34 aferraz Target Version 3.0PR16Q1 => 3.0PR15Q3.5
2015-12-24 11:43 hgbot Checkin
2015-12-24 11:43 hgbot Note Added: 0082989
2015-12-24 11:43 hgbot Status scheduled => resolved
2015-12-24 11:43 hgbot Resolution open => fixed
2015-12-24 11:43 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/ad230fc1c0f1641dec56661e756d54812ede9917 [^] => http://code.openbravo.com/erp/backports/3.0PR15Q3.5/rev/2bfea240573864f3b699a1124c0c2e666b55111e [^]
2015-12-24 11:43 hgbot Checkin
2015-12-24 11:43 hgbot Note Added: 0082990
2015-12-24 11:43 hgbot Fixed in SCM revision http://code.openbravo.com/erp/backports/3.0PR15Q3.5/rev/2bfea240573864f3b699a1124c0c2e666b55111e [^] => http://code.openbravo.com/erp/backports/3.0PR15Q3.5/rev/7674a4411f0f6826e0958148eb6397f8660ac9fb [^]
2015-12-24 11:43 hgbot Checkin
2015-12-24 11:43 hgbot Note Added: 0082991
2015-12-24 11:44 aferraz Review Assigned To => aferraz
2015-12-24 11:44 aferraz Note Added: 0082993
2015-12-24 11:44 aferraz Status resolved => closed
2015-12-24 11:44 aferraz Fixed in Version => 3.0PR15Q3.5


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker