Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031760
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] E. TranslationmajorN/A2015-12-22 09:542015-12-28 18:51
ReporteramayavicenteView Statuspublic 
Assigned Tovmromanos 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision4f71605143ec
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031760: [SERQA 455] Some fields cannot be translated in Sales Invoice || Add Payment

DescriptionSome fields cannot be translated in Sales Invoice || Add Payment. All the parameters have been translates in the same way, in the windows Process Definition and Element (see attached images), however, the fields 'Recieved From' and 'Deposit TO' are not translated.
Steps To Reproduce1. Install the French localization.
2. Login in the backoffice in French and open the Sales Invoice ||Add Payment
TagsSER-QA
Attached Filesjpg file icon 5732.JPG [^] (171,707 bytes) 2015-12-22 09:55


jpg file icon 5732_2.JPG [^] (142,387 bytes) 2015-12-22 09:55


jpg file icon 5732_3.JPG [^] (227,932 bytes) 2015-12-22 09:55


diff file icon add-payment-trl.diff [^] (1,638 bytes) 2015-12-22 10:38 [Show Content]
diff file icon add-payment-trl2.diff [^] (3,722 bytes) 2015-12-22 11:03 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0030986 closedinigosanchez Openbravo ERP No transalation tab for the 'Process Definition' window. 
blocks defect 0031872 closedamayavicente Openbravo Localizations Some fields cannot be translated in Purchase Invoice || Add Payment 

-  Notes
(0082924)
alostale (developer)
2015-12-22 10:23

These specific labels is they are overwritten by org.openbravo.advpaymentmngt.actionHandler.AddPaymentReloadLabelsActionHandler when the window is opened based on the context the process is opened from.

The problem is AddPaymentReloadLabelsActionHandler is not taking in consideration translations.
(0082925)
alostale (developer)
2015-12-22 10:39

Attached proposal for fix (add-payment-trl.diff). There was code to try to get translations, but the query it executed was incorrect.
(0082930)
alostale (developer)
2015-12-22 11:04

Attached alternative fix which:
-Prevents uneeded query if trl is not installed in the instance
-Removes code duplicities
(0083009)
vmromanos (developer)
2015-12-28 12:10

Test plan:
1. Install any translation pack
2. Add a new payment from the following windows in en_US:
Purchase Invoice, Sales Invoice, Payment In, Payment Out, Financial Account | Transaction (BP Withdrawal and BP Deposit).
Verify the labels for Business Partner and Financial Account are OK
3. Change the language
4. Add a new payment from the following windows in the new language:
Purchase Invoice, Sales Invoice, Payment In, Payment Out, Financial Account | Transaction (BP Withdrawal and BP Deposit).
Verify the labels for Business Partner and Financial Account are OK and properly translated.

Please note that the translation is taken from the element linked to the process definition parameter
(0083010)
hgbot (developer)
2015-12-28 12:15

Repository: erp/devel/pi
Changeset: 4f71605143ec1da2f5d80785f891dfbf3b6edd3f
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Mon Dec 28 12:15:18 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4f71605143ec1da2f5d80785f891dfbf3b6edd3f [^]

Fixed bug 31760: Some labels in Add Payment can't be translated

Solution partially based on ALO's one.
The query for translation was wrongly using the element TRL ID instead of the Application Element ID.
Avoid querying the database when language is en_US

This piece of code is executed from Purchase Invoice, Sales Invoice, Payment In, Payment Out, Financial Account | Transaction, Financial Account | Match Statement. However, only in the Financial Account flows seem to be really useful, so we should think about not running it in the other places.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/AddPaymentReloadLabelsActionHandler.java
---
(0083011)
vmromanos (developer)
2015-12-28 12:16

Code review + testing OK
(0083026)
hudsonbot (developer)
2015-12-28 18:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/45daa25294c6 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-12-22 09:54 amayavicente New Issue
2015-12-22 09:54 amayavicente Assigned To => platform
2015-12-22 09:54 amayavicente Modules => Core
2015-12-22 09:54 amayavicente Triggers an Emergency Pack => No
2015-12-22 09:55 amayavicente Tag Attached: SER-QA
2015-12-22 09:55 amayavicente File Added: 5732.JPG
2015-12-22 09:55 amayavicente File Added: 5732_2.JPG
2015-12-22 09:55 amayavicente File Added: 5732_3.JPG
2015-12-22 10:23 alostale Note Added: 0082924
2015-12-22 10:23 alostale Assigned To platform => Triage Finance
2015-12-22 10:23 inigosanchez Issue Monitored: inigosanchez
2015-12-22 10:26 alostale Relationship added related to 0030986
2015-12-22 10:38 alostale File Added: add-payment-trl.diff
2015-12-22 10:39 alostale Note Added: 0082925
2015-12-22 11:03 alostale File Added: add-payment-trl2.diff
2015-12-22 11:04 alostale Note Added: 0082930
2015-12-28 12:07 vmromanos Status new => scheduled
2015-12-28 12:07 vmromanos Assigned To Triage Finance => vmromanos
2015-12-28 12:10 vmromanos Note Added: 0083009
2015-12-28 12:15 hgbot Checkin
2015-12-28 12:15 hgbot Note Added: 0083010
2015-12-28 12:15 hgbot Status scheduled => resolved
2015-12-28 12:15 hgbot Resolution open => fixed
2015-12-28 12:15 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4f71605143ec1da2f5d80785f891dfbf3b6edd3f [^]
2015-12-28 12:16 vmromanos Review Assigned To => vmromanos
2015-12-28 12:16 vmromanos Note Added: 0083011
2015-12-28 12:16 vmromanos Status resolved => closed
2015-12-28 18:51 hudsonbot Checkin
2015-12-28 18:51 hudsonbot Note Added: 0083026
2016-01-13 12:56 amayavicente Relationship added blocks 0031872


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker