Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030986
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 00. Application dictionaryminoralways2015-09-30 11:192015-11-23 21:17
ReporternetworkbView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR16Q1
StatusclosedFix in branchFixed in SCM revision6c6381f49a85
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030986: No transalation tab for the 'Process Definition' window.

DescriptionThere is no transalation tab for the 'Process Definition' window.
Steps To ReproduceOpen 'Process Definition' window and check that there is not translation tab.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031760 closedvmromanos [SERQA 455] Some fields cannot be translated in Sales Invoice || Add Payment 

-  Notes
(0081216)
hgbot (developer)
2015-10-22 15:11

Repository: erp/devel/pi
Changeset: 0e54b749ba1f51cae383e8bb10c489d9a4f0d9bd
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Oct 15 09:53:14 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0e54b749ba1f51cae383e8bb10c489d9a4f0d9bd [^]

Related issue 30986: Add translation infrastructure for Process Definition.

Add translation DB infrastructure for Process Definition.

---
M modules/org.openbravo.client.application/src-db/database/model/tables/OBUIAPP_PROCESS.xml
M modules/org.openbravo.client.application/src-db/database/model/triggers/OBUIAPP_PROCESS_TRG.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_ELEMENT.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_TAB.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_TABLE.xml
M src-db/database/model/functions/AD_LANGUAGE_CREATE.xml
A modules/org.openbravo.client.application/src-db/database/model/tables/OBUIAPP_PROCESS_TRL.xml
---
(0081217)
hgbot (developer)
2015-10-22 15:11

Repository: erp/devel/pi
Changeset: 097255e624a27d42a00de47379a5aa7cf72365f1
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Oct 21 10:36:47 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/097255e624a27d42a00de47379a5aa7cf72365f1 [^]

Related to issue 30986: Add parameter translation tab for Process Definition.

It has been done two things:
*Added parameter translation tab for 'Process Definition'.
*Small fix in 'AD_Language' column. The reference has been changed to 'Table' reference.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_TAB.xml
---
(0081218)
hgbot (developer)
2015-10-22 15:11

Repository: erp/devel/pi
Changeset: 6c6381f49a855b298d21380c4e1c020bcefc900d
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Oct 21 12:18:28 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/6c6381f49a855b298d21380c4e1c020bcefc900d [^]

Fixed issue 30986:fixed grid position of fields in Translation tab.

It have been changed grid position of some fields.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_FIELD.xml
---
(0081219)
hgbot (developer)
2015-10-22 15:12

Repository: erp/devel/pi
Changeset: 2a8ffa8640bec53b6b92dbccfd74c17064cbe33c
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Oct 22 13:03:44 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2a8ffa8640bec53b6b92dbccfd74c17064cbe33c [^]

Related to issue 30986:Updated Obuiapp_Process_Trl_ID name element.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_ELEMENT.xml
---
(0081220)
hgbot (developer)
2015-10-22 15:12

Repository: erp/devel/pi
Changeset: 7383a9b9571d05d88597c53ce1e92739c9ce9914
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Oct 22 14:45:26 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/7383a9b9571d05d88597c53ce1e92739c9ce9914 [^]

Related to issue 30986:Updated Parameter Translation name element.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_FIELD.xml
---
(0081231)
hgbot (developer)
2015-10-22 17:28

Repository: erp/devel/pi
Changeset: 51374d48f474d46cd0bdceb4c69b553317a67634
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Oct 22 17:17:07 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/51374d48f474d46cd0bdceb4c69b553317a67634 [^]

Related to issue 30986:revert change columns type to avoid 'INT-API' failed

The problem was that it has been changed the column type of the name, description and help of
the OBUIAPP_PROCESS table and these changes have broken the api.

It has been found that this change are unnecessary and for that reason it have been reverted.

---
M modules/org.openbravo.client.application/src-db/database/model/tables/OBUIAPP_PROCESS.xml
---
(0081239)
hgbot (developer)
2015-10-22 20:08

Repository: erp/devel/pi
Changeset: b8ea466ed10facd3acb43a15903cc7ff28b8efe2
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Oct 22 20:06:52 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b8ea466ed10facd3acb43a15903cc7ff28b8efe2 [^]

Related to issue 30986:updated column type in obuiapp_process_trl table.

The problem was that testTrlColumnsOraTyp was failling. It has been updated column
types in obuiapp_process_trl table and now it has been resolved the problem.

---
M modules/org.openbravo.client.application/src-db/database/model/tables/OBUIAPP_PROCESS_TRL.xml
---
(0081247)
hgbot (developer)
2015-10-23 09:40

Repository: erp/devel/pi
Changeset: cf2c4e3ef1a87cadaa8d80f4e299f1e7013cfac2
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Oct 23 09:39:33 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/cf2c4e3ef1a87cadaa8d80f4e299f1e7013cfac2 [^]

related to issue 30986: Process Def > Parameter tab marked as trl

  In this way it will not be shown unless "Show Trl Tabs" prefrence is enabled

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_TAB.xml
---
(0081249)
alostale (developer)
2015-10-23 09:57

Code review:
- When creating new language code has been included in AD_LANGUAGE_CREATE which is in core, being insertions for a table in client.application module, the code managing them should be within that module (obuiapp_language_create) where parameters are also handled.
(0081252)
hgbot (developer)
2015-10-23 10:46

Repository: erp/devel/pi
Changeset: 04c472ffcb50fd66990d3af0f91d4fb1ca2568c0
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Oct 23 10:45:30 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/04c472ffcb50fd66990d3af0f91d4fb1ca2568c0 [^]

Related to issue 30986:Code review improvements.

The problem was when creating new language code has been included in AD_LANGUAGE_CREATE
which is in core, being insertions for a table in client.application module, the code
managing them should be within that module (OBUIAPP_LANGUAGE_CREATE) where parameters
are also handled.

Now it has been resolved the problem by moving the code to the correct function
(OBUIAPP_LANGUAGE_CREATE).

---
M modules/org.openbravo.client.application/src-db/database/model/functions/OBUIAPP_LANGUAGE_CREATE.xml
M src-db/database/model/functions/AD_LANGUAGE_CREATE.xml
---
(0081292)
alostale (developer)
2015-10-26 09:29

code reviewed

Tested:
- Process definition trl tab is present (if Show Translation preference is set)
- Parameter trl tab is present (if Show Translation preference is set)
- When a language is set as System and Verify Language process is executed, trl entries both for process definition and its params are created
- Process Definition and Params are exported as part of the language
- When installing a trl module these entries are loaded

Note button name in case a process definition is invocable from a standard window is obtained from the button (column) name, not from the process definition. When invocable from menu, its got from menu entry.
(0081489)
hgbot (developer)
2015-11-05 00:25

Repository: erp/devel/pi
Changeset: 6014133a6a4dee459b7ad4296db47012719a9c4f
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Nov 05 00:24:35 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/6014133a6a4dee459b7ad4296db47012719a9c4f [^]

Related to issue 30986:Problem adding to a role a process definition access

The problem was when it is tried to translated a "process definition". In
a "Role" window it can be added a "process definition" access and it is
not translated.

The process "generate.entities" has thrown an error because a column that
is call process definition in obuiapp_process_trl has "Link to Parent
Column" unselected.

This check had been forgotten to set properly.Now, It has been resolved
with this fix.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
---
(0081529)
hgbot (developer)
2015-11-05 16:56

Repository: erp/devel/pi
Changeset: a7b2496ca7523a1585fd3244529628bbc8b02af7
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Nov 05 16:49:15 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/a7b2496ca7523a1585fd3244529628bbc8b02af7 [^]

Related to issue 30986:Check translation checkbox of translated columns

The problem was when it is tried to translated a "process definition". In
a "Role" window it can be added a "process definition" access and it is
not translated.

It is selected "translation" checkboxes in name, help and description
columns in "OBUIAPP_Process" table to translate properly.

---
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
---
(0082143)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082144)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082145)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082146)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082147)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082149)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082152)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082153)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082154)
hudsonbot (developer)
2015-11-23 21:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082172)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test
(0082182)
hudsonbot (developer)
2015-11-23 21:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7b56bebaaa88 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-09-30 11:19 networkb New Issue
2015-09-30 11:19 networkb Assigned To => platform
2015-09-30 11:19 networkb Modules => Core
2015-09-30 11:19 networkb Triggers an Emergency Pack => No
2015-09-30 16:28 alostale Status new => acknowledged
2015-10-09 08:53 alostale Severity major => minor
2015-10-13 11:13 alostale Status acknowledged => scheduled
2015-10-13 11:13 alostale Assigned To platform => inigosanchez
2015-10-22 15:10 inigosanchez Review Assigned To => alostale
2015-10-22 15:10 inigosanchez Issue Monitored: alostale
2015-10-22 15:11 hgbot Checkin
2015-10-22 15:11 hgbot Note Added: 0081216
2015-10-22 15:11 hgbot Checkin
2015-10-22 15:11 hgbot Note Added: 0081217
2015-10-22 15:11 hgbot Checkin
2015-10-22 15:11 hgbot Note Added: 0081218
2015-10-22 15:11 hgbot Status scheduled => resolved
2015-10-22 15:11 hgbot Resolution open => fixed
2015-10-22 15:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/6c6381f49a855b298d21380c4e1c020bcefc900d [^]
2015-10-22 15:12 hgbot Checkin
2015-10-22 15:12 hgbot Note Added: 0081219
2015-10-22 15:12 hgbot Checkin
2015-10-22 15:12 hgbot Note Added: 0081220
2015-10-22 17:28 hgbot Checkin
2015-10-22 17:28 hgbot Note Added: 0081231
2015-10-22 20:08 hgbot Checkin
2015-10-22 20:08 hgbot Note Added: 0081239
2015-10-23 09:40 hgbot Checkin
2015-10-23 09:40 hgbot Note Added: 0081247
2015-10-23 09:57 alostale Note Added: 0081249
2015-10-23 10:46 hgbot Checkin
2015-10-23 10:46 hgbot Note Added: 0081252
2015-10-26 09:29 alostale Note Added: 0081292
2015-10-26 09:29 alostale Status resolved => closed
2015-10-26 09:29 alostale Fixed in Version => 3.0PR16Q1
2015-11-05 00:25 hgbot Checkin
2015-11-05 00:25 hgbot Note Added: 0081489
2015-11-05 16:56 hgbot Checkin
2015-11-05 16:56 hgbot Note Added: 0081529
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082143
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082144
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082145
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082146
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082147
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082149
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082152
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082153
2015-11-23 21:16 hudsonbot Checkin
2015-11-23 21:16 hudsonbot Note Added: 0082154
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082172
2015-11-23 21:17 hudsonbot Checkin
2015-11-23 21:17 hudsonbot Note Added: 0082182
2015-12-22 10:26 alostale Relationship added related to 0031760


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker