Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031468
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. Platformminoralways2015-11-13 13:052016-03-17 10:54
ReporterNaroaIriarteView Statuspublic 
Assigned ToNaroaIriarte 
PrioritynormalResolutionfixedFixed in Version3.0PR16Q2
StatusclosedFix in branchFixed in SCM revisionafa165be3e59
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031468: It would be nice to prevent sorting and filtering some columns.

DescriptionIf we are working in a high volume environment, some columns cannot perform well when sorting or filtering, there exists the possibility of using the "Grid Configuration" at system, tab or field level to prevent sorting and filtering. But it is not possible to have different configurations at the same level because it is designed to be applied at instance data.
There are also some columns which should be, by default, defined as non sortable nor filterable, for example the computed columns.
It would be nice to create a solution for these topics.

More information within project specs: http://wiki.openbravo.com/wiki/Projects:Disable_Default_Field_Filtering_and_Sorting [^]
Steps To Reproduce-As System Admin go to the Grid Configuration at System level window.
-Click on create new doc button.
-Save the record.
-Click again on the create new doc button.
-Click on save button and realize that it is not possible to save more than one record.
-Close the window.
-As System Admin go to the Grid configuration at Window/Tab/Field level.
-Click on create new doc button.
-In the "Tab" field choose "Header - Sales Order"
-Save the record.
-Click on the create new doc button again.
-In the "Tab" field choose "Header - Sales Order" again.
-Click on the save button and realize that it is not possible to save more than one record applied to the same tab.

Proposed SolutionThere are two solutions, one which applies to the fact of making some columns not sortable nor filterable by default.
There will be two new boolean fields in the columns, Allow Filtering and Allow Sorting, so, if they are checked, the fields based on those columns will be filterable and sortable.

The other solution is the one which applies to the fact of being able to have more than one grid configuration at the same level. To do that a new field "sequence number" will be added to the grid configuration at system level and to the grid configuration at tab level.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028478 closedNaroaIriarte view generation: unneeded queries to grid config tables 
related to defect 00321523.0PR16Q2 closedNaroaIriarte Some columns of tables that belong to the AD dataset can be modified even if their module is not in development 
related to defect 00321513.0PR16Q2 closedNaroaIriarte The Allow Filtering flag is not working for columns that use the Text reference 
causes defect 0034864 closedNaroaIriarte Ordering in GL Item grid in Add Payment process definition does not work. It deletes the lines. 

-  Notes
(0083245)
hgbot (developer)
2016-01-13 15:41

Repository: erp/devel/pi
Changeset: afa165be3e5900d1114d33e5106114d0e089876a
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Wed Jan 13 15:33:23 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/afa165be3e5900d1114d33e5106114d0e089876a [^]

Fixed issue 31468: Implemented sorting and filtering defaults

Merge with the pi-field-filt-sort project.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.application/src-db/database/model/tables/OBUIAPP_GC_SYSTEM.xml
M modules/org.openbravo.client.application/src-db/database/model/tables/OBUIAPP_GC_TAB.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_CALLOUT.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_FIELD.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M modules/org.openbravo.client.application/src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/OBViewUtil.java
M modules/org.openbravo.client.kernel/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/reference/UIDefinition.java
M modules/org.openbravo.client.myob/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.client.querylist/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.service.datasource/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.service.integration.google/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.service.integration.openid/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.userinterface.selector/src-db/database/sourcedata/AD_COLUMN.xml
M modules/org.openbravo.utility.cleanup.log/src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/model/tables/AD_COLUMN.xml
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
M src-test/src/org/openbravo/test/AllAntTaskTests.java
M src-test/src/org/openbravo/test/views/ViewGenerationWithDifferentConfigLevelTest.java
A modules/org.openbravo.client.application/src/org/openbravo/client/application/window/GridConfigurationSequenceNumberCallout.java
A src-test/src/org/openbravo/test/views/GCSequenceNumberTests.java
A src-test/src/org/openbravo/test/views/SortingFilteringGridConfiguration.java
---
(0083286)
hgbot (developer)
2016-01-14 11:14

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: e5374a098b5d1d3340c3a1f70f91dfddd81be627
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu Jan 14 11:13:58 2016 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/e5374a098b5d1d3340c3a1f70f91dfddd81be627 [^]

Related with issue 31468: Fixed column problem in retail modules.

dbcons was failing because the new columns introduced by the
pi-field-filt-sort proyect were not exported to reatil modules.

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0083287)
hgbot (developer)
2016-01-14 11:16

Repository: erp/pmods/org.openbravo.retail.config
Changeset: 1649f7bc7865cc8ccdeeb81873203fd4daf80677
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu Jan 14 11:15:27 2016 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.config/rev/1649f7bc7865cc8ccdeeb81873203fd4daf80677 [^]

Related with issue 31468: Fixed column problem in retail modules.

dbcons was failing because the new columns introduced by the
pi-field-filt-sort proyect were not exported to reatil modules.

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0083288)
hgbot (developer)
2016-01-14 11:17

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: a81d56702755702470e1e5f66a6b00649121949b
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu Jan 14 11:16:54 2016 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/a81d56702755702470e1e5f66a6b00649121949b [^]

Related with issue 31468: Fixed column problem in retail modules.

dbcons was failing because the new columns introduced by the
pi-field-filt-sort proyect were not exported to reatil modules.

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0083289)
hgbot (developer)
2016-01-14 11:18

Repository: erp/pmods/org.openbravo.retail.discounts
Changeset: 1ab09dd431c26e02caf2636b2df12ba1504e836f
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu Jan 14 11:18:06 2016 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/1ab09dd431c26e02caf2636b2df12ba1504e836f [^]

Related with issue 31468: Fixed column problem in retail modules.

dbcons was failing because the new columns introduced by the
pi-field-filt-sort proyect were not exported to reatil modules.

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0083322)
hgbot (developer)
2016-01-15 01:00

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: a121cbc0fbb017288ea939ca0bb07b03352d8b06
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Fri Jan 15 00:54:07 2016 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/a121cbc0fbb017288ea939ca0bb07b03352d8b06 [^]

Related with issue 31468: Add new columns to gift card module

---
M src-db/database/sourcedata/AD_COLUMN.xml
---
(0083338)
alostale (developer)
2016-01-15 11:22

code reviewed and tested as part of the project
https://docs.google.com/spreadsheets/d/1asXovAvF3l340GSW2YIHl8vevRdg_aUrQ7USlJnm2Yw/edit#gid=0 [^]
(0085036)
hudsonbot (developer)
2016-03-17 10:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b22fb0500156 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-11-13 13:05 NaroaIriarte New Issue
2015-11-13 13:05 NaroaIriarte Assigned To => platform
2015-11-13 13:05 NaroaIriarte Modules => Core
2015-11-13 13:05 NaroaIriarte Triggers an Emergency Pack => No
2015-11-13 13:05 NaroaIriarte Assigned To platform => NaroaIriarte
2015-11-13 13:05 NaroaIriarte Relationship added related to 0028478
2015-11-13 14:01 alostale Status new => scheduled
2016-01-13 15:41 hgbot Checkin
2016-01-13 15:41 hgbot Note Added: 0083245
2016-01-13 15:41 hgbot Status scheduled => resolved
2016-01-13 15:41 hgbot Resolution open => fixed
2016-01-13 15:41 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/afa165be3e5900d1114d33e5106114d0e089876a [^]
2016-01-13 15:42 NaroaIriarte Review Assigned To => alostale
2016-01-14 11:14 hgbot Checkin
2016-01-14 11:14 hgbot Note Added: 0083286
2016-01-14 11:16 hgbot Checkin
2016-01-14 11:16 hgbot Note Added: 0083287
2016-01-14 11:17 hgbot Checkin
2016-01-14 11:17 hgbot Note Added: 0083288
2016-01-14 11:18 hgbot Checkin
2016-01-14 11:18 hgbot Note Added: 0083289
2016-01-15 01:00 hgbot Checkin
2016-01-15 01:00 hgbot Note Added: 0083322
2016-01-15 11:22 alostale Description Updated View Revisions
2016-01-15 11:22 alostale Note Added: 0083338
2016-01-15 11:22 alostale Status resolved => closed
2016-01-15 11:22 alostale Fixed in Version => 3.0PR16Q2
2016-02-25 14:43 alostale Relationship added related to 0032152
2016-02-25 14:45 alostale Relationship added related to 0032151
2016-03-17 10:54 hudsonbot Checkin
2016-03-17 10:54 hudsonbot Note Added: 0085036
2017-01-10 09:26 NaroaIriarte Relationship added causes 0034864


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker