Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0031406
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajoralways2015-11-09 13:382015-12-15 23:49
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision8942b6596f0b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0031406: Post button is not hidden in some windows although Show Accounting Tabs is set to No

DescriptionPost button is not hidden in some windows although Show Accounting Tabs is set to No
Steps To ReproduceAs group admin role:
   Go to Session Preferences window and remove the selection of the Show Accounting tabs checkbox
   Go to Preference window and check the ShowAcct preference
   Log out and log in
   Go to the following windows, select a completed record and check the post button is shown:
      Payment In
      Payment Out
      Financial Account - Transaction
      ...
TagsNo tags attached.
Attached Filespng file icon issue_31406.png [^] (72,836 bytes) 2015-12-09 12:36

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0082601)
AtulOpenbravo (developer)
2015-12-07 20:43
edited on: 2015-12-09 14:17

Test Plan
- Login as Group Admin role.
- Go to Session Preferences window and remove the selection of the Show Accounting tabs checkbox
- Log out and log in
- Go to the following windows, select a completed record and check the post button is not shown in following windows.
     - Payment In
     - Payment Out
     - Financial Account - Transaction
As well as for windows such as : Sales Invoice or Purchase Invoice.

*** Recheck Post button is again visible in all above windows by setting Show Accounting tabs = Yes in session preferences by Log out and Login again.

(0082615)
psanjuan (manager)
2015-12-09 12:35
edited on: 2015-12-09 12:36

Issue Verified.
If the checkbox "Show Accounting Tabs" is not checked post button is not shown in forms such as sales/purchase invoice, while it is shown in forms such as Payment In, Payment Out and Financial Account.

To take advantage of the resolution of this issue, the checkbox needs to be renamed as "Enable Accounting"; because current string is confusing as it is not just the matter of showing/not showing "Accounting" tabs but "Post" button which enable or not posting documents to the ledger. See image attached.

(0082621)
psanjuan (manager)
2015-12-09 14:16

Test Plan above verified.

Issue can be closed once it is code review after changing checkbox label to "Enable Accounting".
(0082636)
psanjuan (manager)
2015-12-10 12:43

Verified. Label changed, Issue can be code reviewed and closed.
(0082778)
hgbot (developer)
2015-12-15 18:05

Repository: erp/devel/pi
Changeset: 8942b6596f0bdfbacfcc0f8b348e7485aa12f022
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Dec 10 15:10:00 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/8942b6596f0bdfbacfcc0f8b348e7485aa12f022 [^]

Fixes Issue 31406:Post button is not hidden in some windows although Show
Accounting Tabs is set to No

Added missing part to display logic of Posted Button field based on Show
Accounting Flag in session preferences for Payment In - Header Tab,
Payment Out - Header Tab and financial Account Transaction Tab.
Show Accouting flag is renamed as Enable Accounting

---
M src-db/database/sourcedata/AD_FIELD.xml
M src-db/database/sourcedata/AD_TEXTINTERFACES.xml
M src/org/openbravo/erpCommon/ad_forms/ShowSessionPreferences.html
---
(0082779)
vmromanos (developer)
2015-12-15 18:06

Code review + testing OK
(0082792)
hudsonbot (developer)
2015-12-15 23:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ecd185534f50 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-11-09 13:38 ngarcia New Issue
2015-11-09 13:38 ngarcia Assigned To => Triage Finance
2015-11-09 13:38 ngarcia Modules => Core
2015-11-09 13:38 ngarcia Triggers an Emergency Pack => No
2015-11-09 13:38 ngarcia Issue Monitored: networkb
2015-12-07 20:41 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2015-12-07 20:43 AtulOpenbravo Status new => scheduled
2015-12-07 20:43 AtulOpenbravo Note Added: 0082601
2015-12-09 12:35 psanjuan Note Added: 0082615
2015-12-09 12:36 psanjuan Note Edited: 0082615 View Revisions
2015-12-09 12:36 psanjuan File Added: issue_31406.png
2015-12-09 14:16 psanjuan Note Added: 0082621
2015-12-09 14:17 psanjuan Note Edited: 0082601 View Revisions
2015-12-10 12:43 psanjuan Note Added: 0082636
2015-12-15 18:05 hgbot Checkin
2015-12-15 18:05 hgbot Note Added: 0082778
2015-12-15 18:05 hgbot Status scheduled => resolved
2015-12-15 18:05 hgbot Resolution open => fixed
2015-12-15 18:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8942b6596f0bdfbacfcc0f8b348e7485aa12f022 [^]
2015-12-15 18:06 vmromanos Review Assigned To => vmromanos
2015-12-15 18:06 vmromanos Note Added: 0082779
2015-12-15 18:06 vmromanos Status resolved => closed
2015-12-15 23:49 hudsonbot Checkin
2015-12-15 23:49 hudsonbot Note Added: 0082792


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker