Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030946
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Cash upminoralways2015-02-17 23:062015-10-02 15:11
ReportermalsasuaView Statuspublic 
Assigned Tomarvintm 
PrioritynormalResolutionfixedFixed in VersionRR15Q2.5
StatusclosedFix in branchFixed in SCM revision60ae023272fa
ProjectionnoneETAnoneTarget VersionRR15Q2.5
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned ToOrekaria
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030946: additional checks to avoid wrong cashups

DescriptionWhen a same terminal is accessed from two or more devices, the cashups generated by this terminal can be wrong.

When it happens, the cashup should not be processed and it should be included in "Errors while importing data" window
Steps To Reproducein device1
. clean cache
. do login in VBS-1
. new cashup with "id1" is created in local database
. create and pay a new receipt
. logout

in device2
. clean cache
. do login in VBS-1
. cashup with "id1" is loaded in local database
. create and pay a new receipt
. do a cashup
. logout

in device1
. do login in VBS-1
. cashup with "id1" is loaded in local database
. create and pay a new receipt

in backoffice, the cashup with "id1" is set as
. processed=N
. processedbo=Y

it is wrong
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0028975 closedmarvintm additional checks to avoid wrong cashups 

-  Notes
(0080662)
marvintm (developer)
2015-09-28 11:05

This issue was originally intended to be included in 15Q2, but due to some technical issues finally it didn't happen. It will be included in 15Q2.5.
(0080664)
hgbot (developer)
2015-09-28 11:06

Repository: retail/backports/3.0RR15Q2.5/org.openbravo.retail.posterminal
Changeset: 60ae023272faad8ba85b44153e2e4c6f09d6f862
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Sep 28 11:06:14 2015 +0200
URL: http://code.openbravo.com/retail/backports/3.0RR15Q2.5/org.openbravo.retail.posterminal/rev/60ae023272faad8ba85b44153e2e4c6f09d6f862 [^]

Fixed issue 30946. aditionals checks to verify if the cashup was processed previously

three changes:
when a receipt is synced, in the orderloader is verified if the cashup related to the receipt has been processed previously
in the query to load the cashup in the terminal from backend, only will be loaded the cashups not processed
when a cashup is synced, it is not allowed to change the processed field from Y to N

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
M src/org/openbravo/retail/posterminal/ProcessCashClose.java
M src/org/openbravo/retail/posterminal/master/Cashup.java
M web/org.openbravo.retail.posterminal/js/utils/cashUpReportUtils.js
---

- Issue History
Date Modified Username Field Change
2015-09-28 11:04 marvintm Type defect => backport
2015-09-28 11:04 marvintm Target Version => RR15Q2.5
2015-09-28 11:05 marvintm Note Added: 0080662
2015-09-28 11:06 hgbot Checkin
2015-09-28 11:06 hgbot Note Added: 0080664
2015-09-28 11:06 hgbot Status scheduled => resolved
2015-09-28 11:06 hgbot Resolution open => fixed
2015-09-28 11:06 hgbot Fixed in SCM revision http://code.openbravo.com/retail/backports/3.0RR15Q2/org.openbravo.retail.posterminal/rev/616729f0e0ecf356797e40e89e374bd7b50179f0 [^] => http://code.openbravo.com/retail/backports/3.0RR15Q2.5/org.openbravo.retail.posterminal/rev/60ae023272faad8ba85b44153e2e4c6f09d6f862 [^]
2015-10-02 15:11 Orekaria Review Assigned To adrianromero => Orekaria
2015-10-02 15:11 Orekaria Status resolved => closed
2015-10-02 15:11 Orekaria Fixed in Version => RR15Q2.5


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker