Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030818
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 03. Procurement managementmajoralways2015-09-10 16:562015-09-14 17:55
ReportermalsasuaView Statuspublic 
Assigned Todmiguelez 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision3161f68cc47a
ProjectionnoneETAnoneTarget Version3.0PR15Q3.2
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionpiSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-04-28
Regression introduced in release3.0PR15Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/annotate/b134bab019fe/src/org/openbravo/erpCommon/ad_process/ExpenseAPInvoice.java#l123 [^]
Triggers an Emergency PackNo
Summary

0030818: process: "Create expense AP Invoice" does not work

Descriptionthe process to create the purchase invoice from expense sheet is not working. Error is returned:
    
Error
java.lang.NullPointerException
Steps To Reproduce. in F&B
 . create a new product (p1) of type Expense and add in Price list Otros servicios
 . configure the BP: Javier Martin:
    . Vendor: true
       PO price list: otros servicios
       PO payment method: anyone
       PO payment termns: anyone
       PO financial account: anyone

 . go to expense sheet:
  new record:
   BP: Javier Martin
   date: 10-08-2015
   new line
     time sheet: no
     product: p1
     net unit price: 10
     date: 10-08-2015
  .process it

. go to "Create expense ap invoice" process
 . bp: javier martin
 . date from: 01-08-2015
 . date to: 31-08-2015
 . date invoice: 31-08-2015

process -> error is returned
java.lang.NullPointerException
Proposed Solution. the problem is in the line
https://code.openbravo.com/erp/devel/pi/file/13211c4cc0a0/src/org/openbravo/erpCommon/ad_process/ExpenseAPInvoice.java#l200 [^]
the insert of invoice header is done with the connection "conn" (and this connection is of type DalConnectionProvider(false).getTransactionConnection()) but after that, in the line
https://code.openbravo.com/erp/devel/pi/file/13211c4cc0a0/src/org/openbravo/erpCommon/utility/AccDefUtility.java#l135 [^]
this invoice is not retrieved, because it is in other session.

I think that the commit that it generated the regression is:
https://code.openbravo.com/erp/devel/pi/annotate/b134bab019fe/src/org/openbravo/erpCommon/ad_process/ExpenseAPInvoice.java#l123 [^]
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0030811 closeddmiguelez process: "Create expense AP Invoice" does not work 

-  Notes
(0080381)
hgbot (developer)
2015-09-14 17:54

Repository: erp/backports/3.0PR15Q3.2
Changeset: 3161f68cc47a094de8658526eac54f66a9d7cbb7
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Mon Sep 14 10:24:52 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q3.2/rev/3161f68cc47a094de8658526eac54f66a9d7cbb7 [^]

Fixes Issue 30818: Changes connection used for retrieving data using
xsql files. Uses OBDal Connection and uses OBDal methods for
doing rollback and commit with Close.

---
M src/org/openbravo/erpCommon/ad_process/ExpenseAPInvoice.java
---
(0080382)
vmromanos (developer)
2015-09-14 17:55

Code review + testing OK

- Issue History
Date Modified Username Field Change
2015-09-14 16:06 vmromanos Type defect => backport
2015-09-14 16:06 vmromanos Target Version => 3.0PR15Q3.2
2015-09-14 17:02 vmromanos Tag Attached: Approved
2015-09-14 17:54 hgbot Checkin
2015-09-14 17:54 hgbot Note Added: 0080381
2015-09-14 17:54 hgbot Status scheduled => resolved
2015-09-14 17:54 hgbot Resolution open => fixed
2015-09-14 17:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q3.2/rev/3161f68cc47a094de8658526eac54f66a9d7cbb7 [^]
2015-09-14 17:55 vmromanos Note Added: 0080382
2015-09-14 17:55 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker