Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030491
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 04. Warehouse managementmajoralways2015-07-31 12:272015-08-13 11:16
ReporterumartirenaView Statuspublic 
Assigned ToAtulOpenbravo 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionb0fbae0ed40c
ProjectionnoneETAnoneTarget Version3.0PR15Q2.4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date2014-06-16
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/05f152469a6a [^]
Triggers an Emergency PackNo
Summary

0030491: Return from Customer Pick&Edit Lines allows to enter more quantity to return than the pending to be returned

DescriptionReturn from Customer Pick&Edit Lines allows to enter more quantity to return than the pending to be returned. This happens because the "Returned Quantity other RM" field is showing negative values instead of positive, so this makes the validation on Returned field to perform wrongly.

There is another issue in the pick&edit probably related to the same problem. It shows shipment lines fully returned, when they should not appear.
Steps To ReproduceAs F&B Group Admin:
 * Go to Sales Order window and create a Sales Order with a product with stock for quantity 5.
 * Go to Create Shipments from Orders and create the shipment from the previous Sales Order.
 * Go to Return from Customer Window and create a header for the same Business Partner as previous Order/Shipment.
 * Click on Pick&Edit Lines and select the previous shipment line. Set Returned 3. CLick Done.
 * Book the document.
 * Create a new header of Return from Customer.
 * Click again on Pick&Edit Lines. Realize that the previous shipment line appears with -3 on Returned Quantity other RM field, what is wrong because it should be 3.
 * Check also that it allows to enter a value on Returned field between 0 and 8. when it should be between 0 and 2.
 * At least, if you put a value greater than 3 it will not allow to book the document, it will throw an error.
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0030471 closedAtulOpenbravo Return from Customer Pick&Edit Lines allows to enter more quantity to return than the pending to be returned 

-  Notes
(0079170)
hgbot (developer)
2015-08-04 11:58

Repository: erp/backports/3.0PR15Q2.4
Changeset: b0fbae0ed40c03f5b4eb04696a1cf26b7390b5ca
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Mon Aug 03 23:08:59 2015 +0530
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.4/rev/b0fbae0ed40c03f5b4eb04696a1cf26b7390b5ca [^]

Fixes Issue 30491: Return from Customer Pick&Edit Lines allows to enter more
quantity to return than the pending to be returned

Return document has negative movementqty so ReturnQtyOtherRM was negative.
It should be postive so unlike ReturnQty it is multiplied with -1 as in prev
Datasource prior to transforming it to HQL PE. Where clause which checks
MovementQty of shipment line with the ReturnQtyOtherRM was missing. Sum of
Shipmentline MovementQty and ReturnQtyOtherRM should not be zero. It is added
to fix the problem.

---
M src-db/database/sourcedata/AD_TABLE.xml
---
(0079172)
vmromanos (developer)
2015-08-04 12:00

Code review + testing OK

Tested in both Oracle and PostgreSQL

- Issue History
Date Modified Username Field Change
2015-08-04 10:25 AtulOpenbravo Type defect => backport
2015-08-04 10:25 AtulOpenbravo Target Version => 3.0PR15Q2.4
2015-08-04 10:35 vmromanos Tag Attached: Approved
2015-08-04 11:58 hgbot Checkin
2015-08-04 11:58 hgbot Note Added: 0079170
2015-08-04 11:58 hgbot Status scheduled => resolved
2015-08-04 11:58 hgbot Resolution open => fixed
2015-08-04 11:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.4/rev/b0fbae0ed40c03f5b4eb04696a1cf26b7390b5ca [^]
2015-08-04 12:00 vmromanos Review Assigned To => vmromanos
2015-08-04 12:00 vmromanos Note Added: 0079172
2015-08-04 12:00 vmromanos Status resolved => closed
2015-08-13 11:16 ngarcia Issue Monitored: ngarcia


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker