Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030470
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-07-31 10:392015-08-20 23:16
ReporterVictorVillarView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionad9fcefd23db
ProjectionnoneETAnoneTarget Version3.0PR15Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030470: Wrong posted status for Bill of Materials Production documents

DescriptionWrong posted status for Bill of Materials Production documents when the cost is not calculated yet and the user is trying to post them
Steps To ReproduceAs group Admin role,
  Go to Process Request window:
     stop the Acct Server process and the Costing background process
 Go to Product window,
   Select Cerveza Ale
   Bill of Materials: Yes
 Go to The BOM tab:
    Add Agua
Click on Verify BOM button

Go to Bill of Materials Production
  select Cerveza Ale
  Add a locator
 Create the Production
Click again, and process the production.

Then Launch the Acct Server. Realisa tha the BOM Production is post: Error but should be Post: Cost Not calculated
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0079266)
AtulOpenbravo (developer)
2015-08-10 07:06

Test Plan
- Login as Group Admin role.
- Go to Process Request window
     Stop the Acct Server process and the Costing background process.
- Go to Product window. Select product Cerveza Ale and set Bill of Materials = Yes.
- Go to The BOM tab. Add product Agua Quantity 1.
- Click on Verify BOM button
- Go to Bill of Materials Production. Select Cerveza Ale, Add a locator.
- Click on Create the Production.
- Click again, for process the production.
- Launch the Acct Server. Check that BOM Production status is Post:Cost Not calculated.
(0079304)
hgbot (developer)
2015-08-11 10:01

Repository: erp/devel/pi
Changeset: ad9fcefd23db7fe5042c4fb3e5d5445594db97f1
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Sun Aug 09 13:15:35 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/ad9fcefd23db7fe5042c4fb3e5d5445594db97f1 [^]

Fixes Issue 30470:Wrong posted status for Bill of Materials Production
documents

Post Error was shown when a non cost calculated production entry
was posted. Now proper status Cost Not Calculated is shown by raising a
OBException and handling properly it properly in AcctServer.

---
M src/org/openbravo/erpCommon/ad_forms/AcctServer.java
M src/org/openbravo/erpCommon/ad_forms/DocProduction.java
---
(0079305)
hgbot (developer)
2015-08-11 10:01

Repository: erp/devel/pi
Changeset: 3b3aefef0ce70dacd28d0706c3ed295907cfb1d4
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Mon Aug 10 15:03:57 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3b3aefef0ce70dacd28d0706c3ed295907cfb1d4 [^]

Related to issue 30470: code review improvements

The error message when manually posting the record was overwritten by the "@NotCalculatedCost@" string because the catch code always overwrites the message set in the correspondent Doc* class.
This was wrong, as the Doc* class should be in charge of setting the error message.
Now the message is only overwritten if it hasn't previously set by the correspondent Doc* class

---
M src/org/openbravo/erpCommon/ad_forms/AcctServer.java
---
(0079306)
vmromanos (developer)
2015-08-11 10:02

Code review + testing OK
(0079540)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079541)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-07-31 10:39 VictorVillar New Issue
2015-07-31 10:39 VictorVillar Assigned To => Triage Finance
2015-07-31 10:39 VictorVillar Modules => Core
2015-07-31 10:39 VictorVillar Triggers an Emergency Pack => No
2015-07-31 10:39 VictorVillar Issue Monitored: networkb
2015-08-10 07:03 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2015-08-10 07:03 AtulOpenbravo Status new => scheduled
2015-08-10 07:06 AtulOpenbravo Note Added: 0079266
2015-08-11 10:01 hgbot Checkin
2015-08-11 10:01 hgbot Note Added: 0079304
2015-08-11 10:01 hgbot Status scheduled => resolved
2015-08-11 10:01 hgbot Resolution open => fixed
2015-08-11 10:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ad9fcefd23db7fe5042c4fb3e5d5445594db97f1 [^]
2015-08-11 10:01 hgbot Checkin
2015-08-11 10:01 hgbot Note Added: 0079305
2015-08-11 10:02 vmromanos Review Assigned To => vmromanos
2015-08-11 10:02 vmromanos Note Added: 0079306
2015-08-11 10:02 vmromanos Status resolved => closed
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079540
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079541


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker