Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030418
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementcriticalalways2015-07-23 17:152015-07-23 19:02
ReporterdmiguelezView Statuspublic 
Assigned ToTriage Finance 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionf6d7ef8a9f79
ProjectionnoneETAnoneTarget Version3.0PR15Q2.3
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030418: While calculating Cost Adjustments the Process stops randomly stating that there is no avg Cost even if there is one

DescriptionWhile calculating Cost Adjustments the Process stops randomly stating that there is no avg Cost even if there is one
Steps To ReproduceThis has happened in a Client and we have not been able to reproduce it.

But, while debugging it we've realized that at some point in the Cost Adjustment Process, the process is looking for Average Costs records from a different Product than the one that is being Processed.

This is due to a global variable in AverageCostAdjustmen.java file that has not been initialized again and uses the value from the previous Transaction.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0030416 closedTriage Finance While calculating Cost Adjustments the Process stops randomly stating that there is no avg Cost even if there is one 

-  Notes
(0079050)
hgbot (developer)
2015-07-23 17:19

Repository: erp/backports/3.0PR15Q2.3
Changeset: f6d7ef8a9f79df996a5181374d78cdc11b4962c7
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Jul 23 17:16:08 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/f6d7ef8a9f79df996a5181374d78cdc11b4962c7 [^]

Fixes issue 30418. Initialize global variable each time to
make sure it does not uses values from a previous execution.

---
M src/org/openbravo/costing/AverageCostAdjustment.java
---
(0079064)
dmiguelez (developer)
2015-07-23 19:02

Code Reviewed + Tested in several Clients

- Issue History
Date Modified Username Field Change
2015-07-23 17:15 dmiguelez Type defect => backport
2015-07-23 17:15 dmiguelez Target Version => 3.0PR15Q2.3
2015-07-23 17:19 hgbot Checkin
2015-07-23 17:19 hgbot Note Added: 0079050
2015-07-23 17:19 hgbot Status scheduled => resolved
2015-07-23 17:19 hgbot Resolution open => fixed
2015-07-23 17:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/f6d7ef8a9f79df996a5181374d78cdc11b4962c7 [^]
2015-07-23 19:02 dmiguelez Review Assigned To => dmiguelez
2015-07-23 19:02 dmiguelez Note Added: 0079064
2015-07-23 19:02 dmiguelez Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker