Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030416
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementcriticalalways2015-07-23 17:152015-08-20 23:16
ReporterdmiguelezView Statuspublic 
Assigned ToTriage Finance 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision5e1331b3eaa7
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030416: While calculating Cost Adjustments the Process stops randomly stating that there is no avg Cost even if there is one

DescriptionWhile calculating Cost Adjustments the Process stops randomly stating that there is no avg Cost even if there is one
Steps To ReproduceThis has happened in a Client and we have not been able to reproduce it.

But, while debugging it we've realized that at some point in the Cost Adjustment Process, the process is looking for Average Costs records from a different Product than the one that is being Processed.

This is due to a global variable in AverageCostAdjustmen.java file that has not been initialized again and uses the value from the previous Transaction.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00304173.0PR15Q3 closedTriage Finance While calculating Cost Adjustments the Process stops randomly stating that there is no avg Cost even if there is one 
depends on backport 00304183.0PR15Q2.3 closedTriage Finance While calculating Cost Adjustments the Process stops randomly stating that there is no avg Cost even if there is one 

-  Notes
(0079047)
hgbot (developer)
2015-07-23 17:16

Repository: erp/devel/pi
Changeset: 5e1331b3eaa7afdaeb0b7d5ab86b15097452adc6
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Jul 23 17:16:08 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5e1331b3eaa7afdaeb0b7d5ab86b15097452adc6 [^]

Fixes issue 30416. Initialize global variable each time to
make sure it does not uses values from a previous execution.

---
M src/org/openbravo/costing/AverageCostAdjustment.java
---
(0079063)
dmiguelez (developer)
2015-07-23 19:02

Code Reviewed + Tested in several Clients
(0079507)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-07-23 17:15 dmiguelez New Issue
2015-07-23 17:15 dmiguelez Assigned To => Triage Finance
2015-07-23 17:15 dmiguelez Modules => Core
2015-07-23 17:15 dmiguelez Triggers an Emergency Pack => No
2015-07-23 17:15 dmiguelez Status new => scheduled
2015-07-23 17:16 hgbot Checkin
2015-07-23 17:16 hgbot Note Added: 0079047
2015-07-23 17:16 hgbot Status scheduled => resolved
2015-07-23 17:16 hgbot Resolution open => fixed
2015-07-23 17:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5e1331b3eaa7afdaeb0b7d5ab86b15097452adc6 [^]
2015-07-23 19:02 dmiguelez Review Assigned To => dmiguelez
2015-07-23 19:02 dmiguelez Note Added: 0079063
2015-07-23 19:02 dmiguelez Status resolved => closed
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079507


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker