Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030415
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] 09. Financial managementmajoralways2015-07-23 17:002015-07-23 19:02
ReporterdmiguelezView Statuspublic 
Assigned ToTriage Finance 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision05e39d6804a7
ProjectionnoneETAnoneTarget Version3.0PR15Q2.3
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030415: While calculating Cost Adjustments the Process fails throwing a LazyInitializationException in Hibernate

DescriptionWhile calculating Cost Adjustments the Process fails throwing a LazyInitializationException in Hibernate
Steps To ReproduceThis issue happened in a Client and we were not able to reproduce it locally.

But, there was a LazyInitializationException in Hibernate in the CostingServer.java file, in the process() method while trying to read a list that was related to the Transaction object. It is necessary to refresh this Object before accessing the list.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0030413 closedTriage Finance While calculating Cost Adjustments the Process fails throwing a LazyInitializationException in Hibernate 

-  Notes
(0079049)
hgbot (developer)
2015-07-23 17:19

Repository: erp/backports/3.0PR15Q2.3
Changeset: 05e39d6804a7d37a60148b9b36c26bce7e02fc89
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Jul 23 17:05:01 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/05e39d6804a7d37a60148b9b36c26bce7e02fc89 [^]

Fixes Issue 30415. Refreshes Transaction Object before accessing to it
again to fix a LazyInitializationException Hibernate exception.
Also removes unnecessary save, since flush is done afterwards.

---
M src/org/openbravo/costing/CostingServer.java
---
(0079061)
dmiguelez (developer)
2015-07-23 19:02

Code Reviewed + Tested in several Clients

- Issue History
Date Modified Username Field Change
2015-07-23 17:02 dmiguelez Type defect => backport
2015-07-23 17:02 dmiguelez Target Version => 3.0PR15Q2.3
2015-07-23 17:19 hgbot Checkin
2015-07-23 17:19 hgbot Note Added: 0079049
2015-07-23 17:19 hgbot Status scheduled => resolved
2015-07-23 17:19 hgbot Resolution open => fixed
2015-07-23 17:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/05e39d6804a7d37a60148b9b36c26bce7e02fc89 [^]
2015-07-23 19:02 dmiguelez Review Assigned To => dmiguelez
2015-07-23 19:02 dmiguelez Note Added: 0079061
2015-07-23 19:02 dmiguelez Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker