Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030413
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-07-23 17:002015-08-20 23:16
ReporterdmiguelezView Statuspublic 
Assigned ToTriage Finance 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision1fa4c3218118
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030413: While calculating Cost Adjustments the Process fails throwing a LazyInitializationException in Hibernate

DescriptionWhile calculating Cost Adjustments the Process fails throwing a LazyInitializationException in Hibernate
Steps To ReproduceThis issue happened in a Client and we were not able to reproduce it locally.

But, there was a LazyInitializationException in Hibernate in the CostingServer.java file, in the process() method while trying to read a list that was related to the Transaction object. It is necessary to refresh this Object before accessing the list.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00304143.0PR15Q3 closedTriage Finance While calculating Cost Adjustments the Process fails throwing a LazyInitializationException in Hibernate 
depends on backport 00304153.0PR15Q2.3 closedTriage Finance While calculating Cost Adjustments the Process fails throwing a LazyInitializationException in Hibernate 

-  Notes
(0079045)
hgbot (developer)
2015-07-23 17:05

Repository: erp/devel/pi
Changeset: 1fa4c3218118fff2dfaf7c0958da14ffb934c1b7
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Jul 23 17:05:01 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1fa4c3218118fff2dfaf7c0958da14ffb934c1b7 [^]

Fixes Issue 30413. Refreshes Transaction Object before accessing to it
again to fix a LazyInitializationException Hibernate exception.
Also removes unnecessary save, since flush is done afterwards.

---
M src/org/openbravo/costing/CostingServer.java
---
(0079060)
dmiguelez (developer)
2015-07-23 19:01

Code Reviewed + Tested in several Clients
(0079506)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-07-23 17:00 dmiguelez New Issue
2015-07-23 17:00 dmiguelez Assigned To => Triage Finance
2015-07-23 17:00 dmiguelez Modules => Core
2015-07-23 17:00 dmiguelez Triggers an Emergency Pack => No
2015-07-23 17:02 dmiguelez Status new => scheduled
2015-07-23 17:05 hgbot Checkin
2015-07-23 17:05 hgbot Note Added: 0079045
2015-07-23 17:05 hgbot Status scheduled => resolved
2015-07-23 17:05 hgbot Resolution open => fixed
2015-07-23 17:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1fa4c3218118fff2dfaf7c0958da14ffb934c1b7 [^]
2015-07-23 19:01 dmiguelez Review Assigned To => dmiguelez
2015-07-23 19:01 dmiguelez Note Added: 0079060
2015-07-23 19:01 dmiguelez Status resolved => closed
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079506


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker